[Request] Lenovo RD450X BIOS IntelRCSetup unlocking

Hi there!
I have some refurbished Lenovo RD450X motherboard with BIOS ver RD450X231.
Initially in BIOS ver RD450X231 no proper nvme device support, so I found on csdn (https://download.csdn.net/download/yaozi88/88218852) RD450X602 BIOS ver with NVMe support.
The main problem is that I am using a pci-e nvme x8 adapter, that utilizes 2 nvme devices, but motherboard sees only one of them.
I dig into problem and found that I need to tune bifurcation to make my pci-e port from x8 to x4x4.

I’ve tried couple of things:

  1. changing access from Default to USER in AMIBCP do nothing
  2. removing suppression and changing access to 5 in UEFI Editor do nothing

I figured out some useful topics with similar problems:

I see the guide [Guide] - How to Bifurcate a PCI-E slot but not sure which IOU to change, because in the BIOS more than 2 CPUs with different layouts.

So, looks like my problem is exactly related to that: [Request] ASRock X99 Taichi - Adding IntelRCSetup to UEFI (BIOS) GUI - #8 by Eugene
But I didn’t understand how Sweet_Kitten found the offset where to add\change IntelRCSetup section in his guide.
I thing replacing something like Security with IntelRCSetup will be enough for me, but it’s better have it both.

I extract Platform and Setup modules and extract info (BIOS in archive too): Nextcloud

It would be great if someone explained how to find the right offset to replace or helped modify the BIOS.
I can upload new bios through embedded IPMI, so testing is simple enough for me.


Can’t access the files on google drive to let you know the offset. If don’t want to find it, you may use the following editor. [TOOL] UEFI Editor

Thanks for your reply.
Sorry, google banned file, new link: Nextcloud
Yeah, I tried to use UEFI Editor to change access level, but where to figure out the offset?
Sorry for stupid questions, I not much into that software, there are many hex numbers. I opened Platform module, but it’s not clear where to put Form Id of IntelRCSetup in Setup

There is a button to download .json file. You can obtain AMITSE container offsets from there.

Have a ready-made file as a quicker solution. 289.5 KB file on MEGA

1 Like

the IntelRCSetup’s ID is 43 D6 87 EC A4 EB B5 4B A1 E5 3F 3E 36 B2 0D A9 01. you can find it in hex editor ,and replace the first one(may be) with 0

and the method is in [OverPowered TONGFANG CyberPower Machrevo MACHENIKE - Unlocked BIOS Guide W/ Files]
Maybe it is right ,I’m not sure because I haven’t tried it yet

1 Like

Oh, I see, in data.json there are offsets, I miss that. Thanks!

  "menu": [
      "name": "IntelRCSetup",
      "formId": "0x1",
      "offset": "0x1B54"

Menu shows, some settings works fine.

Bifurcation still not working if I force select x4x4 or x4x4x8\x4x4x4x4 for pcie slots, but looks like it another issue for another thread

IF you realy want bifurcation, You can use this BIOS 超微450

1 Like

Wow, there a bunch of staff.
In 超微450.rom pcie bifurcation works fine!
Thanks for the baidu link


超微450.zip (5.0 MB)

Do you have a working link to the BIOS that doesn’t lead to Chinese sites where it is impossible to register and download anything?