[Request] Modded BIOS for Lenovo Thinkcentre m93 to enable PCIE NVME booting

Can anybody please help with modifying the BIOS to enable PCIE NVME support and booting? and also help with how to flash the BIOS with the new modified BIOS?

EDIT by Fernando: Thread title customized. Where is the original BIOS, which shall be modified?

FBJYDEUSA.zip (5.38 MB)

Sorry, attached.

Hi i just purchased Lenovo ThinkCentre M93P Mini-Tower Desktop PC

I have to eventually clean underneath the cpu of my desktop 8700 because i accidently put way to much paste and it got all over the pins on the motherboard this past Friday night (i was changing the heatsink and fan on the Dell and due to me being overly tired I managed to get paste all over the pins under the cpu) Yes i learnt my lesson not to play around inside computers while being overly tired. I will eventually clean the pins at a later date but in the meantime I have no computer so after reading reviews on here concerning the NVME m2 SSD i decided to order this PC off of Amazon for 300$ and it will be arriving by next weakened hopefully. Right now im using my Android phone as my means of communication.

Im going to be upgrading this M93 when it arrives

Below is what Im expecting …

Intel Core i5-4570 3.2GHz,
8GB DDR3 RAM No Name
256GB SSD No Name
No graphics card
Win-10 Pro x64

This will be my ultimate upgrade once it arrives in my hands

Intel Core i7 4790k 4.0GHz, If Turbo works on this mobo then it can rise up to 4.4GHZ
24GB DDR3 RAM Corsair Vengeance
GTX 1650 4GB {this will be placed in the Pcie gen 2 x4 slot}
Win-10 Pro x64

The last thing I want to do is place my Samsung 970 EVO Plus Series - 250GB PCIe NVMe - M.2 Internal to PCI Express Adapter with Heat Sink, this will fit perfectly within the Gen 3 PCIe x16 slot

Is there a video on how to do this? Perhaps if there is not can someone be kind enough to make one? Does everyone realize the newest firmware is now FBKTDEA 30 Jun 2020 on there site? Ok my question is this …I have no idea what firmware version this machine has and I have no idea on where to start even after reading over the instructions. Can someone break it all down and explain to me word for word I am a complete kindergarten student in school when it comes to this. I have never flashed a bios to start off with and I have never modified a bios or software in this field.

If anyone here can help it would be much appreciated "THANK YOU"

@D-man - see below

@MarkAnthony - What kind of paste? Many pastes are non-conductive now, so you may be OK with using it with paste in there. If not, use alcohol and a light hair art paintbrush to carefully clean it out.
As for tear down video, you’ll have to look in google or youtube etc, you should find one. Updating the BIOS, that is a simple exe you run, download on the Lenovo website

To do NVME mod - please do the following, you guys both may need hardware flash programmers (Ch341A + SOIC8 / SOP8 test clip with cable) if we cannot get past the errors at #2, I can’t remember if we have passed without programmer before or not
After you try #2, put system to sleep (S3, not hibernate), for two full minutes, then wake it up and try #2 only again to see if you get same error as first time or not (if not, let me know!)

If you have already modified the BIOS in ANY way, you will need to re-flash it back to factory defaults using factory method (NOT FPT)!!!
Additionally, please remove all BIOS passwords, disable secure boot, and disable TPM or Encryption if you have enabled. Do this before moving on to below

If you do not have Intel ME drivers installed, install them now from your system driver download page, then start over here after reboot.
Check your BIOS’ main page and see if ME FW version is shown. If not then > DOWNLOAD HWINFO64 HERE <

Once HWINFO is open, look at the large window on the left side, expand motherboard, and find the ME area.
Inside that section is the ME Firmware version. Take note of the version. (ie. write it down or get a screenshot)

Once you have that, go to the thread linked below, and in the section “C.2” find and download the matching ME System Tools Package for your system.
(ie if ME FW version = 10.x get V10 package, if 9.0-9.1 get V9.1 package, if 9.5 or above get V9.5 package etc)
> DOWNLOAD " ME System Tools " packages HERE <

Once downloaded, inside you will find Flash Programming Tool folder, and then inside that a Windows or Win/Win32 folder (NOT x64).
Highlight that Win/Win32 folder, then hold shift and press right click. Choose “open command window here” (Not power shell! >> * See Registry file below *).

If you get an error, reply to this post with a screenshot of it, OR write down the EXACT command entered and the EXACT error given.

((If “open command window here” does not appear, look for the “Simple Registry Edit” below…))

Step #1

Now you should be at the command prompt.
You are going to BACKUP the factory un-modified firmware, so type the following command:
Command: " FPTw.exe -bios -d biosreg.bin "

>> Attach the saved "biosreg.bin ", placed into a compressed ZIP/RAR file, to your next post!!! <<

Step #2

Right after you do that, try to write back the BIOS Region dump and see if you get any error(s).
Command: " FPTw.exe -bios -f biosreg.bin "
^^ This step is important! Don’t forget! ^^

If you get an error, reply to this post with a screenshot of it, OR write down the EXACT command entered and the EXACT error given.

Here is a SIMPLE REGISTRY EDIT that adds “Open command window here as Administrator” to the right click menu, instead of Power Shell
Double-click downloaded file to install. Reboot after install may be required

If the windows method above does NOT work for you…
Then you may have to copy all contents from the Flash Programming Tool \ DOS folder to the root of a Bootable USB disk and do the dump from DOS
( DOS command: " FPT.exe -bios -d biosreg.bin " )

Long story short…I decided not to mod the bios right now instead I found another way which is working great UEFI DUET Installer - REFIND boot manager "on a usb in the back of the pc running 24/7 no issues.

@Lost_N_BIOS sorry that it took me longer to respond back to you but THANK YOU so much for this site as my issue with booting nvme with windows has been solved another great way.

Also very short story on my Dell XPS Q87 LGA 1150, well i ended up destroying the pins with a rotating toothbrush (big mistake on my part). Okay so what happened was i used a 3rd party heatsink with specifically m3 8m screws i forgot to put springs and i ended up crushing the complete socket case and cracked the CPU in 2 places UNREPAIRABLE. Lesson learned never work on replacing parts when your tired or unsure of things.

Thank You so much for your well explained tutorial and time.

I am interested to try the modded bios of this for my M93p as well. Anyone?

Unlock bios, provide an spi dump with FPT tool and later u can flash it at ur own risk.

Lost as been away since January but follow is guidance.