[request] NEED unlock hidden settings for Fujitsu D3162-b1

Need unlock hidden settings for Fujitsu motherboard D3162-b1, for thermal FAN settings + memory timings or everything.
in chrome you must change adress http to ftp

@Bata Please post a valid link to your BIOS. I tried in IE and FF, neither worked with FPT or HTTP - no luck looking up the system using that model name at Fujitsu either.

I tried the following, none work in IE Or Firefox


I found it, at least I think, it's D3162-B1x on their site, what a terrible mess they have with download file links!

I assume it's this BIOS, neither matched what you gave above, so????
Link to main download - https://support.ts.fujitsu.com/IndexDown...3D-8947C6DBEF29

Link to actual BIOS download


Resulting file downloaded >> FTS_D3162B1xFlashBIOSUpdateDeskFlashInstant_V4653R1230_1119339.exe
Which extracts to this BIOS Update file >> D3162-B1x.R1.23.0.DFI.bup

Is that correct? I assume so, now it matches what you mentioned after I extracted it

And then finally, after all extractions... we arrive at a real BIOS file >> D3162-B1.UPD

* Edit please add at least one image of each BIOS section you can currently see (Main, Advanced, Boot, Save and Exit etc). Put in a zip or 7zip, thanks

Sorry for this, I found that FTS have file request on many servers (confusion), yes
it’s correct!
Version (Build/Date) Size Language
D3162-B1x - Admin package - Compressed Flash Files V4.6.5.3 - R1.23.0 (01/12/2014) 40.89 MB
D3162-B1x - Flash BIOS Update - Desk Flash Instant V4.6.5.3 - R1.23.0 (01/12/2014) 8.91 MB

screenshots of bios in second file "bios.zip"

I can see in AMIBCP v.4.53 many hidden settings(BIOS Administrator pack, file named as “D3162-B1.rom”), and parameters what I need to be visible in bios is:
1. Thermal Configuration > Platform Thermal Configuration
2. Memory configuration > Custom profile control

bios.zip (1.77 MB)

@Bata - Thanks for the images, and all the confirmation info too. Since this is Intel system, lets check this way to flash first, it will be easier than possibly using the stock flash tool

Are the two things you mention the only things you want made visible in the BIOS? Memory configuration requires that entire SA menu to be visible. However, if you want, I can limit it down to only the memory config pages I suppose
Thermal config may be possible to enable on it’s own, but it’s easier probably if I enable the hidden Admin page for you, then I believe from within that you can click into the thermal page.
At least that’s how it looks to me. We’ll figure it out, once we confirm best method to flash mod BIOS on your system.

On the hidden Admin page, I can see the hotkey is F11, can you test getting into that by using F11 instead of the normal key you use to enter BIOS.
Press F11 many times at startup instead of whatever the BIOS entry key is, and see if it takes you into a different BIOS, or a BIOS with Admin visible.
If not, also try pressing F11 from the main page of the BIOS (Or control+F11 on main page of BIOS - only) - don’t do that or FN+F11 at bootup, this can change power/fan modes on some systems and get stuck
If you can get into the hidden Admin this way, one less edit for me to make, unless you’d still want it permanently visible?

Download HWINFO64 and on the large window on left side, expand motherboard and find ME area, inside that get the ME Firmware version.
Once you have that, go to this thread and in the section “C” download the matching ME System Tools Package (ie if ME FW version = 10.x get V10 package, if 9.0-9.1 get V9.1 package, if 9.5 or above get V9.5 package etc)
Intel Management Engine: Drivers, Firmware & System Tools

Once downloaded, inside you will find Flash Programming Tool folder, and inside that a Windows or Win/Win32 folder. Select that Win folder, hold shift and press right click, choose open command window here (Not power shell).
At the command prompt type the following command and send me the created file to modify >> FPTw.exe -bios -d biosreg.bin

Right after you do that, try to write back the BIOS Region dump and see if you get any error, if you do show me image of the command entered and the error give >> FPTw.exe -bios -f biosreg.bin

If you are stuck on Win10 and cannot easily get command prompt, and method I mentioned above does not work for you, here is some links that should help
Or, copy all contents from the Flash Programming Tool \ DOS folder to the root of a USB Bootable disk and do the dump from DOS (FPT.exe -bios -d biosreg.bin)

No way to turn administrator BIOS scheme (f11, ctrl+F11,in bios F11 and ctrl+F11), first I’m confused with this BIOS, I have other board with AMI UEFI, everithing is there except hidden settings (easy change to USER) in AMIBCP, but Fujitsu “this bios” have different structure 12 raws only first visible, I’m looking how to add, for example,that raw visible,in this case > “platform thermal configuration” in advanced menu or some other submenu, like first raw (no name raw on picture 1.jpg).For HWINFO and ME FW version, It’s not so clear for me, need instruction with pictures.



@Bata - Thanks for testing F11 possibilities, I’m sure it’s some key combo with F11, just not documented since it’s meant to be hidden. Plus we don’t know if it’s meant to be pressed in BIOS from Main page, or from Advanced page (Try here too), or during bootup etc.
No big deal, I can make it visible by default anyway, just thought if you could get there via hotkey then less BIOS editing needed.

This Admin I mentioned, in case you didn’t see it, is inside the visible advanced menu, but it’s suppressed via setup module. platform thermal configuration will be it’s own menu section, I just have to enable it for you.

Yes, MANY BIOS differ, so it’s normal what you mention about visible/hidden etc between two different motherboards. Don’t use AMIBCP 4.53, use 4.55 instead

Here is where you find ME FW version with HWINFO64


what you see is what you get




@Bata - Thanks! Sorry, I forgot I noticed in ME Analyzer that this BIOS had “Compressed Fujitsu ME FW” so HWINFO doesn’t think it’s there due to this I assume. Glad you found it in the BIOS, good inspecting
I could see it in the stock BIOS, but that is not always what’s on the system, that’s why I needed you to somehow confirm.

Now, go back to post #4 - and at the ME System Tools link download V8 package and then follow the rest of what I mentioned.

OK work with windows (fptw.exe), failed with windows64 (fptw64.exe)

biosreg.zip (2.23 MB)

Yes, as mentioned FPTw.exe not FPTw64, I never mentioned to use that at all. Be very careful with FPT, follow only directions I give you, FPT can brick your board in one click.

Still waiting on info from rest of post #4 with flashing the biosreg.bin file back.

* Edit - have you modified and flashed in BIOS to this system before? I mean, have you edited the currently being used BIOS at all?

Everything is OK.
Original BIOS was ver 1.22, and updated by me to 1.23. Bios have reg. (not edited or hacked) or SLIC for win7 pro, which I’m using (x64)


@Bata - Thanks for confirming about not being edited.
I asked because I see a lot of errors and stuff in your dumped BIOS that’s not in the stock, but I see some of this is due to how Fujistu stores board specific data and other items so I think it’s normal.

Here is first quick test, to see if we can get Admin to show up in Advanced using one of three methods.
Test in the following order, stop at the first BIOS you see Admin submenu inside Advanced section (Don’t worry if it’s empty, only goal right now is make the submenu itself visible)
2. SetupFFO
3. SetupBCPB


sorry for late response. After flashing first file BCPO, There is menu Admin in Advanced setting, but no matter what I’m doing with thermal points, everything is like AUTO settings CPU fan is the same about 1420rpm.
Do you have any recommendations for setting up?

Desktop.zip (952 KB)

O.K. I found some simmilar settings on this page:

i want to thank the genius “Lost_N_BIOS” for patience and great help

@Bata - As mentioned, only goal with BIOS test above was to see menu or not, any settings within may or may not be working, many may be missing etc.
However, since you can see it all as I see in your images, it should be working. Nice to see that Admin did allow the jump to SA and Thermal config menus!

The thermal controls you show in image are only trip points (ie once reached - this happens) What is your goal with the fan, I don’t understand what you mean about it’s like Auto and fan only 1420 RPM
If you want fan to go faster, then lower the trip point 1 temp and or adjust it’s fans speed. I can better explain about this if I know what you’re trying to do.

There is submenu in advanced menu called smart monitoring, with 3 settings: auto, enhaced and disable. All 3 settings don’t react for manual Thermal settings, DISABLE is always to Full FAN speed,ENHANCE = about 1420rpm, AUTO = 9xxrpm. Perhaps missing MANUAL set under SMART MONITORING. In any way thank you very much.

Show me image of this, I don’t see any Smart Monitoring in the settings of the Advanced menu, also show me this submenu visible at root level of Advanced, so I can see where it’s situated in the submenu list

* Edit, I do see this, in System Monitoring
One Of: Fan Control, VarStoreInfo (VarOffset/VarName): 0x24F
One Of Option: Enhanced, Value (8 bit): 0x0 {09 0E 1B 08 00 00 00 00 00 00 00 00 00 00}
One Of Option: Auto, Value (8 bit): 0x1 (default) {09 0E 1C 08 30 00 01 00 00 00 00 00 00 00}
One Of Option: Disabled, Value (8 bit): 0x3 {09 0E 1E 08 00 00 03 00 00 00 00 00 00 00}

Is this what you mean? If yes, I’ll see if I can make a manual, but I doubt

* Edit @Bata - Disabled should always be full speed, enhance = Higher fan speeds, and auto = moderate - all as you have described?
[Enhanced]= Increase air flow and maximize CPU performance
[Auto] = Optimum temperature control and optimum CPU performance
[Disabled] = All fans set to full speed

So how is it not working, you mentioned three speeds, sounds normal and working to me.
I don’t know your issue or goal there, so don’t know how to advise you. I can change one of those to Silent, but no manual possible
[Silent] = Minimum fan noise, may reduce CPU performance

I wrote badly. Anything to change to the admin with the trip point and temperatures, has no effect on the fan speed under any setting of these three (enhanced, auto, disabled), in any case it is useless to set value to disabled, so if you can change in place of it (disabled) like enhanced parameters with a lower reaction temperature, so it starts earlier to accelerate rather than at 60+ degrees, where it is around 1600rpm, and I would like about 2000rpm for example.
I will post the image later from win if you want, but there is no in the bios real time hardware monitoring that gives the current state of temperature and speed, only in the windows app hardware monitoring