[Request] NVMe Support for a Dell Precision T7600

Hi @Lost_N_BIOS ,
Really thanks for reply to the PM!

I am trying to insert nvmexpressdxe_4 module into Dell Precision T7600 BIOS to boot from NVME PCIe drive, no issue in creating/assemble T76000A17.exe file, but while installing modified BIOS I am getting following error.
Error: Unable to read the BIOS update payload.

Thanks you for your help in advance.

Update 1:

Fyi… Do not have flash programmer.

Update 2: Just verified in system that it has 'SEVICE MODE" jumper on motherboard.

EDIT by Fernando: Since this is a specific BIOS modding request, I have moved this thread into the related Sub-Forum. Furthermore I have shortened the thread title.

@Lost_N_BIOS : Can you help?

@gana_000 - I thought I answered this a day or so ago, maybe in PM, or some other thread, not sure? Yes, he quoted me above, but not sure where from, must be PM

Please put on service mode jumper, reboot to windows 3 times, and on the third boot please do the following and send me file from step #1 (If any error at step #2, please show me image, or give me the error #)

If you have already modified the BIOS in ANY way, you will need to re-flash it back to factory defaults using factory method (NOT FPT)!!!
Additionally, please remove all BIOS passwords, disable secure boot, and disable TPM or Encryption if you have enabled. Do this before moving on to below

If you do not have Intel ME drivers installed, install them now from your system driver download page, then start over here after reboot.
Check your BIOS’ main page and see if ME FW version is shown. If not then > DOWNLOAD HWINFO64 HERE <

Once HWINFO is open, look at the large window on the left side, expand motherboard, and find the ME area.
Inside that section is the ME Firmware version. Take note of the version. (ie. write it down or get a screenshot)

Once you have that, go to the thread linked below, and in the section “C.2” find and download the matching ME System Tools Package for your system.
(ie if ME FW version = 10.x get V10 package, if 9.0-9.1 get V9.1 package, if 9.5 or above get V9.5 package etc)
> DOWNLOAD " ME System Tools " packages HERE <

Once downloaded, inside you will find Flash Programming Tool folder, and then inside that a Windows or Win/Win32 folder (NOT x64).
Highlight that Win/Win32 folder, then hold shift and press right click. Choose “open command window here” (Not power shell! >> * See Registry file below *).

If you get an error, reply to this post with a screenshot of it, OR write down the EXACT command entered and the EXACT error given.

((If “open command window here” does not appear, look for the “Simple Registry Edit” below…))

Step #1

Now you should be at the command prompt.
You are going to BACKUP the factory un-modified firmware, so type the following command:
Command: " FPTw.exe -bios -d biosreg.bin "

>> Attach the saved "biosreg.bin ", placed into a compressed ZIP/RAR file, to your next post!!! <<

Step #2

Right after you do that, try to write back the BIOS Region dump and see if you get any error(s).
Command: " FPTw.exe -bios -f biosreg.bin "
^^ This step is important! Don’t forget! ^^

If you get an error, reply to this post with a screenshot of it, OR write down the EXACT command entered and the EXACT error given.

Here is a SIMPLE REGISTRY EDIT that adds “Open command window here as Administrator” to the right click menu, instead of Power Shell
Double-click downloaded file to install. Reboot after install may be required

If the windows method above does NOT work for you…
Then you may have to copy all contents from the Flash Programming Tool \ DOS folder to the root of a Bootable USB disk and do the dump from DOS
( DOS command: " FPT.exe -bios -d biosreg.bin " )

Really thanks for your reply…
When I ran “fptw.exe -bios -d biosreg.bin” system went into hung state, I am not very sure if this is usual behaviour. Will wait until it responds back and keep you posted.

@gana_000 - You’re welcome! I’ve never heard of such a thing happening, so maybe just random glitch, or your system is not stable etc.
Hard reboot it and try again

Hi @Lost_N_BIOS , I tried multiple times system was getting hung all the time, so tried gathering system BIOS using a bootable USB with DOS.
used following command to generate biosreg.bin, and it was successful.
>fpt.exe -BIOS -d BIOSREG.BIN
And tried flashing the original bios by running following command and it was successfully flashed back to the system
>fpt.exe -BIOS -f BIOSREG.BIN

Enclosed original BIOS, please check and help me further.

BIOSREG.rar (2.05 MB)

@gana_000 - Hmm, maybe something in your OS, or old/wrong version of ME FW drivers causing issue in windows? Anyway, good thinking ahead and going to DOS
Here, in DOS flash this back via command following >> FPTw.exe BIOSREGNVME.BIN

*** WARNING * - This BIOS is user specific! If you are not user gana_000 at Win-RAID.com forum, DO NOT USE THIS BIOS!!
If you do, and you are not gana_000, then you will loose your Serial/Service Tag, Asset Tag, UUID, OG NVRAM, and possibly LAN MAC ID as well.
You have been warned!!!

If this system does not boot UEFI by default, then you may not be able to use NVME, I don’t see OS Type, or UEFI/Legacy boot modes or CSM related settings in the BIOS.
Ohh, I found image of BIOS “Boot Sequence” page, and you do have UEFI setting, so set that and you may be OK
You may need to crossflash to T7610 BIOS instead (Programmer tools suggested if you want to do that, but if you insist we can do with FPT and jumper in place, I think). You will also need SOIC8 / SOp8 test clip + SOIC16 / SOP16 test clip due to BIOS chips are different sizes.
Additionally, since this is 2012 system, you will only have PCIE 2.0, so speeds will be limited to nearly half of any normal NVME speed. May not be worth your time risking crossflash stuff, especially without programmer and clips in hand

Then follow all steps at #4 in the “This is what you should do” section of this guide
[Guide] How to get full NVMe support for all Systems with an AMI UEFI BIOS

Before you do that, I suggest you make NVME RAW, to avoid any possible issues installing, as outlined below.
Also, make your Win8-10 USB with Microsofts tool (ignore system requirements, it works for 7-10) - https://www.microsoft.com/en-us/download…s.aspx?id=56485

You can use diskpart in windows from OS (Direct from any CMD Prompt), or from installer ISO (press Shift + F10 on the first setup screen where you pick language)
Or from repair/troubleshoot options in the installer/setup. Remove all other drives, so you have only USB and target win10 drive. Then from CMD prompt do the following

1. Diskpart
2. List Disk << Here, identify what your target disk is by size/name etc, and make note of it’s #, you will use it’s # next - (If in windows, these #'s will match what you see the drives shown as in Disk Management) - Be sure you do not select your USB or main OS drive if in OS
3. select disk # << Here, instead of #, put target disk #, example >> select disk 0
4. clean
5. Exit

Reboot and run the installer again, then point it at the raw/blank drive, do not load any drivers or create any partitions etc, just select drive and click next

Or, you also have these non-BIOS options, to load USB Bootloader and boot NVME from that method
[Guide] NVMe-boot without modding your UEFI/BIOS (Clover-EFI bootloader method)
[Guide] NVMe-boot for systems with legacy BIOS and UEFI board (DUET-REFIND)

Or, you can use Samsung 950 NVME’s, those have built in legacy roms, so they can boot in legacy BIOS systems

Hi @Lost_N_BIOS , I was able to flash the BIOSREGNVME.bin using dos fpt.exe and installed OS on target NVME drive, I can see ‘Windows Boot Manager’ created under UEFI after installation, the problem is that its booting up only when main OS(old ssd) attached, without main OS/Old disks its not booting up it self, tried fresh installation second time without any other disks (only USB installer and target nvme drive) i was unable to start installation with enclosed errors, please check advise if we can go ahead with crossflash thing using ftp or any otherway around?




@gana_000 :
Did you ever do a look into >this< guide, especially into point 4. of the chapter “This is what you should do:”?

Was the disk RAW before you started the install attempt with all other drives removed? If not, do that again, then try again.
How did you make the USB Installer?

Do you have flash programmer + SOIC8 + SOCI16 clips? Is this your only/main system? Do you care about serial or UUID getting lost?

Hi @Fernando / @Lost_N_BIOS ,
“THANKS A LOT FOR YOUR HELP, SUPPORT & TIME” …I am now able to boot from NVME on Dell Precision T7600.

Sorry I did a mistake with my previous installations that I used Windows tool to create bootable OS disk (Thats completely wrong)
As you guys mentioned I followed Chapter-4 and used rufus to create bootable disk, that worked without issues and installation process was pretty smooth.
Thanks a lot again!!! Enclosed screenshot for your reference.
Need one more help to correct IME version in system, looks like I updated wrong one before I reached win-raid. If I keep the system Jumper/support mode, its booting up without any issues, when I remove jumper its giving error (ME_Error.PNG enclosed for your reference) and system not responding after that.

Actual ME version: 7.XXX to be flashed, please help with this thing.



I suggest and use windows USB/DVD tool, Rufus tends to cause more issues for users than it helps, but sounds like it works better for you that way
Yes, I linked that guide and mentioned to read step #4 before Fernando mentioned it too

Nice to see you are booting from NVME now! Do you have original FULL BIOS FPT dump, from before you did anything with ME FW?
If not, I will have to find and use another users T7600 ME FW, clean and update it, then show you how to flash it in.

Hi @Lost_N_BIOS ,

Unfortunately I did not dump full BIOS FPT Dump as I was more concentrated on BIOSREG. Please check if T7600 ME FW image is available.

Best Regards

@gana_000 - OK, I will find a good copy and clean/UPD for you
Meantime, please test and confirm this does not help!
First remove jumper and boot to windows 3 times if you can, if not, boot to DOS and FPT.exe -greset
Then if no luck, please wait

* Edit - @gana_000

Here, put on jumper and reboot three times. Then flash this via FPT >> FPTw.exe -me -f me.bin
Then, FPT.exe -greset

Then once in windows, use ME FW Update tool from the ME System Tools package, and latest 5MB ME 7.1 FW from this thread (you want Intel ME 7 5MB Firmware v7.1.92.3273) << DO NOT Flash this file with FPT!!!
Intel Management Engine: Drivers, Firmware & System Tools

Flash via CMD prompt from DOS or windows >> FWUpdLcl.exe -f update_file_name.bin

@Lost_N_BIOS , Tried rebooting to windows by without jumper, system went unresponsive three times, then boot into DOS and ran ‘fpt.exe -greset’ by putting jumper/service mode. same issue.


Tried your guide lines, got following error → Error 8193: Intel (R) ME Interface : Cannot locate ME device driver

Enclosed error screenshot for your reference. please advise

Hi @Lost_N_BIOS
Probably the UUID is missing in ME.BIN or in *_3273.bin file, due to that that the IME is not being enabled and not showing up in system Device Manager to update its relevant drivers at system level, may be due to that reasons I cannot update firmware with error code 1893— FWUpdLcl.exe -f update_file_name.bin… please help further.

Below information may be helpful to identify the issue…

C:\Users\Gana&gt;MEInfoWin64.exe -FWSTS

Intel(R) MEInfo Version:
Copyright(C) 2005 - 2011, Intel Corporation. All rights reserved.

FW Status Register1: 0x1E0401C5
FW Status Register2: 0x1B520000

CurrentState: Normal
ManufacturingMode: Disabled
FlashPartition: Valid
OperationalState: FW error when M0 with no UMA
InitComplete: Initializing
BUPLoadState: Success
ErrorCode: No Error
ModeOfOperation: Unsecured mode by H/W jumper
ICC: No valid OEM data, ICC not programmed
PhaseStatus: UNKNOWN


@gana_000 - UUID has nothing to do with ME and UUID is not in ME FW, this is like a serial #, only is cosmetic, nothing to do with functions and is generally stored in BIOS

Please do as I mentioned in the edit I made at post #14. Since ME FW corrupted, and you can’t install or run drivers if already installed, you wont be able to do the FPT stuff from windows and will have to use DOS Method.
For the FPT part, you will need jumper on and reboot three times first. For ME FW Update tool, jumper must be OFF and rebooted three times, and ME drivers must be installed in windows (or you can use DOS)

For FPT use DOS, and then once that is flashed in (and -greset again right after flash of ME FW in with FPT), then run ME FW update tool with the second file I mentioned that you must download from the provided link to forum thread
They must be done in this order, if you do both. You do not have to update ME FW to latest with ME FW update tool if you don’t want to, you can just do the FPT + File I uploaded, up to you.

Do FPT DOS First w/ jumper on, to flash the file I posted first, then ME FW update later (That can be done in windows, after FPT DOS, and after jumper removed)