[Request] NVMe Support for GA-B85M-D3H-A Mainboard

Hi Sir,

I’m using Gibabyte B85M-D3H-a motherboard, after reading all the instructions given in the forum (below URl) i did the bios mod to support NVMe as bootable devices and upgradated bios firmware. then i connected ADWITS PCI Express 3.0 + XPG Sx6000 pro M2 ssd on PCie express slot and started to install Windows 10 OS using UEFI : USB method and it booted for first time.
After next reboot imediately either bios front screen will get hung or after long time it will show blue screen error…i tried to reboot multiple times and changed bios setting and none of them works. if i booted Windows 10 from another sata SSD it will boot and previously shows the M2 pcie ssd disk but when i tried to boot m2 it will hung at bios or shows blue screen.

IMG_20200813_115848.jpg



so i came to conclusion to revert the bios to orginal verion and changed it but now m2 ssd is not even detected from windows 10. kindly help a way to fix this issue. from the forum i understood even without Bios mod also PCIe m2 sdd will detect on win 10 but in my case its not showing

EDIT:
@Lost_N_BIOS - Could you please help to modify below bios to support m2 PCie as bootable.
https://www.gigabyte.com/in/Motherboard/…support-dl-bios

EDIT by Fernando: Thread moved into the “BIOS Modding Request” Sub-Forum, posts merged and thread title customized

That’s correct. As long as the PCIe m2 SSD isn’t recognized in Windows 10 there’s no need for any Bios modification. Re seat SSD in adapter card and adapter card in PCIe slot until SSD is recognized. The try to read/write some GB test data and if that works without errors you might try to install an operating system.

(Since you already modified a bios- why didn’t you attach it?)

@BHARATH :
Welcome to the Win-RAID Forum!
As you have realized, I have merged your 2 posts (to save space), moved the thread into the better matching “BIOS Modding Requests” Sub-Forum and customized the title.
lfb6 is right - why didn’t you attach your modded BIOS?
Which BIOS do you want to get modified? Your link offers various BIOS versions for your mainboard.
By the way - the insertion of the NVMe module into an AMI UEFI BIOS is very easy. >Here< is the guide.
Good luck!
Dieter (alias Fernando)

Hi @lfb6 , @Fernando , Thanks for your reply… sorry i forgot to attach modded bios, Please find the same below. i modified the bios using uefitool.exe tool with small nvmexpressdxe_4 file. since i had an issue on editing using mmtools. request your help to modify this file.

https://download.gigabyte.com/FileList/B…5m-d3h-a_f2.zip
modded bios link - https://drive.google.com/file/d/10C2_clw…iew?usp=sharing


That’s correct. As long as the PCIe m2 SSD isn’t recognized in Windows 10 there’s no need for any Bios modification. Re seat SSD in adapter card and adapter card in PCIe slot until SSD is recognized. The try to read/write some GB test data and if that works without errors you might try to install an operating system.

(Since you already modified a bios- why didn’t you attach it?)




i have removed and reconnected the adapter multiple times on both PCIe x16 and x4 slot both it is not recognizing, suspecting that due to revert of original version it seems that it is not detecting or any issues on bios settings. kindly provide your insight… from the Bios option, csm is disbled and os is configured has other OS.

Capture.PNG

@BHARATH :
As far as I can see, your modded BIOS seems to be fine and should give your Intel 8-Series chipset mainboard full NVMe support, if you follow my guide regarding the installation of Win10 in UEFI mode.
Tip: Set CSM within the BIOS to "Enabled", but allow the loading of EFI BIOS modules while booting the computer. Once the OS is up and running fine, you may try to set CSM to "Disabled" and look what happens.

@Fernando :

Thanks, Let me update my mod bios and see whether it able to detect the Pcie M2…

@BHARATH How did you check if Windows 10 does see the drive? It should be listed in device manager ‘disk drives’ and the Controller should appear in ‘Storage controllers’- see picture.

1.jpg

@BHARATH - If mod BIOS attached at #4 does not brick, then it would be NVME compatible.
You just need to follow all steps exactly at #4 here in the “This is what you should do” section - [Guide] How to get full NVMe support for all Systems with an AMI UEFI BIOS

Make sure NVME is RAW or GPT initialized, it cannot be MBR initialized. If you are not sure how to make RAW >>

To make NVME RAW - You can use diskpart in windows from OS (Direct from any CMD Prompt), or from installer ISO (press Shift + F10 on the first setup screen where you pick language)
Remove all other drives, so only the NVME is there, and any other disk you will recognize by size/name etc - so you don’t accidentally wipe wrong things.

At CMD Prompt >>

>> Diskpart
>> List disk << Here, identify by size, and then note the number which disk you will be wiping to raw here (If in windows, this #'s will match what you see the drives shown as in Disk Management) - Be sure you do not select your USB or main OS drive if in OS
>> Select Disk # << here, replace # with NVME # you want to wipe to raw.
>> Clean
>> Exit

@Lost_N_BIOS @lfb6 @Fernando : I have updated the mod bios #4, as mentioned earlier, after upgrade its struct at front screen after multiple try i entered bios and changed first boot as my other samsung ssd disk which takes 5 mins to load os completely , i checked the devmgmt.msc where its showing nvme express controller but not showing the disk.

1.PNG



so i checked on the eventlogs, could see disk1 is getting removed (Pfa Screenshot below) while booting itself so, i decided to check the disk status by booting UEFI:win 10 image from USB and on the disk section it shows disk1 as 0 bytes. yesterday before os installation on m2 SSD, i created gpt partition with two disk. below are my bios settings.

2.png



IMG_20200815_015230.jpg

IMG_20200815_015252.jpg

Since both NVMe controller and disk are on the m2 disk your setup seems OK, but you might simply have defective m2 disk. Only other solution would be another (possibly raid-) driver ‘catching’ the disk and hiding it to be configured in a Raid or as Caching/ Optane …memory. But heard of things like that only for much younger setups.

What other disk-/ Raid drivers are in the system?

Oher fancy things like Intel Rapid Start technlogy or something that sounds similar?

How does the system boot with the modded bios when the NVMe disk is removed?

@BHARATH :
What does the Disk Management show regarding the NVMe SSD? Which are your BIOS settings regarding the SATA mode?
Why don’t you just follow >this< guide by unplugging all other HDDs/SSDs except the NVMe SSD, booting in UEFI mode off a Rufus prepared Win10 USB Flash drive and letting the Win10 Setup create the desired partitions onto the NVMe SSD?

@lfb6 :
On Bios settings intel smart technology was already in disable state, from os level found intel smart technology is installed so now i uninstalled & rebooted but still PCIe\M2 is not detectable. also for sata i’m using only ACHI Mode.

IMG_20200815_103359.jpg

4.PNG



@Fernando :
I follow all the steps upto 3 and on 4th step-Installation of the OS onto the NVMe SSD: formatted with FAT32 using Rufus didn’t make the USB bootable since my os iso image is more than 4.5 GB so i decided to format with NTFS and started the installation. After the next reboot it didn’t booted up…Did i done it wrong?

yes i disconnected all the drives when installing the OS. rescan also didn’t work, i suspect it may be partition on M2 is got corupted.

5.PNG



EDIT by Fernando; Unneeded fully quoted, but not addressed posts replaced by directly addressing to their authors (to save space)

@BHARATH :
If you format the USB Flash Drive using the NTFS file system, you cannot boot off it in UEFI mode. So you have to use the FAT32 file system for that purpose.

@Fernando : Let me try to install it using Fat32 and keep you updated.

@BHARATH - Use Windows USB/DVD tool to make your USB ISO - problem solved
https://www.microsoft.com/en-us/download…s.aspx?id=56485

Ignore it only says Win8, it’s OK, just used it the other day for Win10 2004 ISO


Which disk is “Disk 0” shown in your picture?

If this disk is not your M2 devcie: Was the M2 device connected when you took the screenshot?

Disk 0 is my samsung Sata ssd, and i have connect Pcie/M2 as well which is not detected.
sorry forgot to mention disk details, Disk0 - 250 GB Samsung sata ssd, Disk 1 - PCIe/M2 1 tb xpg adata which is not detectable

@Lost_N_BIOS @Fernando - As i mentioned #12 before, since my iso is more than 4.5 gb rufus tool itself not showing fat32 option so i used microsoftmedia creation tool which write iso to my usb using fat32. I disconnected all other drive except PCie/M2 and started to boot from usb and on disk partition it is showing as 0 bytes. not sure what could be the issue.
https://www.microsoft.com/en-in/software-download/windows10

Also on bios front screen, windows loading symbol appears and loading. One more thing is when i started to do the mod bios two days back, initially MMTool 4.50.0.23 had issue shows a incorrect table (i didn’t captue the error) when i tried to insert NvmExpressDxe module so i tried with UEFITool_v0.28.0 (found Pad Files on my bios) and inserted only the small NvmExpressDxe modue since another module didn’t accepted the size…will it cause any issue?

could you please help to insert NvmExpressDxe.ffs on the below package so that i will tried to flash bios again and check.
https://download.gigabyte.com/FileList/B…5m-d3h-a_f2.zip

6.png

IMG_20200815_122130.jpg

IMG_20200815_122404.jpg

@BHARATH :
It is the size of the INSTALL.WIM, which prevents to set the "File System" of the bootable USB Flash Drive to FAT32.
Solution: Get the desired original Win10 Image, which contains an INSTALL.ESD. It contains all data of the INSTALL.WIM, but in compressed form and requires much less space.
Another question: Is your NVMe SSD untouched or did you or someone else already use it for any purpose?

@BHARATH In this stage of installation the detection of the M2 disk is not bios related. And if the disk shows up it means that the controller on the M2 device is recognized correctly by your system. So the problem (disk yes, but sisze = 0) is on the M2- device between controller and storage chip. Should be warranty on this M2 SSD?

But since the M2 device is seen (NVMe controller recognized) but not only ‘Free space’ but also ‘Total size’ is reported as ‘0 MB’ and there’s no disk shown in ‘Disk management’ or in ‘diskpart’ …

No, it is a new PCIe and M2 sdd which i brought last week. two days back i installed windows 10 OS on it.

yes it has warrenty. i’m planning to replace it.

Just to clarify - win10 iso that i had previously doesn’t had bootx64.efi file due to that uefi boot failed so i downloaded another windows 10 iso from torrent site and using rufus-3.11 with gpt+NTFS i started to install os on my m2 ssd disk. after the successfull installation, i installed my antivirus and it found some virus on it and asken for reboot… after reboot it cleaned some files and when i started system next day, i didn’t bootup and started to have trouble.