[Request] NVMe Support for GA-EX58 UD3R

The BIOS may not show the NVMe SSD, but it has detected it (otherwise the Device Manager wouldn’t show it).
Now you can try to get Win10/11 installed onto the NVMe SSD by booting off an USB stick with the OS Image on it (after having removed or disconnected all other disk drives).

1 Like
  1. Unzip the package named NvmeOpRom and customize the HardwareIDs, which are within the Option ROM named NvmeOpRom.bin, by using the tool named OpRomCfg.exe. You can check your work by opening the original and the customized Option ROM with any Hex Editor (I prefer the tool named HxD).

Can you explain this explanation a little bit because I can’t open the NvmeOpRom.bin file (OpRomCfg.exe). I modded it without making any changes, maybe because the required module is loaded. Also, thank you for your time, by the way. the only problem is just adding modules to the nvmeoprom.bin file.

I knew it all along that he didnt changed the HW ID…

You need to use the OpRomCfg.exe and set the ID of the controller on the NmeOpRom.bin, in this case yours is VEN_15B7 DEV_5019 (from the WD Green WDS480G2G0C, you reported earlier), save it and this is now the correct file to insert in the bios.

1 Like

I understand bro. OpRomCfg (file name> (vendor id) <device id)

I’m overlooking this. Sorry for my first time dealing with bios stuff. I was looking to open the nvmeoprom.bin file with the (hxd) program to edit it, and where to write the device ID :slight_smile:

Option ROM modules like the file named NvmeOpRom.bin can only be opened by using an Hex Editor like HxD. You can download it from >here<.

If you fogot to customize the NVMe Option ROM to make it compatible with the NVMe Controller of your specific NVMe SSD, you should do it. Otherwhise you will not be able to boot off the NVMe SSD.
This is how the related content of the NvmeOpRom.bin looks after having successfully customized it (corrected by me on 05/18/2023):

The “Little Endian” Code you can see (B7 15 19 50) is misleading, but correct (look >here<).

Note: Since you obviously have inserted a wrong (not customized) NVMe Option ROM, you have to redo the integration of the module from scratch by using the original BIOS as source. To avoid a mix-up I recommend to delete the previously modded BIOS.

1 Like

I added a module to the NvmeOpRom.bin file. I didn’t delete anything from it. Then I added it to the original bios. I installed with usb flash. NVMe ssd didn’t show up in boot options. If I install windows 10, you say it will appear on boot. Did I get right?.

By the way, I was using clover boot usb with nvme ssd windows 10 installed for 2 days with original bios. so NVMe ssd has windows ready. Is it normal that the nvme ssd still doesn’t show up in the boot options?

Yes, it doesn’t boot, perform a CLEAN UEFI Win10 OS installation.
Clover is a BOOTLOADER

Due to the missing NVMe EFI module I doubt, that an installation in UEFI mode will work.

1 Like

EDIT: You are right Fernando… how can it be possible if its legacy bios only with the disk controller, ignore my foolish statement… :face_with_peeking_eye: :upside_down_face:

I prepared windows 10 usb flash to NVMe ssd in 3 different ways, I tried, but still can’t install windows 10.
I get the error (We couldn’t create a new partition or find an existing partition).

HDD, sata hdd, I tried to remove all other storage devices. Bios mode (AHCİ)

Where is the problem?

Although I don’t know the exact reason for your current problem to get Win10 installed onto your NVMe SSD, I suspect, that it has something to do with the content or with the connection of your NVMe SSD to your mainboard.
Provided, that the BIOS modification has been done correctly and the modded BIOS has been properly flashed, you may have to create the boot sector (“Master Boot Record”) on your NVMe SSD manually. >Here< is a Guide about how to do it.

Here Try this bios.
And reinstall windows (without Clower). Normal windows installation.
GA-EX58-UD3R rev1.0.rar (586.2 KB)

Probably you were wrong. Not (7B 15 19 50) but (B7 15 19 50).


You are absolutely right - it was my own typo while entering the OpRomCfg command, which has lead to the misleading HxD picture I had posted >here<. To avoid future problems I have replaced the picture by a corrected one. Fortunately I did not share my wrongly modded Option ROM and BIOS files.

Thanks for having had your heads up!!! :+1:

Thank you very much, I’ll try right away

Which one should I make the file system in the picture for NVMe ssd

Fat32 of NTFS ?

The file system of the NVMe SSD should be NTFS, whereas it is better to choose FAT32 for the Rufus USB stick.
The boot sector of the requested system drive has to be MBR (GPT wouldn’t work with your mainboard).

Many thanks to everyone who took the time to care. everything is ok. seamless. thanks to you :slight_smile: @Fernando @Dagal

one more thing. If I want to add a new module, can I use it if I remove the nvmeoprom.bin module in the bios I am using and add it to it and integrate it into the bios again.

for example;
opromcfg nvmeoprem.bin (xxxx) (xxxx) enter?

I am glad, that you finally succeeded and now can boot off the NVMe SSD.
Enjoy it!
If you should ever find another (better) NVMe Option ROM module, you can replace the current one by it and reflash the modded BIOS.

1 Like

Dear @Fernando and @MeatWar
Your patience and effort is Amazing.
If it were me my first answer would be
“I’m Not a Kindergarten Teacher”
Even a stone would crack against your patience.

This brother is from my country.
I have been trying to teach these, that is, these lazy people called Z generation for years, but the result is a huge ZERO(0)
We were young too, and while our older brothers were dealing with something in front of us, we would look at the words that would come out of his mouth and take notes immediately.
They would not knowingly give us confidential information.
Ahahaha… :rofl:
But we efforts would eventually figure it out.
This brother is very reluctant and wanted everything to come to him.
It’s obvious from the beginning that he can’t do this job.
But he finally succeeded with your great patience and dedication.
Now let me ask him a question right now:
Can you re-add another NVMe SSD module to the same bios?
For example:
Add these hardware IDs and let’s see.
Why did I want this?
Because I believe he has already forgotten the practice that you taught him.
Ahahaha… :laughing:
Sincere and sincere thanks to both of you for your help.
It’s good to have you and it’s good that such a platform exists.

1 Like

Guidance here: Experimental Modded VMware-NVME Option ROM for AMIBIOS8 Core ( Legacy ) - Special Topics / NVMe Support for old Systems - Win-Raid Forum (level1techs.com)

[Experimental] NVMe Option ROM - BIOS/UEFI Modding / BIOS modules (PCI ROM, EFI and others) - Win-Raid Forum (level1techs.com)
Good luck.