[Request] NVMe Support for MSI BigBang Xpower II

Hello Fernando and everybody,

I am having a hard time to figure out how to mod the bios for the MSI Big Bang Xpower II to support NVME.
Edit, I managed to extract the bios, attached with update modules.

Is there someone who can assist me, maybe that already has the same board?

Thank you so much for the support.

E7737IMS.rar (5.14 MB)

@uazzamerican :
Why don’t you do it yourself? The insertion of the NVMe module is very easy, if you follow >this< guide and use the MMTool v4.50.
This is the picture after the successful modification:


Thank you Fernando,
Will try to do that.

Only thing is that MMTool does not allow me to change the extension of the file to the same of the bios.
I am forced to use the .fs extension.
Is it ok? Can I flash the new bios as it is?

@uazzamerican :
You should rename the modded BIOS before trying to flash it. Give it the same name (incl. extension) as the "pure" original BIOS file.

Hello Fernando,
I followed your simple instructions and flashed the modified bios.
But it seems that the board is still not able to boot from the nvme pcie card/ssd.
It is a Toshiba-OCZ RD400, the OS already has the ocz nvme driver on it.
But the problem is at bios level I think.
The nvme ssd is recognized as "Pata:"
If I use it as boot device it won’t load the SO.
If I boot from another sata drive, it is correctly recognized.
So I assume something is wrong with my modding attempts…
Any clues?

Hello Fernando,

I tried another guide I found on youtube, using UEFITool, but the outcome is the same.
I can see the nvme SSD listed as “Pata:”, but I cannot boot from it at all.
I can only use it as storage.
Am I missing something? I am sure I added correctly the NvmExpressDxe_4.ffs file and saved it on both procedures, but I am clearly doing something wrong.
Could you assist?

Here attached the file I flashed.

E7737IMS.zip (5.51 MB)

@uazzamerican - Seeing PATA in BIOS means you did the mod successfully and have flashed in the MOS BIOS. YOu cannot boot to PATA, you have to install Win10 first, then you can or PATA will be replaced by "Windows Boot Manager"

Clean the NVME so it’s RAW first, then do the Win10 install. From other OS, with NVME as spare drive, look in disk management, make sure you have correctly identified which drive by # is the NVME Drive. Then do the following
CMD Prompt >>
List Disk << Here, identify the NVME by size or name and note it’s # for next step
Select disk # <<< Here, in place of # put your NVME drive # you identified from Disk Management, or in above step, you can see NVME drive # too if you recognize by name or size etc

Then shut down, remove all drives but the NVME and do the Win10 install. Follow all steps here in #4 in the “This is what you should do” Section
[Guide] How to get full NVMe support for all Systems with an AMI UEFI BIOS

Oh crap…

So this is what I am doing wrong.
I was supposed to be able to migrate my win7 partition from the sata HD to the nvme just like I did with X99…
The point of all my efforts was to use my win7 on this x79 board with nvme…

Now I understand it is impossible.

Last question, maybe some other nvme disk can do the trick? The Samsung 850 ?
Or it is the same story?
Just to put an end to my project as it is, thank you.


Guess my only hope is this guide:

[Guide] How to migrate Windows 7 64bit boot drive from MBR SATA to UEFI NVMe without data lose

Hello all, just an update, I was successfull on keeping my Win7 installation migrating it on NVME disk with the guide above.
Thank you all.

Unfortunately, it seems that the board refuses to boot with the E5-1680-V2 chip (I know for sure it works beacuser it boots on a X79A-GD65) even though I updated the microcodes with ubu.
Again, maybe I did a mystake or the microcode updates do not take into account Xeons?

I know this mainboard should handle it even if on MSI site it is not specified, I see lots of entries with this mainboard and this cpus…

@Lost_N_BIOS could you help me?
I am not able to see if the proper microcode is ther or not…


I am trying to do it myself, I found the microcodes here:
[OFFER] Intel CPU Microcode Archives
It seems that the microcode I need is 306E4, ubutool allows me to inflate the engineering sample microcodes of 306E3 so it basically lacks 1680-v2 support.

If I try to hit “m” during the update,pointing to any of the file of the proper folder, the program says that it cannot find the file…

I am sure I am missing something, but I would thank you if you give me some support.



A quick update, I was able to do everything, it seems that my version of ubutool was simply outdated.
Thank you so much to everyone, now I can enjoy my unlocked 8 cores Xeon with nvme.

bios.zip (5.51 MB)

@uazzamerican - This is only ways I know of cloning WIn7 to NVME, here’s how I do that personally - Installing Clean Win7x64 on M2.2280 PCIe Gen3x4 SSD A-DATA SX8200 Pro
And here is Fernando’s method - [Guide] How to get full NVMe support for all Systems with an AMI UEFI BIOS (330)
Or, did you get it with the method you linked, not sure?

Stock BIOS 28 already contains proper microcode for E5-1680-V2 (306E4) - Why are you mentioning 306E3?

Ahh, so looks like you got it sorted out? If yes, great! What did you have to do for the Xeon to work, in case someone asks later, thanks?


basically I did nothing new, just followed both the guide to insert nvme drivers into the bios, updating it with the latest ubutool on this forum and followed the guide here:

[Guide] How to migrate Windows 7 64bit boot drive from MBR SATA to UEFI NVMe without data lose

And my win7 installation have been successfully migrated to nvme disk without losing anything.

My biggest problem was the cpu, it seems that the last bios was not able to recognize it, don’t know why, so I needed the latest version of ubutool.
Mine for some reason do not update X79 microcodes, maybe it was simply defective.

Nice to see you got Win7 move all sorted out then!

If you need microcode update let me know, I can do for you

hi all,

uazz so if i did understood you flashed your bios BigBang XpowerII and now you can boot from it ?.

Thank you.

Hello everyone !

I have had an MSI BIGBANG 2 motherboard on my main PC since 2014.

I recently bought a Samsung 970 Plus NVMe M2 on an Aqua Computer kryoM.2 evo PCIe 3.0 x4 adapter and wanted to install Windows 10 there.
Unfortunately, I then had to find out that the MSI BIGBANG 2’s BIOS does not recognize the NVMe M2 as a hard drive and cannot create it as a start option.

Now the question of whether the modded bios provided by uazzamerican - bios.zip - brings changes and has already been tested by someone else?

Thanks in advance for an insightful answer.

MfG the Nisel


U should use the option @username in order to that user get a notification

@Nisel : Welcome to the Win-RAID Foum!
If you are unsure regarding the BIOS, which had been modded by uazzamerican, why don’t you try the BIOS modification yourself? For users like you I have written >this< easy to follow step-by-step guide. To be sure, that you have done the insertion of the NVMe module correctly, you can post a request into the linked thread and attach your work (and the original BIOS as well) as *.zip archive. Then you will get an appraisal by an expert, whether your modded BIOS is ready for being flashed or not.
Good luck!
Dieter (alias Fernando)

Hello all.
Sorry for the late response.
The file bios.zip attached worked flawlessly with nvme (and Xeons).
That said, I cannot take responsibility for any other user that will try the bios of course.


Hello, everyone !

First of all, thank you very much for your replies.
Especially to uazzamerican that he gave another confirmation that his bios seems to work with NVMe.
I will play it the days and hope that there will be no "complications".
In any case, I will contact me again afterwards to be able to submit the status.

MfG Nisel

made with google translator :slight_smile:


Short question for you.

To flash bios with your bios, do I have to proceed as specified here?

[Guide] How to flash a modded AMI UEFI BIOS

How to dump the BIOS Region and to flash a modded AMI UEFI BIOS
by using the Flashrom tool
(valid for mainboards from all manufacturers)

When I do it via the M-Flash, it hangs up.

Unfortunately, I am not that professional in this field.

Thanks in advance for an insightful answer.


@Nisel :

According to my knowledge modded MSI BIOS files can be properly flashed by using the M-Flash tool, but the modded BIOS file should have the same name and extension as the original one.