[Request] ReBAR for 2700X CPU on Gigabyte X470

Hello

I see Gigabyte is the only brand that does not show ReBAR option of X470 chipset (Gigabyte X470 AORUS GAMING 5 WiFi), with Ryzen 7 2700X CPU. It should already work for Ryzen 3000, according to Gigabyte.

Is it possible please to modify the UEFI from Gigabyte and just enable this option ? I assume the option is already there, as the current UEFI has the needed AGESA v1.12.0.1, and shows the “Above 4G decoding” option, but hides the ReBAR option for CPUs below Ryzen 3000 series.

I remember one of the UEFI updates from Gigabyte has introduced UEFI “capsule”, which likely means signed firmware, but maybe older versions would still work ?

My current UEFI is American Megatrends v2.20.1271 (07/20/2022, ver F63c)

My first post here so I am not sure how a mod request would work, but I am also happy to make the changes myself if I can get the proper instructions about what to download and what to modify to re-package my UEFI if that works…

Needless to say, this would help me so much with my new Intel Arc A770 GPU, which is known to depend on ReBAR support for proper performance.


Thank you,
Timothy Madden

Yes the F63c bios has the strings in Peripherals and in PCI Subsystem Settings

  • Re-Size BAR Support: Disable Disable
    If system has Resizable BAR capable PCIe Devices, this option Enables or Disables Resizable BAR Support(Only if System Supports 64 bit PCI Decoding).

Now search the forum the proper way to mod it and flash it, dont ask me, no time for it, your task only or wait for other users.

EDIT: How about starting by using the search box on the forum: x470 unlock

1 Like

Anyone can give me some pointers how is this supposed to be done ?

did you have your CSM disabled yet? usually the Resizable Bar needs Above 4G Decoding to be enabled, and it would be able to be shown when CSM is already disabled in the bios

CSM is disabled.

I understand all other brands behave exactly as you say, except Gigabyte, for Ryzen 2000 series

I tried to modify my UEFI image from Gigabyte with ACMIBCP to change Access from “Default” to “USER”, and flash my modified UEFI image using modded Efilash 0.74 from this forum.

When I run Efiflash if finishes in a couple of seconds and automatically reboots, but the new image is not flashed. I still have the original UEFI. What am I doing wrong ?

I see Efiflash 0.87 (modded) is supposed to work with pre-capsule versions only.

Does this mean I can not modify the latest UEFI image, even with moded Efitool, and that is why I can not flash it ? Am I stuck with the 2018 UEFI from Gigabyte ?

Next,

I also tried to set up grub-mod-setup-var, but I can not get it to run. When I replace bootx64.efi on my EFI partition, I get eithe a boot error “operating system not found”, either Windows boots normally. But I can not get to the grub console to run the modded setup_var command.

Gigabyte X470/ X570 Aorus BIOS mod thread - BIOS/UEFI Modding / Offers: Already modded special BIOSes - Win-Raid Forum (level1techs.com)

EDIT: Better ask him in that tread, in Intel we can bypass it with the Intel FPT tool but not in AMD as there is no ME FW engine on it… its AGESA.

Using AfuEfix64.efi from Ket X470 thread above still shows a “Loading capsule…” message with my modded UEFI, and then Error 18 - Secure ROM verification failed.

I do not see any “Aptio capsule” in UEFITool (for the original or the modified UEFI), and loading the modified image in UBU also shows no option to “Remove capsule”…

Is there a way to remove and bypass capsule for Gigabyte UEFI images ?

I also tried to edit the ReBAR byte in the UEFI varstore using setup_var_3 command in the patched GRUB, as described in thread for ReBAR DXE Driver for setting hidden 4G Decoding option". But it had no effect as well.

I got it working by:

  • manually updating the flags byte from the hex dump screenshot from lordkag (to flash the image with Gigabyte Qflash)
  • using the Resizable BAR DXE driver described on this forum

So I did not “unlock” the Gigabyte ReBAR option, but the DXE driver works my Intel Arc GPU has resizable BAR now.