I need help with BIOS mod for Asus ROG MAXIMUS X HERO (non-WiFI model) please. Recently I saw Intel i7-8086k Processor supports up to 128GB RAM now (…o-5-00-ghz.html). Currently, I’m running a system with ROG Maximus X Hero with i7-8086k & 64GB RAM and would really like to use 128GB. I couldn’t find any BIOS update on Asus website mention about 128GB RAM support.

Can anyone please tell me if this latest BIOS from their website has support for 128GB RAM?…

If not, would someone experienced please help me to mod one? I would be so grateful. I read here it is possible but I’m a noob when it comes to BIOS mod (Make 22nm PCH LGA1151 motherboard like Z370 compatible with 128GB RAM).

Thanks very much.

@k6808_8086k - I looked, but I am not 100% sure, since that guide/info does not show images, so I’m not exactly sure I am looking at same thing, due to his use of … instead of showing example in images.

This is what I found at one of (13) the 15x instances in ONE of the modules with that GUID in your BIOS
C7 86 7F 25 00 00 00 80 00 00 8B C2

However, this does not follow exactly what he mentioned ( “C786…000000…00”,"…" is any HEX value.), so may not be correct place/code etc.
I say that, because in his example, the last … is not followed by 00 in your BIOS. But, that is the only instance where I find the C7 86, follow by 8000 (or 0001 if it was there, which it’s not)

Thank you very much for looking into it promptly @Lost_N_BIOS . From your post it looks like they didn’t enable support for 128GB yet!

@dsanke would you please be able to help me on this? I’m really looking forward to get this working without getting a Z390 motherboard.

You need a SPI programmer to flash modified BIOS, because I need modify the Flash Desriptor, to set ME to disabled, which usually is not able to flash without a SPI programmer.
I can help you modify a BIOS this weekend.

@dsanke Thank you very very much. Yes, I can flash with SPI programmer. I have one ch341a device. Used it few times on my Clevo to flash your BIOS after messing with the settings and some other devices.

@dsanke - Thanks for jumping in to help! So what edits required for this then? You didn’t mention FD edit, or ME Disable in your original thread about this. Can you please update your main thread about this, to show what FD edit is needed (I already know how to disable ME FW)

*Edit - I see now, you have updated that post. So ME FW disable via HAP bit all that’s needed, good to know, I already know how to do that.
So, this is a must to use 128GB, loss of everything related to ME Functionality because you have to disable ME FW? If yes, this is not ideal, but I guess it’s still a mod and would be useful to some.

For M10H, support 128G need two modifications.
1.Choose newest BIOS, set HAP bit. It already support 128G in SiInitPreMem.
2.Remove FD+ME backup module , GUID:63F23E9D-5FDA-415E-9C2A-64C4E2A6ECE8

@dsanke - thank you, I will mod BIOS for @k6808_8086k then Looks like what I found (C7 86 7F 25 00 00 00 80 00 00 8B C2) was not correct segment then!
@0001E954h (PE32 Body), that was only C7 86 I seen with 8000, none with 0001, unless maybe it’s @00049E28h? Anyway, thank you for advising here

@k6808_8086k - please dump your BIOS with programmer and send to me, I will make you mod BIOS

Thank you very much @Lost_N_BIOS . I’ll dump the BIOS on Firday, upload to Google Drive and post the link here.

@Lost_N_BIOS I checked BIOS again, you’re right, C7 86 7F 25 00 00 00 80 00 00 8B C2 need be modified.

@k6808_8086k - you’re welcome! No rush here, whenever you get time to do I will mod and send back

@dsanke - thanks, good to know I did spot correct location, I’ve never done this mod before and only had your guide as information.
I wasn’t sure, without images in your guide it was a little confusing with use of … instead of seeing image, and the ending bytes in that location were not same as you mentioned 00 00
So I wasn’t sure about that at all. (I didn’t check it in assembly, since never did before I didn’t know what it should look like)

So >>>>>>> C7 86 7F 25 00 00 00 80 00 00 8B C2
Change to >> C7 86 7F 25 00 00 00 00 01 00 8B C2
Correct? Doesn’t look right, but your guide says 800000 and 8000 too, so little unsure here If you could add images of hex and assembly to your guide showing before after that would help a lot
& This in x2 modules, same module two different volumes, so I know to change both

OK, here is Assembly + Hex before/after does that look correct?


Does disabling ME cause any side effects? Does the MEI device disappears from Device Manager?
Really curious about this subject. Thanks!

Hello @Lost_N_BIOS @dsnake , here is the BIOS dump from my motherboard…iew?usp=sharing

Please let me know if this is ok. Thanks a bunch.

@daniel_k Some functions need ME to work, like Intel SGX, HDCP.
Yes, it will disappear.

@Lost_N_BIOS It’s correct.

@dsanke - Great, thank you for confirmation, and of course thank you for finding and sharing this solution for others

@k6808_8086k - here is your mod BIOS (ME Disabled + 128GB mod as shown above #11) - Must be put back with programmer
Once tested and confirmed, please post update of success for your model in dsanke’s main thread about this mod, thanks…306602224691327

This BIOS is user specific, only for user >> k6808_8086k - If you are not that user, DO NOT use this BIOS, you have been warned!!!
Additionally, if anyone was to ignore the above warning and use this, swap in your board specific details is a must (Serial, UUID, LAN MAC ID at minimum)
You will have to put on with flash programmer, or pinmod, unlock FD, then flash BIOS in full with FPT


Before you begin flashing it with LNB BIOS Mod do you have the 128GB (32GB x4) DDR4 RAM in your possession?

Try installing all 4 modules and see if the BIOS recognizes the 128GB first. If it does see more than 64GB then you have to do another test to verify the OS can see it.

Try Windows 7 Ultimate 64-Bit and see if it recognizes the > 64GB memory. If it doesn’t then try the LNB BIOS Mod and repeat.

@Lost_N_BIOS @dsanke thank you very very much. Now my motherboard supports 128GB RAM. You guys rock :slight_smile:

@XPLives Thank you for your post. Yes, I have 4x32GB Corsair Vengence 3000MHz CAS 15-17-17-35 modules. I’ve tried just installing them before LNB BIOS mod, motherboard only recognised 64GB total.
After LNB BIOS mod, motherboard recognises 128GB total. Also, my Ubuntu 16.04 shows 126GB total (normal for Ubuntu).

@Lost_N_BIOS one more question/request. Would this motherboard support the new i9-9900KS model with or without further modding?

@k6808_8086k - You’re welcome, and thank you for the quick report back! Great to hear it worked first time around too
Thanks again to dsanke for sharing this mod method and helping us along with the mod too

I checked and see 9900KS is just same as 9900K only better binned, same CPUID too (906EC), so yes, it should support that CPU already but I can’t say for sure about the full 100% compatibility
Actually, yes, I checked the CPU Support page and it shows as supported by default for that BIOS, so you’re good to go -…O/HelpDesk_CPU/


Hmmm that is strange I was expecting it to show the correct value but not recognize in OS. Mine will show over 64GB in BIOS on Z370. I guess I should also ask try mixing your 32GB, 16GB, 32GB, 16GB and see it shows 96GB in BIOS in regular BIOS and LNB BIOS mod and any difference.

Also the i9-9900KS should work as it’s just an i9-9000K with a defective iGPU. They probably just removed the connections for an iGPU so it doesn’t get power. I can’t see why they would need a new microcode. But curious if the CPU ID will show it as i9-9900K or i9-9900KS.

Also curious why so much memory for Linux? What programs will you be using that for?

@XPLives I use Linux to test some memory hungry apps and few VMs inside my machine. 64GB was being on the low side. 96/128GB will help a lot.

Will find out about the i9-9900KS in few days. Hope the built-in iGPU will work fine on that processor.