[REQUEST] Unlock advanced menu on 2019 Acer Triton Predator PT515-51 @Lost_N_BIOS

Hi,
@Lost_N_BIOS

I have got my Acer Triton Predator PT515-51 (i7 9750H +2070mxq) bios 16MB size by Flash Programming Tool v12 win64 , And the I will reflash the bios with flash program CH341a
So Could you please help me unlocking BIOS Unlock advanced menu on my laptop?

Thank you so much .


My Predator PT515-51 laptop offical informations as following:

①Model: Predator PT515-51
url: https://www.acer.com/ac/en/US/content/su…roduct/7905?b=1

②BIOS v1.05
url:https://global-download.acer.com/GDFiles…BC=ACER&SC=PA_6

V1.05backup16MB.part1.rar (6 MB)

V1.05backup16MB.part2.rar (247 KB)

@xu17913 - What is BIOS chip ID, if you’re planning to use flash programmer? So I can tell you best software to read/write to the chip. Look with your eyes, do not rely on software to tell you this.
Flash programmer may not be needed though, so if you want to try without it, please do the following - Disable secure boot, remove any BIOS password, disable TPM/Encryption and then >>
Download the following package, and run the command below from each versions folder that directly contains it’s exe.
Once done, copy the entire folder somewhere, delete everything but any created vars.txt and then repackage this and send to me, this way all created vars.txt remain in place in the folders of the version that created them.
http://s000.tinyupload.com/index.php?fil…212104496994806

H2OUVE.exe -gv vars.txt

Although, one member already tried this and it didn’t work, we can try again if you want, see it maybe it was just something he was doing wrong?
In the end, we didn’t think so, and concluded he needed flash programmer. So, if you want to avoid going through trying without flash programmer, go ahead and open system up now and give me the BIOS ID so we can dump and edit

Hi,
@Lost_N_BIOS

Also,I will try to flash w/o Flash programmer.
So I Disable secure boot, remove any BIOS password, and >H2OUVE.exe -gv vars.txt

Here is my var.txt (120k) in attached.

Thanks

PT515-51 V1.05 Var.rar (11.2 KB)

@xu17913 - OK, we’ll try. Then if it fails, and you can’t flash mod BIOS region, you’ll have to dump BIOS with programmer and send to me.
Here is unlocked vars - http://s000.tinyupload.com/index.php?fil…315471116423656

Drop this in 100.00.16.11 folder, and flash with following command >> H2OUVE.exe -sv varsM.txt
There will be list of success/fail, this is normal, reboot once done and then do step #1 from below (NOT #2 yet), and ignore stuff about flashing stock BIOS first, this is copy/paste, just do directly step #1 after flashing in the mod vars and send to me.

If you have already modified the BIOS in ANY way, you will need to re-flash it back to factory defaults using factory method (NOT FPT)!!!
Additionally, please remove all BIOS passwords, disable secure boot, and disable TPM or Encryption if you have enabled. Do this before moving on to below


If you do not have Intel ME drivers installed, install them now from your system driver download page, then start over here after reboot.
Check your BIOS’ main page and see if ME FW version is shown. If not then > DOWNLOAD HWINFO64 HERE <

Once HWINFO is open, look at the large window on the left side, expand motherboard, and find the ME area.
Inside that section is the ME Firmware version. Take note of the version. (ie. write it down or get a screenshot)

Once you have that, go to the thread linked below, and in the section “C.2” find and download the matching ME System Tools Package for your system.
(ie if ME FW version = 10.x get V10 package, if 9.0-9.1 get V9.1 package, if 9.5 or above get V9.5 package etc)
> DOWNLOAD " ME System Tools " packages HERE <

Once downloaded, inside you will find Flash Programming Tool folder, and then inside that a Windows or Win/Win32 folder (NOT x64).
Highlight that Win/Win32 folder, then hold shift and press right click. Choose “open command window here” (Not power shell! >> * See Registry file below *).

If you get an error, reply to this post with a screenshot of it, OR write down the EXACT command entered and the EXACT error given.

((If “open command window here” does not appear, look for the “Simple Registry Edit” below…))

Step #1

Now you should be at the command prompt.
You are going to BACKUP the factory un-modified firmware, so type the following command:
Command: " FPTw.exe -bios -d biosreg.bin "

>> Attach the saved "biosreg.bin ", placed into a compressed ZIP/RAR file, to your next post!!! <<

Step #2

Right after you do that, try to write back the BIOS Region dump and see if you get any error(s).
Command: " FPTw.exe -bios -f biosreg.bin "
^^ This step is important! Don’t forget! ^^

If you get an error, reply to this post with a screenshot of it, OR write down the EXACT command entered and the EXACT error given.

Here is a SIMPLE REGISTRY EDIT that adds “Open command window here as Administrator” to the right click menu, instead of Power Shell
Double-click downloaded file to install. Reboot after install may be required
> CLICK HERE TO DOWNLOAD CMD PROMPT REGISTRY ENTRY <

If the windows method above does NOT work for you…
Then you may have to copy all contents from the Flash Programming Tool \ DOS folder to the root of a Bootable USB disk and do the dump from DOS
( DOS command: " FPT.exe -bios -d biosreg.bin " )

Hi,
@Lost_N_BIOS

I have done with ‘Dump Bios region w/fpt’ step #1 > fptw64.exe -bios -d biosreg.bin
Then I get the biosreg.bin(12mb) in attached.

Backup biosreg .png



Thank you.

PT515-51 V1.05 biosreg.rar (4.41 MB)

@xu17913 - You’re welcome! Did you flash in varsm above first? If yes, OK
Here is unlocked BIOS, flash it back via the following command >> FPTw.exe -bios -f biosregm.bin
If you get error 167, then flash programmer is required
http://s000.tinyupload.com/index.php?fil…721077109065591

*** WARNING - To ANYONE with laptop and unlocked BIOS!!!
DO NOT try to enable this graphics card or disable that card, switch cards etc. Otherwise you will end up with no display output (ie black screen) and no way to recover except by blind flash or with flash programmer.
You can change graphics related settings, like changing memory sizes, or core speeds etc, just don’t try to disable one card or change which is main etc.

Additionally, be very careful when trying to undervolt CPU, you can leave BIOS unbootable due to CPU voltage too low (Sometimes even 0.05 is too much)

WARNING *** - This BIOS is user specific! If you are not user xu17913 at Win-RAID.com forum, DO NOT USE THIS BIOS!!
If you do, and you are not xu17913, then you will loose your serial, UUID, OG NVRAM, and possibly LAN MAC ID as well.
You have been warned!!!

Hi,
@Lost_N_BIOS

I have got the unlocked BIOS, Thanks for your quick reply.
Then I flash it back via the following command >> FPTw64.exe -bios -f biosregm.bin
BUT……I still get error 167….

Biosreg M ERROR 167.png




Maybe flash programmer CH341a is what I have to need….

So I have backuped the complete BIOS,it is 16MB size.
Could you please help me unlocking BIOS Unlock advanced menu on my laptop? and I will flash it back via CH341a.
MY BIOS ID:MX25L12875F 0xC22018 size:16384kb(131072Kb)

Here is my Complete Bios Backup(pt515bios16MB,2parts cause the limited sizes) in attached.


Thanks

pt515bios16MB.part1.rar (6 MB)

pt515bios16MB.part2.rar (243 KB)

@xu17913 - Yes, as I noted in post #6, as mentioned also at post #2, flash programmer may be required for this model.
You are second user to attempt normal bypass method, so you confirm it >> Flash programmer required to flash in mod BIOS on this model.

Please confirm with your eyes, what the Chip ID is, do not rely on software, is it really MX25L12875F? If yes, what software did you use to dump above BIOS?
Please upload that to tinyupload.com or uploadfiles.io, I can’t deal with split files attached here it’s a mess. Or actually, don’t, unless it’s created with one of the below software / versions, if chip ID is actually MX25L12873F
If the BIOS Chip is actually MX25L12873F use CH341A v1.31(1.4) (CH341AFree) (This is the name of the folder), ASProgrammer 1.4 or 1.41, or CH341A v1.1.1.32 from package below, and make a new dump
http://s000.tinyupload.com/index.php?fil…213094641136166

Hi,
@Lost_N_BIOS

Thanks a lot for your remind.
I will open the laptop ,take a pic and confirm the BIOS model carefully.
Then I will backup bios via ch341a and send it to U again.

Have a good day!

@xu17913 - You’re welcome, and I didn’t mean for that to sound rude if it did, only meant to say I expected that would probably happen and we’d need programmer.
Yes, please confirm chip ID with your own eyes and then dump with one of the methods mentioned above, even if it’s actually MX25L12875F, do dump as mentioned above using one of those software/versions
Only ASProgrammer has actual MX25L12873/5 ID’s, but the others work as well, just choose correct size (16MB) and type (25) for 1.31/1.40 free, or with 1.1.1.32 choose 128Mbit and MX25L12805

Hi,
@Lost_N_BIOS


I have opened my laptop and find the actual bios is MX25L12872F

IMG_7143.HEIC.JPG



The bios via flash program CH341A and ASProgrammer 1.4.1, but there is no perfect IC model when it readed .So I choose the IC MX25L12873F , read&save BIOS 16MB size.

2004_2.png



Did I do correctly or not ?

Could you please help me unlocking BIOS advanced menu,disable FPRR&BIOS LOCK on my laptop,it will better if the soft flash support.

I will program back later.Thank you so much.

Here is the backup link:

http://s000.tinyupload.com/?file_id=09829160061298519559

@xu17913 - Thanks for checking, yes, that is correct to use 3F ID.
Not sure if I can find and remove the FPRR lock, but I will look and see if I can find. If not, it does not matter, you will program in mod BIOS unlocked anyway, so all will be done.
Sorry, I could not find

Please test this real quick, flash in this mod vars, reboot, and see if you can dump BIOS region with FPT using new name again and then test write back of BIOS region with FPT
http://s000.tinyupload.com/index.php?fil…827002054841229

If that does not work, then here is mod BIOS to program in with programmer
Erase, then blank check, then open BIOS file, then write, then verify. If using ASProgrammer, before erase hit “unprotect” icon, not drop out menu, just icon
http://s000.tinyupload.com/index.php?fil…977014571165119