[REQUEST] Unlock advanced menu on 2021 Lenovo Legion 5 PRO AMD


Please help Unlock Lenovo Legion 5 PRO bios Unlock Unlock Advanced hidden menu ,thanks.
Legion 5 PRO 82JQ009CHH 2021
Bios ver. GKCN34WW, Bios is InsydeH20

Lenovo Legion 5 PRO
MainBoard : Lenovo LNVNB161216
CPU : AMD Ryzen 7 5800H
GPU : NVIDIA GeForce RTX 3060

Lenovo update bios
Lenovo.com: Bios gkcn34ww.exe

i don’t know how to dump AMD bios .

try it intel FPFW dump it ,then show:

H20UVE\FPFW\fpt64-12-300>FPTW64.exe -bios -d biosreg.bin
Intel (R) Flash Programming Tool Version:
Copyright (C) 2005 - 2019, Intel Corporation. All rights reserved.

Error 63: Unknown or unsupported hardware platform.




in the same boat, I like to use XMP profiles for the ram I purchased, it’s CL18 3200 1.2V so really like JDEC ones…

Could you post or upload all menu tabs active shots to see this bios ?
It’s an Insyde Bios witth AMD CPU.
There are something into a “Debug” Module, but i cannot understand without see the images …

CCFD7D6B-623F-442A-BAB5-EE7FAF07AEE9 DebugPageDxe

The modifies are here, but we have to find a way to reflash the bios mod :

FE3542FE-C1D3-4EF8-657C-8048606FF670 SetupUtility

Form Sets
Offset: Title:
0x31E04 Configuration (0x28 from string package 0x2)
0x338C4 Power (0x126 from string package 0x2)
0x34B24 Advanced (0xA3 from string package 0x2)
0x36CC4 Home (0x7 from string package 0x2)
0x37D84 Information (0x8 from string package 0x2)
0x61044 Main (0x78 from string package 0x2)
0x62294 Boot (0xC1 from string package 0x2)
0x63EE4 Security (0xA1 from string package 0x2)
0x65E54 Exit (0x102 from string package 0x2)

0CF6E : 74 09 to 74 00

0CF73 : 0F 83 0B 0C 00 00 to 0F 83 00 00 00 00

let me know

sure thanks for that,
you need pictures of the tabs in the real BIOS or something read with a software in windows?

here they are

Here is the Bios folder without the file .fd as we don’t want to flash anything, but make a bios backup by H2OFFT-w.exe :


Extract the folder into C:\ HD place and open a command line interface from it.

Execute H2OFFT-W.exe -g to get a bios backup.
Executing the command H2OFFT-w.exe -h it give :

Insyde H2OFFT (Flash Firmware Tool) Version 6.28
Copyright (C) 2000-2020 Insyde Software Corp. All Rights Reserved.

Usage: H2OFFT-W [BIOS_Filename] [-Option]

-h This flash utility help.
-b Force suspend BitLocker.
-ecp Update non-share EC block by block.
-edt#@:“VALUE” # : The type ID. Value 4 ~ C.
@ : The data format. Value F, S, W, DW.
F for file,
S for string (Unicode string),
W for word value,
DW for double word value.
Update type 4 data, the source is file.
And update type 5 data, the source is string.
-edt4f:logo.jpg -edt5s:“Input string.”
Update a type 9 data, the source is WORD.
Update a type C data, the source is DWORD.
-extrfd OUT_PATH Extract BIOS file from single package to OUT_PATH.
-forceit Skip BIOS version check.
-forcetype Skip model name check.
-g Read current ROM and save to file.
-iv Show utility and onboard BIOS supported IHISI
-mfg Tell BIOS current run is in manufacture mode.
-n Do not reboot after flash.
-noconfirm Do not popup flash confirm dialog.
-nopause Will not prompt the user for command line input
during flash update.
-OemCus Tell BIOS to do OEM custmization feature.
-pbi:TYPE Flash specified type of BIOS protect region.
TYPE is the protected region type BYTE value in hex.
-pi Query BVDT protection/private region MAP in input
BIOS file.
-pq Query BIOS protection region MAP in current ROM.
-pr Query external region MAP in current ROM.
-priv Query BIOS private region MAP in current ROM.
-pw Query whole region MAP in current ROM.
-pwd:PASSWORD Input password for the feature which need password.
-r Reboot the system to complete the update.
NOTE: Requires -s option. Only available with -s.
-s Run as silent mode.

So looking there is an option -g to make a bios backup !
I removed the bios file to avoid issue, so it’s only program. if you do you want try it , let me know.

This Bios has the Debug Mode active so we can try to show the hidden page by the Fn+D key using this procedure :

Boot to Bios and quickly Press key Fn + key D, then release Fn and quickly press F10 to save and exit.
Boot again to Bios and look if Debug Mode is actived , so all Menu tabs showed …

Here many tricks worked on different Y Series :

Lenovo Legion 7i Advanced Bios Menu

That work:

- enter BIOS by tapping F2 while booting up
- Click “more settings”
- hold Fn, then slide your finger through all the alphabetical keys (Q to P, A to L, Z to M)
- release Fn, then quickly press F10
- save and exit
- enter BIOS again and more settings will be unlocked

Lenovo Legion Y740

You can access this by entering the bios, hitting FN + hit every key on the keyboard individually or what i did,
was just drag my finger across the rows of keys, then hit F10, yes.
Then hit FN+F2 (or just F2) and enter the bios. Boom, debug mode.

Hello! I watched your video in no way could enter the BIOS with advanced settings (lenovo Y740 -17")
And when I was already desperate, I decided to try the last time and ran a finger along the entire row with the FN key pressed,
including the side buttons: Q-\ A-Enter Z-shift , and then I reloaded the BIOS and Oh miracle :slight_smile:
everything worked out :slight_smile:

Now I have a few questions, to which I will be very grateful :

1. where in the BIOS I can find a line where I can set the keyboard backlighting parameters at startup (this rainbow is very annoying)
2. I would like to reduce the acceleration delay of the fans when the set temperature is reached. For example,
when the processor reaches 75 degrees, the fans operate at 100 percent, but this does not happen right away.
I would like to reduce the reaction time. Perhaps you know where I can find this menu.
3. It would be great if you had a tutorial on all BIOS parameters :slight_smile:

Steps to enable advanced BIOS:

1. Goto BIOS
2. Hold Fn and press the qwerty row: Q to P, asd row: A to L, zxc row: Z to M. Release Fn
3. Press F10, select save when it asks you to save settings in the BIOS (yes you didn’t do anything apart from step 2 in the BIOS).
4. When the system reboots, open BIOS by pressing Fn + F2.
5. You should now have the advanced BIOS, exercise strong caution before messing up the settings.

A ton of thanks to CodeHusky for this.
So far, it works on his Y740 9750H and my Y740 8750H. May work for other legion models, try and report.

This worked for me, but only when I slid my finger across the row like others had mentioned.
When I pressed each button carefully it wouldn’t work so maybe I was too slow.
I was hoping to find a flashing ‘Enable G-Sync’ option in there but no luck so far

You stop windows not restart and at startup press continuously on F2 alone

With the y530 it was Hidden Features:

Fn + Tab, Fn + ASDFGH, Fn + O, F10 (Yes)

Only Fn + Tab then F10 Save (yes)

More keys combinaison, doesn’t work on C340IML, While in bios hold FN then run your finger across the keyboard,
let go off FN,
Save Yes.

Let me know

great thanks, will do that asap, I’m on linux atm so I’ll boot on w10 and let you know :wink:

hey man I am getting
an error when execution the command as admin, any advice?

C:>H2OFFT-W.exe -g

Invalid file.

Should I put a bios file as well next to the h2offt program?

try this open command line interface CLI aka window PowerShell or cmd as Admin , you’ll get C:\yourdoldername\subfolder , etc then execute

H2OFFT-W.exe biosreg.bin /g

Here you go the H2OFFT-W manual :



there you go, easier from powershell, I’m a linux user ^^

Btw I tried all the key combinations with no luck to unlock the bios

There is’nt your bios backup !!!
You deleted it ?

This is the only file that was generated what extension should it have?

Oh wait it’s gone :confused: hold on

try this one https://wetransfer.com/downloads/6a9945e…01152635/300ea3


not good ?

Ok i’m going to find a solution, but also you look this one :


i will reply quickly.

From Lost_N_BIOS :

For AMD, your only options are risky AFU /GAN method, or flash programmer, or possibly flashrom if this method is compatible with that system (See Annex at end of this guide, ignore 32MB/Asus comment and try anyway)

I tried it but I have AZERTY keyboard, do you think the combination is the same?
Meaning all the 3 alpla keys rows from left to right?