[Request] Unlocked ACER NITRO 7- AN715-51 BIOS

here are my specs -
Bios version - 1.08 , FPPR is unlocked by default .
Bios Chip - XM25QH128A
System Manufacturer: Acer
System Model: Nitro AN715-51
Processor: Intel(R) Core™ i5-9300H CPU @ 2.40GHz (8 CPUs), ~2.4GHz
Memory: 16384MB RAM
Card name: UHD630 + NVIDIA GeForce GTX 1660 Ti

Most of the options are locked in the new Bios .
I use the system with Ubuntu + windows 10 .

Here’s a dump of my 1.08 Bios Via FPI . - BIOS 1.08
do you need something else? I do have a CH341a programmer .
thankyou in advance .

photo of FPI flashing

EDIT by Fernando: Thread title shortened (detailed information are not required there)

@mesh17 - If you are ready to recover original BIOS from chip with flash programmer, I can send you one test file I think “Maybe” I found menu unlock, but I am terrible at Insyde BIOS so it may be fail/brick.
Some Insyde I can get, others I can’t see anything that looks like what I KNOW is menu unlock, this one I found a maybe. If you want to test it let me know, but you MUST be ready to recover from brick before you flash or program it in.

Ooh , that was quick :slight_smile:
It’s night time for me , just send me the test file I’ll test it in the morning and post the results .
Thankyou so much again !

You’re welcome. OK, here is file, it may not be correct edit as mentioned, so be ready to recover. - http://s000.tinyupload.com/index.php?fil…425675813954312
If it fails, but boots, let me know and I will look one more time, but I can’t make any promises because I’m not good at Insyde (best place to get mod like this is at BIOS-mods.com forum)
If it does work, great, that may help me fix BIOS for another user that’s been wanting Nitro AN515-52

hello again .
I have some questions .
My Bios chip is XM25QH128A . the thing is programmer detects/reads the chip , but it doesn’t have the manufacturing details !!
Anyway I took a backup from ID W25Q128FV . will that be an issue?

Also I tried flashing the BIOS you gave me above , it gives me error while writing !! does something else needs to be unlocked for writing ?

error when writing -
Error 167: Protected Range Registers are currently set by BIOS, preventing flash access.
Please contact the target system BIOS vendor for an option to disable
Protected Range Registers.
FPT Operation Failed.

Sorry that I told you FPRR is unlocked !

That is common error (167 FPT I mean), this means you have locked FD and or FPRR/PRR locked in the BIOS (not always a “settings” thing), or could also just be BIOS or SMI lock is enabled, but that would be rare, usually 167 is FD lock and or FPRR/PRR enabled.

What software and version are you using for your programmer? Is your programmer general cheap CH341A? If yes, try 1.30 or 1.34 from link below and ID EN25QH128, or use colibri included, it has exact ID.

What you mentioned will fail, it will either dump wrong, or dump and write wrong. (most likely) Please link me to the stock BIOS download page

Anyway, to even try mod BIOS, you need to disable FPRR/PRR, or use programmer. I didn’t check BIOS for FPRR/PRR, why did you initially say it was disabled? I assumed you checked, or disabled or something, is why you mentioned, so I didn’t even look.
I will check in a bit after I post this reply. Make sure you get a good backup with the programmer before you do anything, check it in BIOS tools and make sure it looks OK, opens OK, looks similar/same as stock BIOS etc. Or upload for me to check, before you erase or write anything to the chip.

* Edit @mesh17 - It’s enabled >> Flash Protection Range Registers (FPRR), VarStoreInfo (VarOffset/VarName): 0x6D1, VarStore: 0x5, QuestionId: 0x50C, Size: 1, Min: 0x0, Max 0x1, Step: 0x0 {05 91 77 0D 78 0D 0C 05 05 00 D1 06 10 10 00 01 00}
One Of Option: Disabled, Value (8 bit): 0x0 {09 07 04 00 00 00 00}
One Of Option: Enabled, Value (8 bit): 0x1 (default) {09 07 03 00 30 00 01}

You may be able to change this via grub/setup_var or H2OUVE dumped vars, edit, then re-write. Here, lets see if we can disable it via H2OUVE

Select the folder that directly contains the H2OUVE.exe in each version folder, hold shift and press right click, choose open command window here (Not power shell).
At the command prompt type the following command once for each version >> H2OUVE.exe -gv vars.txt
Then send me the package back, leaving all files in place, so we know what version created what vars.txt

If you are stuck on Win10 and cannot easily get command prompt at exact location, and method I mentioned above does not work for you, simply registry edit that adds “Open command window here as Administrator” to the right click menu
Double-click to install, reboot after install may be required

1- Alright that means my FPRR/PRR is locked , I was able to read and dump it though !! that is why I thought it is unlocked .

2. I’m using CH341A programmer , yea it’s cheap .
- OK , I tried both 1.30 and 1.34 from your link with Id EN25QH128 but when on verify it gave me an error at 52%
error - Chip Main memory with the contents are in disagreement .
- I did a backup from Colibri , and still it didn’t detect the ID . then I did a backup using the ID EN25QH128 in CLOIBRI and I think I’ve a backup . Here’s the link - http://s000.tinyupload.com/index.php?fil…330871059965279

3. Here is the link to the stock Bios 1.08 with bin file - http://s000.tinyupload.com/index.php?fil…840486948027327

4. Like i said above . Can you please check the above link and see if its the correct backup or else I can order some other programmer .
BIOS TOOLS - Is it a software , can i get a link please .

5. here’s are the files back with vars.txt - http://s000.tinyupload.com/index.php?fil…433526946333610

6. Also here’s the IFR.txt from SETUPUTILITY PE32 - http://s000.tinyupload.com/index.php?fil…603168410791800


Hello @Lost_N_BIOS
I tried the GRUB method to disable FPRR
code ( setup_var 0x6D1 0x0 )
error - offset out of range . I was reading the helios 300 thread , I’m pretty sure predator and nitro uses the same code/bios almost !!
I dumped the Vars.txt above . waiting for your mod .

- also any idea what this chip does - (W25Q80EWSIG) it’s near my 1660ti ( almost bricked the Graphics card thinking it was a bios )

You can always read/dump BIOS region

CH341A is compatible with that chip, it’s just not much software is, maybe flashrom and colibri, and then rare non-exact ID’s with other general software for CH341A like the 1.30/1.34 and ASProgrammer etc.
You’d have to order one of the mid-range priced ($20-30) ones like flypro or something to get a confirmed working software with that chip ID.
Flashrom may work OK with it, but I have not experiance there and the program itself is not kept updated properly all in one location, so there is 1000x edits all floating around and some work with this or that while others dont

That small chip is probably EC FW. Please link me to the stock BIOS download page from Acer, I will extract any files I need from the exe myself. Then I will check your dump above, I can’t do that before I have stock package from Acer.

Please edit your posts in future if you need to add more info, questions etc. Thanks

Here is edited vars, flash this back using command below, there may appear to be errors possibly, it’s OK.
Reboot and then dump BIOS region again with FPT with a new name, then immediately try to flash it back, if success then send me that newly named FPT BIOS region dump
DO NOT FORGET -BIOS flag while using FPT!!!

Program back in modified vars >> H2OUVE.exe -sv varsM.txt

Alright successfully flashed the varsM.txt file .
backup- code ( FPTw.exe -bios -d biosreg.bin)
and then flashed it (FPTw.exe -bios -f biosreg.bin)

here’s the pic - http://s000.tinyupload.com/index.php?fil…794478460948067

stock bios from acer v1.08 - https://global-download.acer.com/GDFiles…BC=ACER&SC=PA_6

also here’s the Bios file after flashing varsM.txt - http://s000.tinyupload.com/index.php?fil…360726983482095


EDIT- well just bricked my bios and then restored it using CH341A programmer (using colibri , ID-EN25Q128), laptop is up again
was trying some edits form acer predator helios 300 thread .
At least I have a way back now
I’ll just wait for your mod .

@mesh17 - Great, so the vars edit does unlock FPRR, good to see, and you have tested recovering via programmer now too, also great! So, put back in your original dumped BIOS with programmer, unless that is what you have now?
Then flash in the modified vars, and then send me new FPT BIOS region dump (or is this what is above)?

@Lost_N_BIOS - Alright .
Here’s the new bios file after flashing it with programmer and then varsM.txt

@mesh17 - Thanks. So, you confirm, this file above, can now also be flashed in with FPT, correct? I guess it doesn’t matter, since you have programmer, but would be nice to FPT it in to save using programmer for only when it’s needed.
I will edit in mod attempt #1 in few minutes, please refresh page in a sec, it’s only two byte edit but I have to build it and then upload.

* Edit - OK, here, if you still have programmer out and ready, this also has unlocked FD now too, so if you program this in, FD will always be unlocked (until you program in some other locked FD in future)
Otherwise, I’ve also included just the BIOS region extracted, if you don’t want to program in, and only want to FPT it in for now

Be ready to recover as mentioned, this may brick, if not, it may also not unlock the menus.
If it boots, but no menu unlock, I will look again but may not be able to find (this kind of edit best asked over at BIOS-Mods.com forums, they are Insyde Pros)

@Lost_N_BIOS - I just flashed the BiosregM.bin using FPT , it boots everything is fine . but no unlocks .
do you want me to flash SPIMFD.bin via programmer ?

Thanks, I guess that edit is fail. Go ahead and flash back in your new FPT BIOS region dump for now, in case that failed edit causes any random bugs.
Up to you, if you want unlocked FD, you can program that in, and then once in windows reflash your new FPT dump you sent me, that way you are back to square one without a failed edit in BIOS + Unlocked FD
Then you wont need to use programmer anymore, for anything, except if BIOS bricks. I will look once more now for the unlock, but I don’t have high hopes.

@Lost_N_BIOS . Ok , I’ll try flashing it via programmer !
here’s a thing , do you remember the acer helios 300 you unlocked back in 2019 (link- [Help] Unlock advanced menu on 2019 Acer Predator Helios 300 PH315-52 (4) , post#55 ) . I was just looking into some of the setuputilityPE32 edits file via HEX from my bios and predator they are almost the same , maybe that can help you :slight_smile:

also the varsm.txt file that you send me yesterday I edited it back and then flashed it , both predator and nitro had the same FPPR
edits from predator forum .

1- [02C] “PchSetup”
GUID: 4570B7F1-ADE8-4943-8DC3-406472842384
Attributes: 0x7
DataSize: 0x6E0

2- [033] “Custom”
GUID: 4570B7F1-ADE8-4943-8DC3-406472842384
Attributes: 0x7
DataSize: 0x6E0
same GUID and same datasize from predator vars.txt

thankyou for your work though !

It wont matter flashing it via programmer, outcome will be the same. Only you will then have unlocked FD. After that, you should program back in your original FPT dump from post #11 so there is not failed BIOS mod in the BIOS region.
Thanks for tip, I will look at my folder on Helios 300 and see if it helps any. I just looked through again and couldn’t see anything that caught my eye, so not high hopes. What exact tabs by name can you already see?

Hey! great thinking and find! Yes, I think Predator Helios edits I found may work here too, into assembly now and you are right, looks very similar, I will post back shortly and with mod that will work I think

* Edit - @mesh17 - here, test via FPTw.exe -bios -f biosregm2.bin

Bro it worked
thankyou so much for your work dude , would have been impossible without you :slight_smile:
here the pic attached
locked - Power menu is still locked , the overclocking menu is greyed out too !
unlocked menu - debug , advanced seven blesings to you friend .
Is there anything else I need to do? or more unlocks ?


@mesh17 - great to see!! @amd_comeback will be happy too, I can now unlock his nitro 5 an515-43 as well

There may be still some hidden settings, but you’d have to give me a package of images of ALL settings withing ALL the new submenus, then I can compare that to the possible settings, and further reveal anything still missing
If you do this, please set your camera to take small images, 100KB or so, or 800-1000px wide is all I need to see. That, or super resize, shrink all of them by batch before you resend to me. And no matter what, if you do send package of images, please use 7zip or zip and max compression, thanks

Big thanks to you for digging up that other BIOS thread I unlocked before, I probably wouldn’t have found this without looking into my folder on that one.
Good thing I keep all edits in proper folders

@mesh17 - Edit, almost forgot >>
WARNING - To ANYONE with laptop and unlocked BIOS!!!
DO NOT try to enable this graphics card or disable that card, switch cards etc. Otherwise you will end up with no display output (ie black screen) and no way to recover except by blind flash or with flash programmer.
You can change graphics related settings, like changing memory sizes, or core speeds etc, just don’t try to disable one card or change which is main etc.

@Lost_N_BIOS Alright !
Images - I’ll send it shortly , 100kb-7zip - got it !!
all the work was your’s dude , big thanks
I’ll attach the images soon .

alright , I won’t disable any cards !!

  • Edit - Well that sucks! Sorry @amd_comeback , I first thought these two BIOS were very similar, now I see not same at all, so sorry. I am still at huge loss on finding unlock for your model

    Yes, just small as you can make images would be preferred, I only need to look at them for a second, so don’t need 6MB images