(REQUEST) Unlocking CM5575 -LGA 1156- OEM board's full potential for overclocking...

I posted this in bios-mods, but there was no response. I joined here, so lemme re-post what I wrote there.

"I don’t know what forum topic of the BIOS should go, but I saw American Megatrends, Inc. so I thought it was the long words for AMI. Anyway, moving aside, I have a CM5575 OEM board (which is a locked P7H55-M SI) and yet it has no OC options. So maybe I need some help here, hehe. Sorry."

I actually flashed the CM5575 board with the P7H55-M SI BIOS to find if there was some overclocking… no luck has been found even though both boards are similar. A guy and I are looking for this on our two boards (which are the same using Intel Xeon X3440s) and both our boards don’t have OC options. I tried the original P7H55-M bios, but that bricked my BIOS chip which luckily it’s removable, so I can just mod another BIOS in once my BIOS programmer comes in the mail.

If there could be a way to add OCing to the BIOS, that would be great. Please let me know in PMs or here.

Update: Since people are telling me to flash the P7H55-M SI BIOS to the OEM board, that either doesn’t have OC options… sadly from what I see IIRC.

So you cross-flashed the other board and it bricked, to clarify that’s what happened? How did you modify the BIOS to force the crossflash, or how did you forc flash it if you didn’t modify the BIOS.
If they are indeed the same board, crossflash done properly shouldn’t brick, that is why I ask about how/method etc.

Does your board have two BIOS roms, does the other board? Asking this because often on Asus, the second is not always a backup but rather other board information ME, system data, serials, etc.
Hope you have a backup of your original BIOS before any of this, that way you still have your DTS Key, UUID, and LAN Mac.

I checked your BIOS linked here, and P7H55-M SI BIOS from here - https://www.asus.com/supportonly/P7H55-M%20SI/HelpDesk_BIOS/
I see what you mean, JumperFree Config section is missing in your CM5575 BIOS. I will see if I can add/unhide that, give me some time and hopefully you’re flash programmer arrives soon

I actually used Flashrom in DOS to force flash the BIOS since AFUDOS and AFUWIN (not trustable, I know) didn’t let me flash the BIOS for the retail board. Then I flashed the original P7H55-M BIOS and I bricked my board.

I think I still have a original version of my BIOS, not sure however since I keep my time off-track and just distracted.

I appreciate for what you are doing, thank you. I’m no BIOS programmer myself, sadly. And I do hope that my flash programmer does arrive soon too, considering I wanna flash back to the original BIOS before jumping on to a newer one that has OCing.

Thanks for the info. The way you did that may be part of the problem, since it was incorrect board/BIOS ID flashrom may not have written it all correctly. Proper way to do that would be edit the BIOS on the file you want to crossflash to have your same/current BIOS/board ID, then regular asus or AFU methods would work without issue.

You would need a flasher to recover though, if the BIOS and other board is not very close match to your board. I can try a few methods to attempt to get what you want, that is why flash programmer on the way is good!

Once it arrives let me know and I’ll get you some test files and tell you what each is etc.

Thanks, dude. I’ll let you know once the flash programmer arrives… :smiley:

Sorry I took three weeks, but it did arrive just today. Thank god. :slight_smile:

Great you didn’t have to wait too long! Do you have an original BIOS backup from before you bricked the board? That way I can start by sending you a corrected initial BIOS to get the board running again with your proper details (System UUID, Serial, LAN Mac DTS Key, etc)?

I actually got the CM5575 ROM from the download site and pretty much used that with the Flashrom for CH341A USB adapter, which worked perfectly and I got the PC booting up, fully working as I type this message.

Great it’s working now! So, do you have backup at all, from before the bricking incident or before you wrote to the BIOS chip again with the programmer?
If you do, upload it here and I’ll see if I can salvage your board details for you before we start bricking the board again with test BIOS

Alright, I’ll do the backup and let you know once I get back. :smiley:

This is as far as I could get from backing up my BIOS? I used the EZ Flash from the board itself.

EDIT: I forgot there was a 6MB limit (considering the file is 8192KB, so I zipped the backup BIOS into a RAR. Hope you understand.

CM5575.rar (2.88 MB)

Yes, zip/rar is expected, or you can host on another site is OK too.

What do you mean “As far as you could get”? Did you try other methods and get errors, if yes what methods and what errors. And why not backup with programmer, if this is current/now backup?
Please post a current backup from programmer too (Aside from below comments, wrote this after below) Make sure the backup from programmer is read (From chi, not file)/save/verify and that it verifies chip/buffer match

Wait! You said “Do the backup” I asked for backup from before you flashed anything, or previous old backup etc?

You don’t have that? And this backup is not real backup, correct, only programmed BIOS from Asus site you put on chip, then backed up?
If you don’t have that kind of backup from before incident, then you lost your boards serial #, LAN MAC, UUID and DTS keys

You’ll have to open the case, and hope all the right stickers are on the board. You wont ever be able to get same UUID or DTS key probably, but we can fix good enough.
Due to this, two questions, is your windows activation OK still? This only applies it it’s real/valid, does not apply to hacked methods - none of that matters except LAN MAC if you are using hack method for windows activation.
Does your LAN connection work, Ethernet one?

If you open the case, take an image of all stickers you see and upload in a zip and host on free file host site or attach here.
Be sure to look on the sides of the 24pin connector, and on top/bottom sides of all the PCI/PCIE slots too, don’t miss the long thin white sticker too.

On another level for now, since you have programmer now, did you try to program in the other board BIOS and see if it runs properly that way?
The original problem may have only been caused by flashrom program, so I would test this before anything else. Nothing to worry about now, since you have programmer.
Except, be careful when removing chip from the board, those legs break easy sometimes if bent wrong direction or bent badly

Yea, I know. Sorry about that lol.

Oh, okay. I thought it was by getting the backup via EZFlash since it wasn’t UEFI-based.

Yea, the BIOS from the ASUS site is what I used for the programmer + flashrom for CH341As.

Problem is that the Serials are all blacked out (sticker covered in Sharpie but can still see the numbers somehow with a bright light) when I got the board so this means I can’t grab the board’s keys. Yea, it’s still okay (hacked method). My Ethernet connection works too.

My PC isn’t in a case at the moment haha. Yea, I know about the chip. The chip is the worrying part. It bent, but I unbent it back.

Extracted from the BIOS programmer, it’s the same ROM sadly. Doesn’t include anything. Do keep in mind that this board is 2007-2009 ish so I can’t tell why it wont extract the stuff we need.

BIOSChip.zip (3.02 MB)

OK, well give me all the numbers you can read, hopefully you can read them all. Also, since your LAN is working, run ipconfig/all and get the current LAN Mac and let me know that too so I can put all that in final once we get fixed,
Or I guess we can skip all that since it’s not a big deal for UUID/Serial/DTS due to hacked win

For the chip removal, use something plastic like bic ink pen cap tip, and nudge one side up a little at a time until it’s loose enough to get something thin/flat underneath it then you can pull straight up and outward from both sides at once.
You can get more on ebay cheap, but you would have to wait for shipping time 2-3 weeks usually. You can also tied some flat ribbon cable or something thin and wide as the chip once you have it out, all the way around it, that way you can always easily pull it up from both sides at once.

You don’t have any backup from before you tried the crossflash? The backup you sent, is about 90% NVRAM errors 100’s in a row, all referring to your CPU mostly.
Whatever BIOS is there now, if that is what gave this backup, is not setup properly for the CPU.

Hacked is always OK with missing or incorrect UUID, DTS Keys, etc so as long as you always use that it will be OK. Valid method using the OEM activation in the board BIOS will not work without the correct details.
So if that’s never an issue you don’t have to worry, and since LAN MAC is working that’s good!

I think you should try the crossflash again as I said above, using your programmer this time. First, make sure your programmer and software version are working properly by reading the chip (Not a saved BIOS file), saving and then verifying.
You want it to say chip memory or main memory and buffer match after running verify. Once you can read a chip and verify then it’s OK. if not try other software version until you find one that works properly, here’s a few versions

Once you have it working properly, program the other boards rom with your programmer for a test run, verify it wrote OK, then put in board and test. If it fails OK, at least we know it wasn’t fully the method of force flashing that caused the brick initially.

After that, I can send you something to try I think. Are you sure this model is closest match to your board?

Which should I try for the programming? The P7H55-M SI BIOS, or the regular P7H55-M BIOS?

I meant to go ahead and try programming in the BIOS you original tried to crossflash that failed, just to test and verify that the BIOS fails and not the method used when trying to crossflash initially.

Ah, okay.

So I checked the BIOS I flashed when I bricked the board, I actually got the same result. Flashed back to the CM5575 ROM, so I can stay with my original BIOS for now…

Keep in mind I didn’t read the other part about the CPU, but I do run a Xeon X3440 here.