[Request] Win7 compatible Intel I/O drivers for the Touchpad of ASUS Notebooks

Hi everyone! I received a great help here with the installation of Win7 in my new notebook, now I miss a last step and I have everything working. I have to enable the touchpad, which at the moment is completely not working.

Some information: Win 10 shows 4 different HIDs.

Win 7, After a bounch of attempts and drivers, I have a multi-touch Serial IO in HID devices, but this device shows the error "The specified device generates a resource conflict. (Error Code 12)"

Prior to this situation, I had an unknown device called ACPI / Elan1200, but no drivers were accepted / working.

Attached there are the images, much more clear I guess, I hope in some new idea, because I finished them.

Thank you for any help!

Win 10 :

win_10_1.jpg

win_10_2.jpg



Win 7 :

win_7_1.jpg

win_7_2.jpg

win_7_3.jpg



EDIT by Fernando:
Since this is a specific Win7 problem, I have moved this thread into the Win7 Sub-Forum and customized the thread title to open it for all ASUS notebook users, who are searching for a working touchpad driver while running Win7.

Please give the exact model for your tablet, and a link to the Asus download page if you an. Did you install ATK package already?

This may help?
https://www.reddit.com/r/Windows10/comme…rt_gesture_and/

Hello Lost_N_BIOS, the exact model of my notebook is Asus VivoBook Pro N580VN-DM017T

The ATK package is installed correclty (downloaded from the respective asus webpage).

I have already tried this driver, it is partially working in Windows 10 (no gestures) but does not works in Win 7, the installer shows "device not connected"

Thanks for your help

Thanks for the model info. I will look more later today.

Did you try uninstall everything touch related I2C, HID, and ATK etc, then try method mentioned at the reddit pages?

Also, have you tried these drivers and methods to update/stop other drivers from installing etc
https://ivanrf.com/en/asus-smart-gesture-and-windows-10/

New tests executed:

1) Removed all drivers of I2C, LCP Controller, ATK.
2) Tried to install the driver suggested on reddit, original asus driver, asus smart gesture
3) Error for all these drivers
4) Installed new ATK suggested (1.0.0060)
5) Tested again the mentioned drivers > Same result
6) Re-installed Chipset drivers > New attempt with touchpad drivers > Error
7) Re-installed ATK official driver > New attempt

The weird things is that the device does not appear at all in the device manager, even if I check the “show hidden devices” option.

On the drivers official webpage there is a driver that I can not manage to install, Intel Serial IO controller driver (https://www.asus.com/it/Laptops/ASUS-Viv…pDesk_Download/). I’m not sure, but this could be related.

At the moment in the device manager I do not have unrecognized devices.


p.s. I decided to give a try with ‘easy driver’ software, update chipset and serial io drivers, and an unrecognized device jumped out again. ACPI/Elan 1200

The drivers installation keep to fail, and if I force the installation manually this is the result (elan driver from reddit)


Immagine.jpg

Does windows updates offer any drivers if you run windows update, with all drivers uninstalled as per your original #1 begin test above?

In the image, says conflict. Maybe leave that elan 1200 driver, remove other I2C driver and ATK? Test reboot after each one of those removed, one at a time.

What is error given when you try to install the linked file from Asus, the Intel Serial IO controller? Did you try Compatibility mode for Win7? Did you try manual install the INF’s from this package via device manager?
I see here, this is required if you plan to use the I2C, SPI, UART, or GPIO host controllers - https://communities.intel.com/thread/117769
I checked download from Intel direct, and this driver in all variants is made for Win8-10 only (no Win7 option), so if compatibility mode does not help it may not be possible to load on Win7 - https://downloadcenter.intel.com/search?..erial+IO+Driver

Do you know what your I2C controller value is? Find in device manager > “Properties” > “Details” > “Property” > “HardwareIDs”. If 9D60 or 9D61 you can try this one
https://support.lenovo.com/us/en/downloads/ds122265

Do you already have Intel ME drivers installed? Are you already on the latest BIOS there? If not, update BIOS now in case it’s a BIOS bug.


No drivers offered by win update


If I remove the I2C drivers from the system, the device elan1200 from HID disappears. Even after rebooting, the device is no longer visible. The two drivers seems connected.


"There is a problem with this windows installer package. A program run as part of the setup did not finish as expected". Similar error if I try manual install the INF, "The folder does not contain a compatible driver."


I’m not able to install these drivers


I have the most updated bios and Intel ME drivers


This is interesting. I do not see these hardware ids in my I2C devices, however I can install this driver, and two of the I2C devices are recognized. After installing this driver, the elan 1200 device appears in the device manager as unknown device. Unfortunately the situation does not change trying to install the drivers of the touchpad at this point.

Thank you for your help, it’s much appreciated

Vincenzo

They’re really cblocking Win7 and pushing Win10 here is the main issue. Did you have it working in Win10, or no? What about system factory restore, it should have been all working when you got the device correct?

Everything works fine on Windows 10, I deleted the system as soon as I received the notebook, then installed both Win 10 and Win 7 on the new M.2 SSD. It’s a pity, I managed to make everything work except the mouse. I would also let it be if I didn’t need it for work. Well, maybe I’ll have to get used to always having a mouse with me

Mouse only, the touchscreen doesn’t work either? I thought was touchpad issue, not LCD screen touch problem too. Sorry I don’t know any other way to fix this, it’s due to Intel and MS blocking everything for older systems and trying to push everyone towards Win10.
It can probably be fixed by editing the Win10 drivers to also work with Win7, but that is beyond my knowledge.

There is no touchscreen, only touchpad. Unfortunately it is also beyond my knowledge, so for the moment I will have to resign myself to using windows 10, and live with it. I will use windows 7 as a second system, unfortunately. Thank you so much for all the help

Sorry I can’t help! Maybe if you ask @Fernando he could look at modifying the drivers from Win10 to Win7 for you, or he knows someone here that might be able to?
I think main one you need fixed first is the Intel Serial IO controller, then possibly others but that would be starter to port to win7 with your correct hardware ID’s if the Lenovo file above doesn’t have your correct hardware ID’s

I can try to modify the Win10 driver, but I need the HardwareIDs of your on-board Intel Serial I/O Controller and the name of the Win10 driver.

Such a great news! Thank you guys.

Attached there is a full HW IDs list and the Serial I/O IDs list, captured in Win10. Also, I found something about serial i/o in Windows 10, it seems that one of the controllers does not works, altrought I have installed the drivers package of Win10 from asus. I’m not sure it’s true, in peripheral management everything is recognized.

Here is the Asus Win10 driver Serial I/O controller >Link< and full drivers list >Link<

Screenshot - 17_07_2018 , 10_15_41.jpg

Screenshot - 17_07_2018 , 10_26_03.jpg

Hardware IDs.zip (3.5 KB)

@Fiox89 :
As soon as I have the reqired time (not before this evening) I will try to create a mod+signed Intel Serial IO driver, which may be usable with Win7.

Thank you very much Fernando, for any additional information ask me as well

@Fiox89 :
After having read all your posts and looked at the inserted screenshots it seems, that the devices, which are connected to the Serial IO ports of your system, don’t have a driver problem, but a problem with the resources (2 of them are trying to use the same resource).
Please try the following:
Uninstall the yellow flagged Intel Serial IO device from within the Device Manager, unplug all not absolutely required devices (incl. the mouse), reboot, look into the Device Manager and report what happened.

off-topic:

Can I deleate the Forum member with the nickname “fiox”, which seems to be you as well?

@Fernando , this is correct, but I have to clarify.

This piece of hardware that you can see yellow marked is the ELAN1200. This device appears only installing the Serial I/O driver from Easy Driver app, otherwise it’s not present in Device Manager. Then, since this appears to be the mouse driver, I tried to install several different Elan1200 drivers, without success.

Now the system is clean, new installation, and this is what appears if I just install the mentioned Serial I/O driver from Easy Driver app.

I do not know what happens when I install this driver, but as you can see from screenshots 2 and 3, there are two devices that seem to share the same name Serial I/O A161, but have different Hardware IDs. I think this is the reason why the system refers of a resources conflict.


off-topic:

Please do it! I probably had a really old account that I did not remember existed, I’m sorry!


Cattura.PNG.jpg

screenshot_2.png

screenshot_3.png

@Fiox89 :
Since I am not able to extract the ASUS Touchpad driver from the ASUS package named “Touchpad_ASUS_Win10_64_VER11018.zip”, I need the “pure” ASUS Touchpad driver from you.
Please boot into Win10, open the Device Manager, expand the section "Human Interface Device (HID), right click onto the listed device name “ASUS Precision Touchpad” and choose the options “Properties” > “Driver” > “Driver Details”. Note the name(s) of the driver(s).
Then run the Windows Explorer and open the folder C:\Windows\System32\DriverStore\FileRepository and search for the first letters of the driver you have noted.
Open the related subfolder, put all the files, which are in the folder, into a *.ZIP or *.RAR archive and attach it to your next post.
Thanks!

@Fernando , attached to the post there are the zipped folder and a screenshot of the driver actually used in Windows 10.

Thank you!

asusptpfilter.inf_amd64_d26fce47b9355d08.zip (60.5 KB)

driver_asus_precise.jpg