[Request] Win7 compatible NVMe RAID Driver for Intel Z390 Chipset

Hello. i9-9900k, taichi z390 I am using Windows 7.
I was using the 970 evo +, but after purchasing an additional one, I configured raid0.
However, it is not recognized because there is no driver.

Windows 7 x64 bit ssd can get raid0 driver?

Edit by Fernando: Thread title specified and customized

If you want to boot Win7 off the NVMe RAID array, it will be very difficult.
Try to check the HardwareIDs of the RAID Controller (by running Win10/11).

Try this driver

Win7x64RS.zip (5.82 MB)

@kgbab :
It is very unlikely, that an AMD RAID driver will work with an Intel Chipset system.

@Lupine :
As a result of my own tests with an NVMe RAID0 array I generally do not recommend to use such configuration as system drive.
1. The risks are high to get a not bootable system (caused by the failure of a RAID member or just by a not properly working boot procedure).
2. You will not even recognize a performance boost while working with it (unless you are reading/writing extremely big sized files while doing tasks like video encoding).
My opinion: The very limited performance gain is not worth the risks of a not bootable system.
If you want nevertheless to create a bootable Intel RST NVMe RAID0 array, I recommend to load/integrate the Intel RST RAID driver v15.9.8.1050 WHQL.

You are right I did not notice that it is an intel system


This is the hardware address taken in Windows 10.
Is this the hardware address you are looking for?

The device in the picture came out of Windows 7, but the raid0 D drive that was normally recognized in Windows 10 did not appear.


This picture is the device hardware address for raid0 volume in disk driver.

This device was recognized normally by Windows 10, but not by Windows 7.

@Lupine : Thanks for the pictures with the HardwareIDs (only the ones of the Intel SATA RAID Controller were interesting for me).
The problem is, that the DeviceID DEV_2822 is just the universal one, which is externally shown for all Intel RST SATA RAID Controllers from ICH8R up, whereas the real (specific) DeviceID is hidden.
Have you already tried the Intel RST RAID driver v15.9.8.1050 WHQL as recommended by me in post #4? It is the last Intel RST RAID driver, which definitively supports Win7 and probably your on-board Intel RAID Controller as well.

Intel Rapid Storage Technology (RST) Version WHQL
I tried to install but the raid0 drive is not showing up. It doesn’t even show up in the device manager list.

Lupine >>> and you have RST mode for SATA MODE in bios ?
first must use RST sub-menu in bios "create raid0"

and install better drivers "send chipset name" ,.,.but windows 10 using 17.x-x by default ,.,.15.9 not works well .d
for most RST users "raid0" is possitible using 18.36-x-x "my RST on cm238 -example"

on 15.9.-x .,.,I had a lot of trouble in last windows 10

// and win7 using different ROM in bios if you not have UEFI !
here works Orom !


and 970 samsung ?? ,.,.here not works RST !

@Lupine : How did you try to install Win7 onto the NVMe RAID0 array? Which procedure did you use? Did you load the Intel RAID driver or has it been integrated into the Win7 Image? Which were your RAID related specific BIOS settings?
Maybe a video like >this< or >this< one will help you.


This is not true. The Win10/11 in-box Intel RST RAID driver is v15.44.0.1015, but doesn’t support NVMe.

It worked well with my Intel Z170 RAID0 as system drive.

Unfortunately none of the v16/v17/v18 platform Intel RST drivers work with Win7. They all require Win10 from 10.0…15063 up.

According to my own tests the Samsung 970 Series SSDs are working fine with the generic Intel RST NVMe RAID drivers. Do you want to see benchmark results?

I’m just saying what I know from MSI forum
and from SAMSUNG official PDF // and to many similar users and SAMSUNG + RAID problem D:

980 is OK ,.,.970 need SAMSUNG NVME DRIVERS and samsung guide says - AHCI mode ,.,.not recommended RST.

this is my experience
15.9 drivers not works on my 200series chip "remember my post here ? 15.9 drivers + 15.5 EFI ROM " on some last WIN10 - system random freezes
and Windows 10 21h1 ,…I thinks it comes with 17.x.x. at least the ones I installed last ,.,…,but it could have been my mod :slight_smile:

,.,. but each system is different

drivers and WIN7 support ,.,thanks for info

.,MBR VS GPT table ?
but I no longer remember exactly win7

win10 / uefi - GPT table
win7 - probarly CSM/legacy boot - MBR

@NeXt3R :
These pictures verify, that Samsung NVMe SSDs resp. their NVMe Controller are running fine with compatible Intel RST RAID drivers:
(left Pic: Single 500GB Samsung 970 EVO Plus, right Pic: 2x250GB Samsung 960 EVO as bootable RAID0, all tests done with my Intel Z170 System)



I believe you :slight_smile:
.,I just know that there were problems with MSI, for example

// and problem above is probably GPT disk table from win10 ,.,.and this not works on win7 ??
but I don’t remember it anymore "win7 support"

all disk must be identical ,.RAID / no- RAID
and win7 ? - MBR by defaults

The GUIMode Partition Table (GPT) is absolutely required to be able to boot off an NVMe SSD or a RAID array consisting of NVMe SSDs (only exception: Samsung 950 Pro).

I think he has to try RUFUS for USB
and possitible mod win 7 for uefi

similar way
Cannot completely install Windows 7 on Acer Predator Helios 300, G3-571 Kaby Lake

or win10 + win7 virtually "but everything works on win10 well or better"
win10 - is better win7

good luck

bios settings
sata mode: raid
disk partition: mbr

You didn’t load inf before Windows installation. Windows Install -> Device Manager “Intel(R) Chipset SATA/PCIe RST Premium Controller” device is identified as the changed version.

I installed windows 7 on sata ssd.

After capturing it as a wim file, I am willing to test it with driver integration.

I made a Samsung 970+ 1tb x2 raid0 for data storage, but Windows 7 doesn’t recognize it, so it’s a pity that I can’t play with it.




My PC is configured with a total of 3 nvme storage devices. Windows 10 is installed on non-raid 512gb, and 2 1tb are configured as raid0.

try win7 UEFI mod
,.,.but not exist reason for usage win7 "win10 is better and is possitible setup like win7"