[Request] Xeon E5 26XX v3 Turbo Boost Unlock on HP Z440

I am trying to do the Turbo Boost Unlock mentioned in this thread "[GUIDE] Haswell-E/EP Xeon CPUID:306F2 Turbo Unlock" Unfortunately, I keep running into problems and I need some help. Originally, I could not dump the BIOS with FPT but once I moved a jumper on the motherboard it allowed me to. So, I then went into the image and edited the microcode and installed the FFS driver mentioned in the thread. It looked like there was no way for me to flash this using software since it was blocked, so I used a CH341a. After I flashed the modded BIOS, the computer would not boot giving an 8 beep code which means that it failed the checksum verification. So I need help disabling that in my modded bios and also checking to see if I did all of the other steps right.

Not sure but after the mod the file also should be flashed with Intel FPT… this is the problem in OEM machines like HP and their security in bios.
Now i do think u need to restore original bios with CH341… and here also lies some issues… an extracted original bios file (Its blank, so ull loose ur original system data ID) or the original FPT dump (Contains original data ID)
Its gonna be a headache for sure… better see all threads regarding HP Z machines.
Good luck.

EDIT: Good then , those FFS belongs to another source outside Win-Raid… i cant help here on this issue.

No I already restored the original bios, the system works now but I still want to do the mod. I had a backup so I did not lose anything

Well if someone else could help me that would be appreciated, I have already looked around the internet for more info

could you dump the entire bios using intel fpt and send it here? maybe someone could help with it.

I already have a dump of it, I’ll upload it in a little bit.

I would upload it but it has machine specific information (product key, mac address, etc). How do I remove that before uploading?

OK I have a solution; I have prepared a BIOS Region image from the HP website with my mods to upload here (so no personal info). I want someone to take a look at it and see if I did the mods correctly and try to remove the checksum verification that caused the computer not to boot after flashing previously. Then make a post telling me what you did so I can copy the modifications on to my personal BIOS dump

HP Z440 BIOS 2.57 (HP WEBSITE VERSION) With Turbo Boost Unlock https://drive.google.com/file/d/1bORjaoI…iew?usp=sharing

Maybe @Sweet_Kitten you could help?

Not sure. I can try once.

HP Z440.zip (4.72 MB)

Ok what did you do to it?

Tried to avoid reset register from being executed in "SecureUpdate" BIOS module.

So does that bypass the verification thing that causes the computer to give the beep code? Can you describe what you did so I can replicate it myself because like I said the file I sent was just an example one, not the one from my personal machine.

Don’t know.

No.

Well the thing is the file was just an example BIOS for this model, so I wasn’t planning to flash this to my computer because 1. Its the image from the HP website that lacks my system specific information and 2. Its just the BIOS region and I can’t flash specific regions which the CH341a, I have to flash the entire thing. I need to see what you did so I can replicate it on the full 16mb dump from my system. Could you send some screenshots of the modifications you did if its too hard to describe?

HP Z440.jpg

Oh it seems like they changed that PE32 image between the version I uploaded and the one thats actually on my pc. I will send you one from HP that matches the version on my PC. This one doesnt have the turbo unlock mod but thats fine because I all I need to know is how to bypass the security. https://drive.google.com/file/d/1Yt2cFmI…iew?usp=sharing. So can you do the same mod you did on the other one and send a screenshot?

Also another thing, I want to figure out how to disable Protected Range Registers. I already have removed the BIOS lock by moving a jumper on the motherboard but if I am able to do this I will be able to flash with FPT which will be more convenient than using the CH341a. I saw another thread where you mentioned a way to do it involving EFI shell. Could you describe it to me?

HP Z440.jpg


Variable edititng via EFI shell is blocked on most of HP computers.

Well the Z440 is a little bit older, from 2014 or 15 I think so it might not be as locked down.