Requesting a modded vbios for Rtx 2070 max Q

Hi there,

Im new to the forum i am not sure if this is the right section to request a vbios for my rtx 2070 max q in my sager/clevo. Any help is appreciatedt this is my original vbios if someone can mod it for me and unlock it so i can increase the voltage and push the clocks more that would be great thanks

@kingkaan - Please link full motherboard BIOS. How did you get the file you linked above? Is this GPU-z dump, or you pulled from board BIOS? It’s not standard size, this is mainly why I asked, but also need to know too.

* Edit -
TU106M.rom - Power Slider Adjustable - Only change
TU106M2.rom - Above + Thermal & Power Limits increased using app "preset"…451986317766474

I do not know if these are safe to use, only test if you have flash programmer in your hand and a valid backup made and checked to confirm it’s proper and complete.
This tool was used (Downloads in the releases tab), it’s the only one I found compatible -
Discussions/reports back of tool usages -…-thread.806161/

Yes, I’ve got the vbios from gpu-z dump. do you still need the full motherboard bios? when i was dumping it i had my overclock settings applied in gpu tweak 2 maybe that’s why its not original size? i only have experience flashing the kepler and maxwell cards with nvflash i do not know if the process is the same with these cards at all…maybe when ever you have extra time on your hands you can walk me through it. thank you, I appreciate your help.

No, no need for board BIOS. You can’t flash that BIOS probably, it’s not standard size, so tools will tell you no, I assume. You may need to dump BIOS again, with whatever tool you planned to flash that in with, then give me that instead to edit (or you can edit with tool I linked)
No, your settings changes wouldn’t make the file size change. I assume NVFlash would be what you use, make a backup with that and send to me to inspect, if it’s 1023KB then go ahead and try to flash the above ones then, but be ready to recover from another card

When flashing I get a version missmatch error and therefore I am not able to flash it.

You may need to use the nvflash mismatch version.…om-bios.248769/

Or dload an unverified bios from

Then open it up with the above tweaker app n check what’s on it n make adjustments suitable to what you want. I noticed the file TU106M2.rom file above has the tpd set to the desktop cards which I don’t think is suitable to the laptop. Again use tweaker app to check what’s on the bios.

I want to go back to the original as the tweaked one is NOT working at all, it has broken my mini dp and also it has overclocked vram and therefore is artifacting, the performance is also a lot worse than with the original one but when I am trying to go back to the original I get missmatch error with the missmatch bypassed version!

Please I really need my laptop back @Lost_N_BIOS any help please?

Now I get code error 31 and I cant use my dedicated graphics card…

For anybody interested: nvflash64.exe -6 filename.rom

@Brask did you make a copy of your bios before you flashed it?

if so just reflash with that bios.

if not go to and see if its there

Thank you, I had done a backup yes, and I reflashed it with

@Lost_N_BIOS , i wanted to know if u could help me with this too, or give ur opinion about, i got a file from a msi 115w rtx 2060, and mine is set to 90w, as i said is the refreshed 2060 mobile, so can u look the files and see if is compatible? and tell me how i could flash this in my rtx i think about of…match-disabled/ this software, and if this fail by software could i put my original bios back by rewritten in the same bios chip? or have another chip just for vbios?

edit: in the site i found it, the guy tested the bios in a clevo, that is from where my laptop is too just with another brand wrote on it in case (Avell)

msi and original (1.19 MB)

gpu z (77.9 KB)

@Lonely_wolf - You can’t modify modern Nvidia BIOS. As far as compatible, sorry, I can’t help you with that, you’ll have to google around and see if anybody did the crossflash you are considering.
If you have 2 graphics cards, you can always write back your original vBIOS if flash fails/bricks etc, you just boot to DOS or windows with second card and then flash first one back.
Sorry, just realized you’re talking laptop! I would not attempt crossflash unless you have flash programmer, and programmer backup of original BIOS (software dump will not be complete)
And, I would not waste my time trying that, unless you already know for sure it works on yoru exact laptop model (vBIOS for laptop are hard configured for the exact systems they are in, so would be rare for other model/brand to work for you, certain display outputs may fail, or may just fail in general etc)

@Lost_N_BIOS so i got some couple of pictures of my laptop opened and u mentioned in pm the chip that have vbios is similiar to the that holds bios too, if u could give a look in the images i got, and the vbios chip is usually close to the gpu? or depends to motherboard to motherboard?

link:…t7d?usp=sharing the chip with red tint (it came from the factory) is the chip bios i already showed before to u.

and u mentioned about lose some ports, like losing hdmi or minidisplay port, and that for me wouldn’t be a real problem if i could boot later the original vbios if i needed, my only worries was about no possibility of recovery it like its doesnt appear video anymore and i dont have anything to do about it.

@Lonely_wolf - Yes, usually it’s close to the graphics card, if not on the card itself. Usually, if the card is not part of the main PCB, then the chip will be on the card itself, and you may need to remove it to see the chip on the other side of the card.
Yes, loss of display ports or even LCD output is possible, if you flash in vBIOS that is not from card sold with this exact brand and model. Sometimes you might get lucky and LCD, or other output works OK with other BIOS, but that would not be a usual thing.
If you flash in a vBIOS that is not compatible, system will be effectively bricked (due to no display out), so yes you would need to fix via programming in your origi9nal vBIOS dump that you made with programmer before you tried other vBIOS.

I checked the images, and can’t see anything in those. You will need to remove the heatsinks and show me image of the graphics card itself, and the board with all the heatsinks removed
Then you may also possibly need to remove the graphics card and show me the other side of it too, if we don’t see the chip on the board or front side of the card.
Do not do any of this, unless you have thermal paste to repaste both the GPU and CPU after you’re done taking the images.

My suggestion to you is to leave this alone, until you have a flash programmer in hand, and have made a backup of the current vBIOS and someone checked it to be sure it’s valid dump.

@Lost_N_BIOS Yes actually i am looking for make this backup and find where this vbios chip is, if i dont got progress on finding the vbios chip and having a valid backup, i will just leave it alone. my gpu is already pretty decent, the only thing i could have with more tdp is maybe a better overclock and it have the perfomance of a rtx 2070 max-q or the old 2070 (all laptop version)

Thanks :smiley: i will re open it probably this week and take some picture of it.

@Lost_N_BIOS hey man i finally opened my laptop again and i took some pictures of it i found a chip smaller but 8 pin too close to my rtx 2060 i tried to use a command to dump sudo flashrom --programmer ch341a_spi -r backup.bin\ but this returned me a error (i will put the picture too)

link to pictures…Vdg?usp=sharing

if u confirm me that this is my vbios chip so i will probably buy antoher ch341 and test it i think its broken this one

@Lonely_wolf - Sorry, I know nothing about dumping with flashrom. That may be OK command, but you maybe need to have power connected to system, main battery and or PSU Cable, (or removed)
I doubt the CH341A is the problem, probably you just need to find if this model needs power connected or not, and or get the clip on there just perfectly. Some boards/things, need the chip removed and put in adapter or clip, before you can read/write to them, but that is very rare

That chip GD25LQ80 is 1.8V chip, so you’d need 1.8v adapter to connect and read/write to that. Let me know if you need a linked example

@Lost_N_BIOS yes i would like a example

@Lonely wold - OK, this is example of what you need, but you can find other places too, or shipped faster on ebay for more $$ etc

@Lost_N_BIOS do u have a tutorial with images of how i can use it?

this would work?…-_JM?quantity=1