Resizable BAR Added to Z97-G43 H.B bios

Maybe one of the users modified the bios for MSI Z97 G43 ver H.B?
This is a nice board with PCI slots. I’m trying to run Arc 770 on it. Currently, it doesn’t give a signal to the monitor.
Tested on Ryzen 5 3600 and MSI B550 and it was ok.
I don’t know if it’s the BIOS’s fault and the lack of ReBAR support.

Thanks in advance for help.

Most probably the issue is not REBAR.
Does the symptom occur in both modes, UEFI or Legacy (CSM On)?

EDIT: Bad luck… a huge gap in hw generations. Did you reset CMOS and tried another PCIe slot?
There’s a beta bios H.B0 (V17.11 11/23/2016)… but only refers as notes, supporting external TPM2.0 module.

Both black screen.
Windows starts on Iris 6200 but gpu z dont see arc 770 only Iris.
Power supply 650w.

Beta bios H.B0 ?
I don’t see it on the website msi.

No, you don’t, it’s from the German MSI Forum
Station-Drivers - Z97-G43
Right-Click, save link as.

EDIT: You may also take a look here, regarding ARC FW

i saw one report of Arc not working without rebar but it’s most likely not the case

You probably need to disable CSM and other legacy stuff, Arc GPUs work on even older systems btw.

1 Like

UEFI enabled.

Finally Arc 770 with I7 5775c works on MSI Z97 G43.
There was a problem with the pins. I was about to give up.
But I tilted the card slightly and it worked.
Still need help with Resizable BAR.

Ok, the beginnings are difficult.
I will try to find if the bios can be unlocked
4g decoding.
But AMIBCP does not read BIOS ver 4.53 and 5.02.
Or I’m doing something wrong.
BIOS 7816vHB

Try this bios and boot to full Uefi: Z97G43Mod.rar (6.0 MB)

For Above 4G Decoding, your varoffset is at 0x1, follow this guide from step 5 to enable, and dont forget to Disable CSM or set boot mode to UEFI only (no legacy stuffs except legacy usb), then go to modded efi grub and follow the guide to enable Above 4g Decoding. First you gotta disable it and enable it (which means setup_var 0x1 0x0, press enter, type reboot and press enter, repeat again but this time setup_var 0x1 0x1).

After you finish, go to Device Manager > View > Resource By Type, and see if there is Large Memory Tab. If its available, open this app as admin and set it to 13 first, enter, and reboot.

If everything successful, go to Device Manager > View > Resource By Type again and see if your gpu is listed in large memory, and then gpuz > advanced > vulkan and see if memory heap is all 8gb, no 256mb heap.

Thanks a lot.
Today I will try to test it.

1 Like

M-Flash does not see the E7816IMT.HB1 file in the BIOS.

I am renaming it E7816IMS.HB1

And then I’ll try.

1 Like

this bios is based off the HB0 beta that supports tpm 2.0

M flash gives information that the HB0 beta bios is broken.
Maybe it’s better to modify the HB version?
7816vHB (1).zip (6.0 MB)

Ok, I tried this bios and it failed.
Brick bios.
I went back to the H.B. version.
Someone help to unlock for Above 4G Decoding ?

sorry for the late reply, but i might able to do this mod later. I’ve been selling my pc parts for an upgrade so yeah :sweat_smile:

Here, test this (based off Bios ver H.B): Z97G43HBr.rar (6.0 MB)

Again brick bios.

After 15 min

now there is a big problem.
What now ?

And same

I’ve never seen anyone get Boot Guard error using ReBarUEFI, not sure what can be done to workaround this ? Even other MSI Z97 boards didn’t get it.

Anyone else on this forum know how to fix this ?

EDIT: Seems like you can see boot guard regions with UEFITool NE, I think uncolored regions are unprotected so you can insert ReBarDxe there.

Can’t find any information about meaning of cyan but red obviously means locked.

Yeah that’s something that i really cant recall seeing… but i think it’s better wait for the user that provided the mod file to this user…
I have my doubts that this is direct related to your ReBAR DXE driver… i can be wrong.