Samsung 840 RAID0 + HDD not in RAID on Asus P5Q

I just spend a couple of hrs in this forum reading about RAID0 on old boards and BIOS Modding. Great stuff so far! Since I’m not 100% sure what to do in my current situation I got a question about my specific setup.

I use a rather old ASUS P5Q w/ Intel P45 chipset and unfortunately just SATAII. I’d like to transfer my system from my current HDD to a new Samsung 840 Evo SSD RAID0 and use the old HDD as an internal storage for backups. I run the latest official Asus BIOS Version 2209 currently in AHCI mode for the SATA ports. Unfortunately I just found the option to trigger the mode between AHCI and RAID for all SATA ports, not just for those two SSDs individually. Is there an option to run my intended setup SSD RAID0 + a normal HHD?

Furthermore I read your posts about RAID0 TRIM support /w a modified BIOS. I’m not quite sure which of the mods I need, how I do a backup of the current bios and how to apply the mod for RAID0 TRIM. I read ur description & downloadpage AHCI & RAID ROM Modules but also heard that the P5Q has not enough space for big BIOSes. So I’m a litte confused what to do without burning my system. I also overclocked my Intel Q6600 to 3Ghz /w some BIOS adjustments. Would be a bummer if I’d loose those after an update. I’d love to get some advice :stuck_out_tongue:

All the best from Aachen, Germany
Julian

@ youngpilot:

Hello Julian,
welcome at Win-RAID Forum!

Since you cannot set the SATA mode of the different SATA ports individually, your HDD will run in RAID mode as well, but this is not a problem.

According to >this< BIOS modding success/failure table you will be able to successfully insert the TRIM in RAID0 modded Intel RAID ROM v10.1.0.1008.

Each flashing of a new BIOS (original or modded) will erase all previous BIOS settings. So you will have to redo your special BIOS settings anyway.
According to my experience the overclocking possibilities of a RAID system are very limited. You must find it out once your updated syste is running.

Greetings from the North Sea
Dieter

Thanks Fernando for your fast answer!

I spent the last night updating my BIOS, reinstalling Windows, all the Programs and Updates. Unfortunately I was not able to move my old System from the HDD to the new SSD RAID0. All “moving tools” required me to boot up the System on the HDD, but therefore I had to set the SATA mode back to AHCI, which disabled the SSD RAID. So I tried some other configurations of the additional two Drive Xpert SATA ports, which are intended to be configured separatly in the BIOS. But even after reading manuals and tips from forums the BIOS option stayed greyed out - no matter which or how many devices I connected. So I saw no other fast way then reinstalling w/o a data move by a portable system.

I also found an already modded BIOS for the Asus P5Q Mainboards at this page http://www.xtremesystems.org/forums/show…xe-Premium-BIOS. It works flawlessly and even maintained all my BIOS settings. Awesome! But I’m still not 100% sure if TRIM really works. TrimCheck 0.7 says its not working and I know no other easy way to test it. How can I check if TRIM works, and if not how to enable it?

I read a lot about RAID0 drivers one should include when installing Win 8.1 but so far did none of that. I configured the RAID in the Intel Rapid Storage Manager which popped up after the POST. Then formatted the volume within the Windows installation. I just read your [Guide] Integration of AHCI/RAID drivers into a Win7/8/10 image. And it seems to me that i ran into that exact problem. Luckily i did not downgrade those drivers yet. Need to reinstall everything again? damn it :confused: Why those standard drivers wont do it? Should i just try a downgrade anyways?

Just tested the speed a couple of times and attached the CrystalDiskMark results below. I think they seem legit for an SATAII RAID0 of two 120GB 840 Samsung EVO SSDs. What do you think?

2015-03-07_051850.png

What do you mean, when you write “Windows”?
It is not easy to help users, who ask for the “best” Intel RAID OROM/driver combination, but don’t let me know the OS they are running.

TRIM cannot work, because the modded BIOS you have flashed doesn’t contain a TRIM in RAID0 modded Intel RAID ROM module. I just have checked it: Within the modded BIOS is the original Intel RAID ROM v11.2.0.1527 and not the TRIM modded variant.

Have you already done a look into the start post of [url=http://www.win-raid.com/t24f34-Easy-TRIM-test-methods.html]>this<[7url] thread?

Yes, the scores are fine. Nevertheless you may get even better results after having installed the Intel RST driver v11.2.0.1006 WHQL.


I’m using the latest Windows 8.1 Pro x64 Build 9600 including all recommended Updates by Microsoft. Last night installed Windows 8 and afterwards updated to 8.1.


Oh man, I didnt saw that last night. Thank you! Just patched to the TRIM modded version 10.1.0.1008 you provided and installed the Intel RST driver v11.2.0.1006 WHQL on Windows. TRIM Check 0.7 now reports that TRIM is working & no stability issues so far. You say TRIM mod v10… works best w/ driver v10…!? Is Intel RST driver v11.2.0.1006 WHQL fine or should i try the v10 one?

Actually the speed increased a little bit. I attached the CrystalDiskMark sshot w/ current setup again. Intel Q6600 @3Ghz CPU load during the read/write test is 1-45% but most of the time at 5-15%.

sshot-1.png