Samsung laptop limits SATA3 speeds to SATA2 only?

Hello everyone.
I have this issue for a year now and it was a great pleasure to find this forum.

I am the owner of Samsung NP300E5Z-S05RS laptop. Here are the specs:
Intel i5-2540M (initially it was i3, but I upgraded it recently)
HM65 chipset - Sandy bridge platform
8GB DDR3 Ram
Biostar S100 480 Plus SSD

So, problems started when I replaced an old HDD with the new SSD. When I installed Windows, I found out that SATA GEN3 mode is turned off in BIOS (AHCI was still turned on, of course). When I turned it on, I started experiencing system hangs (system freezes). At that moment, I am only able to move the mouse, without possibility to click on anything or use the keyboard. The only solution then is to forcefully shutdown the laptop by pressing and holding the power button, which is not very good for SSD or other components as you know.

After numerous system reinstalling, and experimenting with various drivers (including all official versions and Fernando modded version), I managed to run Windows 10 x64 on my laptop with decent speed and stability, with Intel RST v11 official drivers (which are recommended by Fernando). Sometimes I experience freezes on boot screen, which can resolve after couple of minutes (or rarely not at all), but that’s not happening very often and it is acceptable.

Recently, I installed CrystalDiskMark and HWInfo64, which gave me information that are on the pictures below: that my SSD is running on SATA2 speeds, although it is capable of running on SATA3. On some forums, I found out that some laptop manufacturers (like Panasonic) intentionally limit the SSD speeds, in the name of system stability and prevention of overheating the components. Does somebody have experience with this kind of problem?

My BIOS version is 09QB and Samsung Update says that it is up to date.



Thanks in advance

Since I cannot even find a BIOS download for this model, we’ll start here. We can probably change from grub using setup_var, but I can’t give you info on that until I can look at your BIOS

Check BIOS main page and see if ME FW version is shown, if not then download HWINFO64
Then on the large window on left side, expand motherboard and find ME area, inside that get the ME Firmware version.
Once you have that, go to this thread and in the section “C.2” download the matching ME System Tools Package
(ie if ME FW version = 10.x get V10 package, if 9.0-9.1 get V9.1 package, if 9.5 or above get V9.5 package etc)
Intel Management Engine: Drivers, Firmware & System Tools

Once downloaded, inside you will find Flash Programming Tool folder, and inside that a Windows or Win/Win32 folder.
Select that Win folder, hold shift and press right click, choose open command window here (Not power shell).
At the command prompt type the following command and send me the created file to modify >> FPTw.exe -bios -d biosreg.bin

Right after you do that, try to write back the BIOS Region dump and see if you get any error >> FPTw.exe -bios -f biosreg.bin
If you do get error, show me image of the command entered and the error given
^^ This is important step, don’t forget ^^

If you are stuck on Win10 and cannot easily get command prompt, and method I mentioned above does not work for you, here is some links that should help
Or, copy all contents from the Flash Programming Tool \ DOS folder to the root of a USB Bootable disk and do the dump from DOS (FPT.exe -bios -d biosreg.bin)…creators-update…menu-windows-10…ator-privileges

Or here is simply registry edit that adds “Open command window here as Administrator” to the right click menu
Double-click to install, reboot after install may be required…134606820377175


It is impossible to find BIOS download, it is only limited to the Samsung application for bios updating. It is a Phoenix bios variant. My Intel ME firmware version is 7.1

I was not able to do it from Win10 (I get Error 103), but I managed to make the DOS bootable USB and do it from there. I ran FPT.exe -d and FPT.exe -f command right after that. When I ran FPT -f command, everything went successful but I got some notice that “PDR Region does not exist”.

Here is the biosreg.bin

Hello everyone

Unfortunately, I started experiencing random system hangs (at the boot time mostly, when windows logo appears). I will keep these under SATA2 conditions until I find out if it is possible to modify bios somehow. Thanks

Latest bios:…nts?platformID=QB&PartNumber=AAAA

gives you som XML information:


take ITEM_20130312_817_WIN_09QB.exe:…17_WIN_09QB.exe gives you an exe- file contaning the bios region and tools. Run the file, you should be able to find the files of the package in your temp folder.

SATA3 schould be possible on port 0/1 (HM65 has in some revisions an error on ports 3 to 6). I own a NP300E5A, HM65, bios 09QA, which doesn’t have any problems with a SSD on port 0. Are you sure that all connections er OK? Cable OK? SSD OK?


I ran the file but it just said that my BIOS version is newer that the one included in the file.
I am starting to think that maybe the cable is the issue. @lfb6 please run HWInfo64 and send me the screenshot of SATA AHCI controller description, I am interested in speed that is running on your laptop. Thanks in advance

There’s no newer bios tha 09QA/09QB. Only difference between QA and QB is Windows 8 license information included in QB. There’s no difference with a Samsung 850 evo 500GB, which was installed earlier.


Thanks for the screenshot. I am getting a new Kingston a400SSD (for another laptop) in two weeks. I will post my results here!