Sata 3 write speed problem with SSD

Hi guys;
i would like to ask strange question.
i have 2 diffrent ssd s 128gb. one of them kingston the other corsair gs series both have theoric have 400mb write and read speeds.
i was tried both on my mobo which is MSI z77a-GD65 on sata 3 and also my msi gt 780dxr laptop which also had sata 3 support
the strange thing is i could never able to reach over 130mb write speed. but read speeds mostly 500mb/s and everythings ok with it.
tried to change my cables. also tried with windows 8.1 and windows 10. nothings changes. series 7 chipset have 13.10.2126 raid with realied drivers. also series 6 chipset had 11.9 bios .
any suggests?
Thnx
Regards

@ article15:
Welcome at Win-RAID Forum!

Maybe you forgot to check the “Write Caching” options of the SSD from within the Device Manager. For details please look into the start post of >this (AHCI)< resp. >this (RAID)< thread.

Are you running your Intel SATA ports in RAID mode? If yes, have you created a RAID array by using both different SSDs as members?

Regards
Dieter (alias Fernando)

Thnx for reply Fernando.
and yeah i have checked write cache.
and yes i am on raid mode but i didnt create raid with ssds but i have raid 0 with 2 7200 sata 6 supported drives.
but ssd works as os drive.
Also i would like to thnx for perfect guide for intel raid drivers and rom update tricks ive learn so much.
ah before forget also for my raid drives writeback allready choisen.
so any suggest?
regards

Not really.
It doesn’t make much sense for me to create a RAID0 array with HDDs as members, but to put the OS onto a single SSD, which is running in RAID mode, but not a member of a RAID0 array.
If you should break the RAID0 array (after having done a data backup) or if you should have another on-board SATA Controller, you can choose a better performant combination.

Thnx again for answers Fernando.
I was tried same test with Sandisk and everythings was fine. i was able to see 300 mb/s so that means i was choose wrong ssd at first place…
regards