set value for igpu amd to 512mb in bios F.2A Rev. A

As is known when adding more RAM the igpu takes memory automatically from the ram, I would like to set the value to 512mb from the vram

my laptop:MODEL:hp g42072la-cpu:a105750m -igpu:8650g-dpgu 7670m (1gb) 8 ram dual channel

here a user from another forum succeeded but an intel igpu and mine is AMD…0-w-Insyde-F-2A

@sagael - So, you want to set 512MB, but that is not what is currently set! I gotcha now, thanks!
Please dump vars how I mentioned to you initially. Also, please link me to the exact BIOS download page for this model.
If you cannot find BIOS download page, then download this tool (ignore any virus warnings), and run, then save once it’s done. You cannot move the window once it’s open. Open it as Admin, then click read, then backup and once it’s done close the window and BIOS will be in folder (Send me this)…up_toolkit.html

@sagael - Thanks, what is the exact model, so I can keep this BIOS in a proper folder. Or, also, please link me to the page you got the above link from
* Edit - Actually, also do the above with Universal BIOS backup toolkit too, I need you to dump your BIOS so I can see which is your systems because this EXE contains BIOS image for two different variants. Or, maybe I can tell if you show me image of your BIOS MAIN page…8/model/5282698

picture bios here rec 3.7

H20UVE-Get2.rar (824 Bytes)

Thanks! I think you missed my edit above.
But anyway, due to these BIOS being encrypted, I need you to dump your BIOS with Universal BIOS backup toolkit, then I can use that to modify vars for you, or show you other way to change the setting you need to edit.

* Edit - Also, no vars.txt in the above linked package, did none of those versions work?

about var that’s all he gave me

Insyde-F.2A.rar (2.27 MB)

That’s a bad/corrupted dump, is this system bricked and not booting? If not, then this software is not compatible to dump your BIOS.
Let’s try this, here is stock flash package contents minus both BIOS images, please run InsydeFlash.exe and show me image, do you see a backup function?

If not, then you will have to get flash programmer and dump chip directly

What? That means you can’t flash that BIOS to your system too!? Please try it again, but right click exe and choose run as Admin
If same, then run the sp77491.exe and see what it shows you. Don’t hit start/flash, if possible, we just want to check to see if it errors too. If so, it may be a windows issue, you may need to use older OS or something.
Yes, I just tested on XP in virtual machine, and it runs for me there (with some errors), but it shows all buttons, not shown in your image such as Browse to file and options

See if either one of these will run for you -

I tried even the hp exe the same error as the first one

in this other version it gives me the following

I will try with this solution I am downloading give me a few minutes…OS/td-p/6928741

@sagael - Since stock EXE fails too, this is probably Win10 issue, and you need to use XP or Win7
For the versions I sent you, did you try both, and they both give same error above? If yes, please test, cut and move "platform.ini" from that folder (put on desktop for a second, then put back later when you are done)
Do you get same error that way, or can you then see options? If you see same, or no options, put "platform.ini" back in folder, open it with notepad and find >>
Flag=1 << Change this to 0, save and try again

Also, when you do above edit, also make this change >>
; Supports on WIN flash.
Flag=0 <<< Change to 1
;Flag (wW)
; default : 0.
; 0 : Auto flash mode.
; 1 : User option mode, including option, start, exit buttons.
; (Option button will disable on secure flash mode.)
; 2 : User flash mode, including start, exit buttons.

i edit notepad showme this

Great, now click options, what do you see?

* edit -
Edit platform.ini again and add this, see if it makes backup after you open program. if not, use 5.13 version, it already has this in platoform.ini (you will need to make same edits (above) as before again too)
;Flag default : 0.
; 0 : No backup BIOS.
; 1 : Backup current BIOS and new BIOS binary.
;FilePath default : empty.
; empty : Use current directory.
; String : Directory for backup BIOS.
;FileName default : empty.
; empty : Use platform ID as file name.
; String : File name for backup BIOS.

If no file created, try same again, but edit this instead from above, and then check ROOT of C drive for BIOS backup.bin

Thanks! Nothing useful there, see my edit above about backup.

Also, try to run this CMD from same folder with EXE (Run CMD as Admin) >> H2OFFT-W.exe backup.bin /g
If you do not know how to run Admin CMD prompt from exact location, install this registry fix and you may need to reboot before it wo, then you can click anywhere inside folder with EXE and choose "Open CMD Window here as Admin"

I see the same I send you the ini file to check the steps

the other version gives me an error even with the notepad edit use win 8 or 7 try to select compatibility in both

platform.rar (10.2 KB)

Did you try to run command instead, that I mentioned above? This would be quick and easy way.
Platform.ini above looks good, but add a space between that last section and your addition

say file backup not found ,i try install sp107493 if will work

Did you try both ways? Edit platform again and add C: to path, instead of blank path? Did you check the folder you ran from, backup would be there, if made. Then once you add C: it will be made at root of C:, if it gets created.

Do not install any new BIOS yet, but see if that will run properly. If it does, close exit, don’t flash, if that is an option. Then, we will edit platform.ini and make backup while it flashes in the update.
To do that go to where ever it extracts the exe (ie C:\SWSetup\sp107493) and edit platform.ini there and edit the backup section or add it if missing etc.