[Solution] Win7 drivers for USB 3.0/3.1 Controllers of new Intel chipset systems

Great, thank you for the reply. I am trying to find it. It is clearly identified in that thread as Realtek USB Audio, or is the audio driver bundled with the other USB driver package? I have not identified a post with a link to Realtek USB Audio driver yet.

Edit: @canonkong - I read every post in that thread and could not identify a link making reference to Realtek USB Audio driver update or a link for it. Search does not seem to work well for me on this new forum.

1 Like

Download that AMD driver package,it include the XHCI,Realtek Audio,2.5G/5G/10G network driver that intel platform needs.

4 Likes

OK, thank you for the clarification.

Edit: perfect, thank you Brother @canonkong the Realtek USB Audio drivers installed nicely. Better than using the Dell Dock driver that I had been using. I appreciate it. :+1:

1 Like

I’ve been trying to install Windows 7 on my Acer Travelmate B1. I get “A required CD/DVD driver is missing” error when I try to install it from a USB stick. From what I can tell it’s because I don’t have an appropriate USB driver. The onboard USB controller is a part of a Gemini Lake SoC chipset.
Here are USB controller’s Hardware IDs:
PCI\VEN_8086&DEV_31A8&SUBSYS_129F1025&REV_06
PCI\VEN_8086&DEV_31A8&SUBSYS_129F1025
PCI\VEN_8086&DEV_31A8&CC_0C0330
PCI\VEN_8086&DEV_31A8&CC_0C03
Is there a modded driver that would work with it?

Hello all, i want to buy this barebone mini pc and add a 9100T with a UHD 630, mainly for daily usage and some light games:

,but the only version they have is the one with the chipset H310 and i read here that is not supported by official drivers. Before i buy it and build my backup system i want to be sure i can install properly win 7.

I already have a modified usb image of windows 7 x64 pro with last AHCI 15.9.8.1050 drivers and last Intel USB 3.0 eXtensible Host Controller 5.0.4.43v2 i manually dismed into install.win and boot.win packages, but for what i understand they aren’t supported with this hardware.

Can someone give me some tips and link where i can download the modded drivers i need to properly /dism into my win 7 x64 pro image?

Tried to read into this huge topic but i’m a bit confused and some drivers are missing or removed and i have no idea where to found them. Thank you.

Thanks a lot for the help,
but unfortunately the “AQNIC 10G” driver in the “AMD Ryzen driver package” do not seem to work for my

" Marvell FastLinQ Edge 10Gbit Network Adapter (AQC113CS)"
PCI\VEN_1D6A&DEV_94C0&SUBSYS_87F51043&REV_03
on Asus Z690 motherboard

Do you know if there is any driver that could work for windows 7 for this adapter?
it seems to need the latest Marvell AQtion Windows 64-bit Driver 3.1.6 for part number “AQC108” (it includes AQC113C drivers inside)
but it does not exist for Windows 7…

i really want to find a solution to use this AQtion10G adapter with windows 7…

ftp://fudi.internet-box.ch/NT%206.1/mobile%20slipstreaming/
Username: nutzer
Password: 132
has been unable to log in to your FTP, please check.

Hy i2i8, nice to read your request.
What browser aure you using ? Afaik chrome does not support ftp anymore at all, I tried it with Internet Explorer 8, the version that Windows 7 comes preintegrated, that’s why just this version. I assume you try it again with Firefox or another browser/software.
Let my know if something works out for you.

Hi guys.
Please help me with the drivers for Asus prime H370 plus. I can’t install windows 7, mouse and keyboard stop working at this step of installation showing in picture below
win7png

Here are USB controller’s Hardware IDs:
PCI\VEN_8086&DEV_A36D&SUBSYS_86941043&REV_10
PCI\VEN_8086&DEV_A36D&SUBSYS_86941043
PCI\VEN_8086&DEV_A36D&CC_0C0330
PCI\VEN_8086&DEV_A36D&CC_0C03
Is there a modded driver that would work with it?

@Mr_Fox Can you please provide a link to those USB drivers that have been working on Z490 as I have upgraded to Z490 recently and can not get Windows 7 to work on it?
I have been trying to get it running for weeks now and can not get a solution :frowning: .

I have a Evga Z490 Dark Kingpin motherboard and i used the signed Intel drivers form here Intel 300 series IO_USB drivers 正式版A.7z — Yandex.Disk , they worked perfectly and allowed me to setup Windows 7 with my mouse and keyboard, but on my motherboard there are two other USB ports with an ASmedia controller “PCI\VEN_1B21&DEV_2142&SUBSYS_10503842&REV_00” I used the ASmedia driver from this post [SOLVED]modify & install asmedia usb driver with specified hardware id but it only works if i boot Windows 7 with the F8 option “Disable Driver Signature Enforcement”. Using the following commands does not allow the drivers to load, only using the F8 option before booting.

bcdedit.exe -set loadoptions DDISABLE_INTEGRITY_CHECKS
bcdedit.exe -set TESTSIGNING ON

I didnt modify the ASmedia drivers, i just downloaded them from the Microsoft catalog in the thread linked above, but Windows 7 wont allow the drivers to start unless i boot with the F8 option. Does anyone know a way i can sign these drivers myself or if there is another Asmedia driver that is more suitable to use?

1 Like

@Alexander154 try this…

Batch file or command line:

bcdedit /set loadoptions DISABLE_INTEGRITY_CHECKS

bcdedit /set TESTSIGNING ON

bcdedit.exe /set nointegritychecks on

For the watermark removal, use [ this tool ]

1 Like

@shsv88 - here is what I have that might be helpful. Z490 and Z690 Double Driver backups.

hi
its version “en mobile slipstreaming x64 v1.1” for repacking last? or have later?

@canonkong do you got modded drivers for usb 3.0 and 3.1? for the intel 500 series mobile chipsets? or am I meant to make them myself? I read a few of your comments about removing the drivers from the shelf. So are we meant to modify our own drivers? if so how can I do that? please help.is there a certain software, if so can you give me the link? I have very high IRC latency for the wdf01000.sys drivers. Which is basically usb 3.0 and 3.1. The modded drivers you provide should work perfectly. Looking forward to your reply.

You can find the driver here :https://winraid.level1techs.com/t/solution-win7-8-1-drivers-for-usb-3-0-3-1-controllers-of-new-amd-chipset-systems/33603?u=canonkong

hi :blush:, do you have drivers for the intel chipset? its fine if you dont.

Do you know how to make your own drivers for this?

I have managed to install Windows 7 on Asus Z490 and 10600k using old usb driver. However after few months usb ports are not recognized any more. Windows 7 boots up fine but I can not use it because USB ports are not working. Is there any solution to this?

Use PCI-E to USB2.0 or PCI-E to PS/2 card to install the driver again.