[SOLVED] B450 Aorus Elite & Nitro+ RX580 1024x768 EFI resolution

Hi everyone,

I have Gigabyte B450 Aorus Elite motherboard paired with Saphire Nitro+ RX580 8GB GPU. Unfortunately, EFI framebuffer resolution is stuck at 1024x768. Motherboard is on the latest F51 BIOS with CSM disabled. I have updated Radeon’s GOP to 1.69 using GOPUpd and tried different PCI slots, but nothing changed. BIOS recognizes GOP version and there is an option to choose output, but nothing regarding output resolution (some Gigabyte BIOSes have resolution picker on F6 key, but not mine). My screen is 1920x1200 (16:10), and I have tested both DP and DVI, but also HDMI on my TV (1080p 16:9). I don’t have any other UEFI capable GPU to test (other than one more Nitro+ RX580, which is acting the same).
What is broken here, MB or GPU? My guess is MB, but is there anything I can do regarding GOP support? I have found this modded BIOS for X570, so can I mod B450 in the same way and how? I have SPI flasher, so I’m willing to try anything. This is my first proper PC build, and this is driving me crazy. Among other things, I was really looking forward to flickerless native resolution boot output, but I got barely readable systemd output (before KMS kicks in) insted.



I’m curious to know, what do you need the higher resolution for?
or is it just for looks?

First, it looks awful and it just doesn’t feel right on my new shiny machine, in 2020. Additionally, Linux systemd boot output is close to unreadable. Since I’m using VFIO PCI passthrough of a GPU to a Windows VM (testing EFI resolution was done with one GPU, too), I cannot use early KMS loading, so half of the boot process is not even visible and flickers terribly. On Windows, there is a long black screen pause before login. I had none of these issues on my trusty X230 Thinkpad, and I don’t want booting 2700X from PCI SSD to feel like a downgrade.

I got it figured out! After updating motherboard’s GOP to 2.10 using UBU Tool and making no progress, I used some of the tools bundled with it to look around bios and try to find anything of use. Once I extracted setup IFR, bunch of “Windows 10” strings stood out which made me think that Windows 10 WHQL mode was there, but hidden. Bios menus unlocking threads here pointed me to AMICBP (used version 5.02), and I was right! There was Windows 10 Features item in “BIOS” tab which is hidden by default. After setting it’s access value to USER and making WHQL mode a default, I finally got 1920x1200 boot splash resolution and linux/windows output before drivers. I also needed to change one byte in bios image to enable QFlash flashing. Since I got my hands dirty, I also changed bios logo from atrocious Aorus bird head of some sort to plain and simple AMD logo from their logos archive. This was simple replacement of raw section body of GUID EE4E5898-3914-4259-9D6E-DC7BD79403CF using UEFITool with new BMP image. Important thing is Aptio V expects max 800x600 BMP3 image for logo. I made splash with Gimp, exported as png and converted it to bmp using imagemagick convert (convert logo.png ppm:- | convert - BMP3:logo.bmp). I am quite satisfied with the result, I just need to tweak rEFInd theme to match bios splash.
I have one more question though. Has anybody been successful with enabling PCIe bifurcation on B450? I have two RX580, and host card (chipset laned) is running at X4. Having both at X8 would be nice.


You need to enable AMD PBS menu in tour BIOS/UEFI, read >Here< and >here<.

Basically you need to:
1- Open you BIOS file with UEFITool.
2- Search CTRL-F for AMITSE module (GUID - B1DA0ADF)
3- Extract PE32 image as is and leave UEFITool open for later replacement.
4- Open the file extracted with Hex editor (Ex. HxD)
5- Search CTRL-F for 59 B9 63 B8 C6 0E 33 40 99 C1 8F D8 9F 04 02 22 (Reverse GUID of AMD PBS module) in Hex-Values
6- Replace for (Menu:Edit/Fill selection) 00 and save file.
7- In UEFITool replace as is the file saved in step 6 and save your BIOS file.
8- Flash modded BIOS file.

OK, this is the "normal" mod for unlocking PBS menu, but does not work on all BIOSES, on my X570 I can not find 59 B9 63 B8 C6 0E 33 40 99 C1 8F D8 9F 04 02 22 on the AMITSE module and I still trying to find/search a way to unlock the AMD PBS menu. Hope that works for you.


I’m looking for the same string in my X570 Aorus string. How to set it to USER via AMICBP? Thanks!