[Solved - BIOS Unlock] ASUS VivoBook F510UA/X510UAR

Hello, guys!

I’m having trouble modding the bios on this laptop. I’ve managed to flash a modded one successfully, but it doesn’t show any changes made with AMIBCP. The bios has some duplicated tabs (eg. “Advanced” and “Boot” tabs) which is a bit confusing.

My main goal is to unlock CPU Power Management (or similar) in order to undervolt the CPU and GPU, which is currently done via Intel XTU upon system startup.

Bios file can be found here (X510UAR version 309):


Any help will be appreciated, thanks.

@noreplyse - Please check main BIOS page and get ME FW version, if not found there check in large window of HWINFo64 motherboard section and find ME Firmware version, let me know. If this is AMD CPU system, never mind all that, and let me know.

Hi @Lost_N_BIOS

My system’s ME Firmware version is 11.8 b3390 according to HWinfo, which is the same version of FPTw I used to flash the modded bios. If it is needed for any reason, my CPU is an Intel i5 8250U.

@noreplyse - OK, great, you’ve already flashed a modified BIOS via FPT. That’s where I was heading to help you do

Please test all three of these BIOS, let me know if any give you secondary Advanced menu. This is only a root menu unlock test, if it appears but is empty that’s OK and maybe expected, we can fix. This only test to see which way of these methods, if any, work to enable the menus’
Please also continue testing, if one BIOS works and shows both advanced, still try the rest, I need report back on all three please and thanks.

If we cannot get it, you can change with AMIBCP the default value, since you already know what you want to use from using XTU, then that will be the applied settings.

Thank you @Lost_N_BIOS for modding the bios so fast.

I’ve tested all three of them, but none of them showed any change (apart from overwriting the SN).

About modifying the values with AMIBCP, I wanted to do it in the bios so I could edit and bench the system faster, apart from being able to edit other options and settings.

I’ve also tried to enable the Chipset tab, but I couldn’t make it visible either.

Sorry about the serial @noreplyse - I didn’t think to have you send a FPT dump, hopefully you have one you can use to restore serial/UUID etc with
Looks like I will have to look at this in assembly when time permits, all the usual easier methods did not work. I can’t make any promises since I am not great at finding things in assembly, but I will try once I have time (really behind here, so may take a few days)

Oh, sorry I didn’t mention that I had a backup file. I’ve flashed it and the SN was restored :slight_smile:

I’ve just downgraded to BIOS v308 because v309 has compatibility issues with macOS, so I will be using that one instead. Also, I will try to modify some default voltage values with AMIBCP in order to run the cpu cooler, though I will not set aggressive values.

As for modding the bios in assembly, I really appreciate it, but if you are busy don’t worry, there is no rush :slight_smile:

@noreplyse - It’s more about if I can find and fix in assembly, I am not good at assembly but some things I can figure out, so that is why it takes me a long time (Plus I need to catch up first).
So it’s no problem, but will have to wait until I can get in there.

@noreplyse - Bumping this up for myself and you, I think I know how to unlock now and will be working on this for you in next day or so!

to modifier this bios and unlock hidden menus,follow these instructions.
the protection in AMITSE is the same as my PC… clear ID at 8C4F3 and 8C503, change the menus at 11E2F0 and 143C10.

Yes, I know @fv1862 - thanks! That is why I bumped this thread, going to do this users BIOS now and another one similar in other thread that reminded me about this thread (I forgot, sorry @noreplyse ) - [BIOS Modding Request] ASUS VivoBook S510UF/X510UF

* Edit @noreplyse - Since these laptops do not have USB Flashback, modified BIOS will be flashed easiest via FPT, and for this I need a FPT backup first from you in order to keep all your board details in the BIOS (Serial, UUID, DTS Key etc)
Please check BIOS main page for ME FW version, or if not shown there download HWINFO64 and on the main large window, on the left side expand the motherboard section and find ME then look for ME Firmware Version.
Once you’ve found ME FW version, go to this thread in section “C” and download the ME System Tools package that matches your main ME FW version number
Intel Management Engine: Drivers, Firmware & System Tools

Inside that package you will find Flash Programming Tool folder, and inside that a windows or Win or Win32 folder, select that Win/Win32 folder and hold shift, then press right click and choose open command windows here (Not power shell)
Then type the following command, zip the created file and send to me for modification
FPTw.exe -bios -d biosreg.bin

@fv1862 and @Lost_N_BIOS

Thank you both for helping. I will try it right away.

In the meantime, @Lost_N_BIOS , do you know how to use the BT utility? My keyboard lost its backlight and I can’t use the BT Asus utility: when I try to execute the command bt -c CNFG /W DD 7C it always fails saying that there is “no support EXTF function”. I know this setting must be somewhere in the NVRAM config (as I’m trying to edit the config block) but I can’t find it with other utilities (as UEFITool).

PS: I’m sorry for replying a month later, I was away for a couple of weeks and totally forgot about this thread :slight_smile:

Bios dump (v308) with FPT (ME v11) uploaded.

@ noreplyse

For backlight extract the rar and put the 2 files on BOOTABLE USB,
run FIXMYKB.BAT, you receive an error (it’s OK),
then restart, and light should resume.



Thank you for the file, but I get the same error message and nothing happens.

The error I get is the one on the attached image.



How to format the USB DRIVE ?

Hi @balearis

Yep, I formatted the drive as FAT32 and I have enabled CSM in bios in order to boot from it. Also, I already had disabled secure boot.

A few time ago with an APTIO IV, with AFUWINGUI and a working file,
I changed serial number, w8 serial and turned on backlight, flagging only nr.2 as in the picture…


but I do not want you to do things that I’m not 100% sure on APTIO V, for this it is better to wait for Lost_N_BIOS…

@noreplyse - thanks for the dump, I’ll get you unlocked BIOS shortly. Hopefully the advice above can get your backlight issue fixed, if it does, please send me new dump because this is stored in NVRAM which is part of the dumped region.
NVRAM you can edit/extract/replace with UEFITool, it’s usually the first volume (or two) in the BIOS region, and there is also a stock copy within the main volume that holds the setup module too.
However, I’ve not yet been able to compare a backlight off to a backlight on dump, so I cannot for sure tell you inside which submodule this setting is stored inside NVRAM.
If you get it working, please send me new dump to unlock, and I will compare that with dump you attached above with backlight disabled, then I’ll know and be able to better advise others in the future!

I will wait to do the BIOS unlock, in case you get the backlight working,

@fv1862 may be correct with above AUFWINGUI method, I am not sure, you’ll have to try and see. But, I do think for that method to work the backlight would need to be already enabled in the source file used (Dump with it already enabled, or modified BIOS with it enabled etc)
You can try with stock source though, but I assume that may erase your serial, unless you use your dump BIOS as source and then we know the outcome since backlight is disabled already

@Lost_N_BIOS I tried to edit some of the NVRAM values with HxD (and replacing it with UEFITool), but I had no success. I didn’t want to start typing random things on random locations just to be sure, but I wrote a 7C at an offset of DD from NVAR CNFG (which is what asus bios tools is supposed to do), but it gets resets to FF after a reboot (didn’t test if it was there after flashing before restarting the computer). The same thing happens with other configuration which is supposed to save the keyboard backlight level (it was set at 01, modified it to FF but it was also reset).

NVRAM is visible, from UEFITool, on v53 alpha, but replaceable on 0.25 (stable).

I also wanted to make sure that I was writing at the correct offset, but I have no way of comparing, as I only saw other people using this utility to rewrite MAC addresses after an improperly backed-up bios and this notebook doesn’t have an ethernet port.

Regarding the AFUWIN method, I am unable to test it as not one BIOS file I could find for this machine had this non-critical block present (n2).

Just FYI, this laptop doesn’t come with a backlit keyboard, but the more premium model S510 does, and it’s exactly the same machine (same motherboard, same everything, except for the one having a discrete GPU). In fact, my laptop has the keyboard’s backlight connector.

@noreplyse - I’m not sure how familiar you are with this kind of editing? But you have to open the file in UEFITool, expand the NVRAM volumes, expand again, and then expand again past compression (4x on the inside BIOS volume one), then do that write after the header of first internal module, if it even goes into that module (?).
You can’t just random extract and edit, you have to extract properly and then edit at proper location (not including header in the count to reach “dd” - so body of whatever you edit), so yes, how you mentioned is probably not correct location. Inside NVRAM there is no NVAR CNFG, “Setup” config is the first entry module
And there is usually two NVRAM volumes at top of BIOS region, and one sub-volume inside main BIOS volume too, that’s why I’m unsure proper location without having broken and working dumps to compare.

In stock 309 BIOS, on inner NVRAM volume inside main BIOS volume DD = 00 and is five bytes after a 69 (Same for main NVRAM volume at the top). So, if this is where you made the edit, then this is not the correct module apparently.

In your search for an answer on this, did you ever come across someone’s dumped BIOS with this broken and then someone gave back to them edited and fixed, or provided them a fixed proven working dump? If yes, see if you can find that again and grab both BIOS for me.