[Solved] Cannot seem to install Windows 8.1 on RAID 0 SSD on X79. Rebooting all the time.

Argh… This is driving me nuts.

I finally purchased 2x Samsung 850 EVO 250 GB SSD’s and installed them. Created a RAID 0 array, but for some reason I cannot install Windows 8.1.
It keeps rebooting when the Windows 8.1 logo appears and says something about “Your PC ran into…” (I cannot even read the rest, because it reboots to quickly).

Things I tried so far;

- In BIOS selected Intel RAID - RSTe 3.8 > Created RAID 0 array.
- In Bios selected Intel RAID - RST 12.8 > Created RAID 0 array.

I really have no clue how I can manage to install Windows 8.1. Thought this was going to be easy… Apparantly not. And I have no clue what to do?

I even tried disabling and enabling UEFI, but that didn’t work either.

I have an USB stick (UEFI compatible) with Windows 8.1. Which I tested (before installing the 2 new SSD’s) on my “old” single Samsung 840 PRO 256 GB SSD.
There I didn’t have a problem at all. I just could select on which partition to install. So the USB stick with Windows 8.1 on it is fine.

It seems the problem is with the RAID array for some reason? No clue though.

Also I noticed something weird, prolly just me, but nevertheless.

If select in the BIOS RAID > RSTe 3.8 I can select less space for the RAID 0 array then when I select in the BIOS > RST 12.8 for the RAID 0 array?
Is that normal. It’s about 20 GB difference.

I hope someone, or Fernando, can advice how to get Windows 8.1 installed correctly on this RAID 0 array. :expressionless:

// edit

Oh, why do I get to choose to use RST 3.8 and RST 12.8 in the BIOS for RAID? I thought with X79 (C600?) chipsets only RSTe was supported anyways?

If you really have done it this way, it was a very bad idea.
Before you create a new RAID array, you have to delete the old one and this can only be done with the RAID Utility, which had created the old RAID array.
So I recommend to do the following:
1. Secure erase both Samsung SSDs by using the Samsung Magician Boot CD.
2. Choose the RST RAID option of the X79 mainboard BIOS and set the Intel SATA Controller to “RAID”.
3. Unplug the power cables from all drives except the 2 Samsung SSDs.
4. Hit CTRL+I while booting and create a new RAID0 array by using the Intel RAID Utility v12.x.x.xxxx.
5. Boot off the DVD/USB Flash Drive, which contains the OS you want to install.
6. The OS Setup will detect your RAID array and ask you, if you want instal it onto the RAID array.
7. Agree and let the Setup create a new partition on the RAID0 array. It will automaticly create additional partitions (depends on the boot mode (LEGACY/UEFI).
8. Don’t load any driver.
9. Once the OS is up, you can reconnect the other storage drives and install the Intel RAID driver you want to use (recommended: v12.9.4.1000).

I think you misunderstood me.

Before I had a single SSD disk, which was a Samsung 840 256GB SSD. This was used in AHCI mode (not raid, since I had only one SSD).

Today I received my 2 new SSD’s, which are the Samsung 850 EVO 250 GB SSD’s (2x).
I removed the old (840 PRO) SSD and installed the 2 new 850 EVO SSD’s.

After that I went into the BIOS and tried the stuff I mentioned before. But didn’t work.

When I was done typing this and went back upstairs the Windows 8.1 installation screen was there. I could do the installation, select the partition, however after the first step was at 100%, it said something about being unable to read the source files?
I really have no clue what’s this about. Never had this much problem with a Windows 7 x64 install. Pfft… So far I can tell Windows 8.1 really sucks.

I also checked the cables and connectors, but everything is hooked up correctly. :expressionless:

//edit

Just to be clear, without further confusion; the only storage installed in my PC are the 2 new 850 EVO SSD’s and the USB stick (with Win 8.1 on it). I don’t have anything else connected to it, no CD, no other HDD’s or SSD’s.

In this case your boot image seems to be faulty. So you may have to recreate the bootable USB Flash Drive by using an appropriate tool like Rufus.
Alternatively you may try to use another USB Flash Drive.

In this case your boot image seems to be faulty. So you may have to recreate the bootable USB Flash Drive by using an appropriate tool like Rufus.
Alternatively you may try to use another USB Flash Drive.




Well this is AFTER it says 100% at first step. If I retry to install, it shows several partitions e.g. recovery, windows and bootsection (?).

So if the USB stick was faulty; wouldn’t it have stopped before the 100% at step 1 (copying windows files)…?

//edit

Anyways, I will retry with rufus as you said. But that’s how I created the USB stick in the first place.

Most important: Choose the correct boot sector (MBR/GPT).

Pffft… I redid the whole Rufus things. Selected GPT, because BIOS is fully UEFI. This time, though it took a very long time (to long imho, but could be normal) it “installed” Windows 8.1.
After the first boot I got BSOD, or whatever it’s called. Mainly with code 0xc0000001 error.

No clue what’s going on. Wasted enough time on this crap already. Given my past RAID 0 installations (on different systems, but all Windows 7), I honostly didn’t expect this amount of problems.

I was really expecting to be busy for about 1 or 2 hours at maximum. This would include installing the SSD’s into my system. Setting up RAID 0 and installing Windows 8.1.
After that installing latest drivers and programs I frequently use. However it seems to be completely different. I already “wasted” over 5 hours on this and still nothing installed, let alone Windows 8.1.

This is by far the most annoying install I ever did and no clue what is wrong here. The only things changed compared to my Windows 7 x64 installation; is the single 840 PRO SSD (AHCI) being replaced by 2 brand new 850 EVO SSD’s (RAID 0).
The rest is exactly the same which worked perfectly with Windows 7 x64. Even used OCCT to test stability (ran for almost 24 hours non-stop; no crash). Sighs…

I will call it a day for today and will try again tomorrow.

I will also check the SSD’s individually tomorrow. Maybe there is an issue with one of them, because, other than that I have no clue what could be it.
Maybe a faulty SATA connector/port? I think this will also become apparent when I test the SSD’s individually.

Any tools / ISO’s you can recommend on which to test the SSD’s with? I think I have an old copy GParted somewhere or whatever it’s called.

Thank you in advance. And hopefully tomorrow will be a better day.

The best diagnostic tool for HDDs/SSDs is usually the one, which is offered by the manufacturer himself. In this case it would be Samsung’s Magician.

The best diagnostic tool for HDDs/SSDs is usually the one, which is offered by the manufacturer himself. In this case it would be Samsung’s Magician.




Uhmz… And let me guess to use Samsung Magician you need to have Windows installed, because there isn’t a bootable USB version, right? :((

That is correct, but you asked me and I answered.

Okay, created a Windows 7 Embedded bootable USB stick. Will run Samsung Magician when I get back home.

Hopefully it will show something, otherwise I have no clue what’s wrong. Already regret purchasing the two new SSD’s and trying to run RAID with them. :expressionless:
Oh well. Will report back later. * crossing fingers *

Grrrrr… I am getting tired of this setup.

For some reason this PC doesn’t like the USB stick I created. At work it worked without any issues; tried it several times and everything on the stick booted including the embedded Windows 7.
But here it does not work. Tried even switching UEFI to UEFI + Legacy in the BIOS, but it didn’t help. Really weird.

Anyways, I fooled around a bit more. And I noticed something strange.

In the BIOS, under “Integrated Peripherals” you can choose the RAID mode:

- Intel RST 12.8
- Intel RST 3.8

Enabling either and rebooting back to BIOS shows a new option, where you can create RAID arrays. Now the weird stuff starts, in here it shows a completely different version:

- for Intel RST it’s: RST 13.1.0.2126
- for Intel RSTe it’s: RSTe 4.1.0.1026

I don’t know if this is normal…? Once again; this is from within the BIOS where I can create RAID arrays also. This is not the CTRL-I function during boot.

Also after fooling around a bit (even tried resetting the options and reboot several times) it started to behave weird. Weird as in it not getting the screen anymore during boot where you press CTRL-I to create/access RAID arrays (during boot).
I have spend the last 15 minutes to get that back, but no go. Seems to have vanished completely?!

I am gonna modify the BIOS again with UBU and reflash it completely, to see what happens. Maybe that will fix things, because currently things aren’t working as it should imho. I have installed RAID arrays in the past, but I never had these kinds of problems. Sure I got BSOD in the past with WinXP x64 and Vista (back in the day), but that was because I forgot to use F6 and load drivers… But, that was easy to fix. This ain’t as it looks.

Will report back later; if you still have any other ideas or what versions to flash with UBU, please share. TY.

@ HHawk:

You obviously are mixing up the LEGACY and the UEFI BOOT settings.
When you have access to the Intel Rapid Storage Technology RAID Utility from within the UEFI BIOS, you are running your computer in UEFI mode. As long as you do not change the BIOS settings within the "BOOT" section, you will not see the "LEGACY" mode Intel RAID Utility by hitting CTRL+I while starting your computer - this is an absolutely normal behaviour of a modern UEFI BIOS system and no issue!
The UEFI mode Intel RAID Utility is managed by the EFI "SataDriver" module and not by the Intel RAID ROM, which is within the BIOS as well, but as Option ROM module part of the CSMCORE file.

So you should be able now to create a proper working RAID0 array by using the Intel Rapid Storage Technology RAID Utility from within the UEFI BIOS. I recommend to choose the RST v13.1.0.2126 option.



Well I don’t know about mixing things up, but what I do know, is that I set it up correctly (as it should be done) the first couple of times, after that I did probably starting messing around and mixing things up. Because it doesn’t work.

I did notice one very odd thing; when I install the original BIOS from MSI it will show Intel ME 8.1.5.x.x or something in the BIOS.
When I have used UBU on the BIOS file it will say (in the BIOS): Intel ME: N/A

I am no expert, but if the BIOS says (after using UBU on it) Intel ME: N/A is something I doubt which is good.

Since I didn’t make any progress today (again), I will flash the original BIOS from MSI again (the one which is showing an Intel ME version) and see how Windows 8 installs on that.
The only downside is, is that the original MSI BIOS uses 12.7 or something for RST, which is probably not so good.

But at least it’s worth testing. So I know I am not making any mistakes…

The "Intel ME: N/A" message is nothing to worry about. It just means, that the UBU tool was not able to read the Intel ME version.
You can check it yourself by running the Intel MEInfo Tool for ME8 systems.

Okay, ofcourse I can’t test MEInfo Tool, cause I have no OS.

Anyways, will try the original BIOS first tomorrow and after that will decide on what to try next. Calling it a day again.

Thank you anyways for answering.

To my knowledge UBU does not show the ME version or anything ME-related for that matter. The BIOS should display the ME version properly, otherwise maybe something is not quite right.

What is your exact MSI model?

Edit: Found it, BIG BANG-XPOWER II



Sorry, wasn’t around anymore, so couldn’t respond earlier. But yeah, the motherboard is indeed a MSI Big Bang xPower II x79.

Exactly; I thought it was also strange that it showed under, ‘System Information’ (in BIOS); ME Version: N/A.
So far I can tell, this only happens with BIOS files which I have edited (=updated) with UBU.

If I use an original BIOS from the MSI website, this does not happen and after flashing it indeed does display a version in the BIOS under ‘System Information’, if I recall correctly it’s version 8.1.5.x.x.x or something like that.

Seeing what I have tried so far, I can only imagine it’s because of the updated BIOS files through UBU, however tried so many things so far, I don’t exactly recall what I did try and did not.

This is what I am gonna try later (when I get back home this evening);

First; I am gonna try to install Windows 8 from a new image (3rd version by then) and from a different USB stick (pretty sure it’s not the USB stick though)

Secondly; if that doesn’t work, I am gonna re-flash my motherboard with the original MSI BIOS for my motherboard. This is version 2.80. With this version it will show the ME Version in the BIOS correctly. I am really starting to think this is the cause of problems, but can’t be sure. I remember, from the past experience, that when you flash your BIOS you always had to reinstall Intel ME in Windows, otherwise it could become unstable.

I really am starting to think it’s because of ME Version is missing. It would explain the random installation problems I am experiencing with Windows 8. It doesn’t crash always at the same point, like yesterday; first two times I tried to install Windows 8 it crashed/rebooted during Windows 8 logo. Later on it stopped at 74% copying files from USB. The day before it installed everything (when I thought it was going okay), it crashed during the 2nd boot (when it finalizes things). So the crashes, reboots and BSOD’s are pretty random.

The only, real downside, to the original MSI BIOS file is that Intel RST OROM is v12.7. Oh well. If the UBU does indeed mess up my ME Version, at least I will know what’s causing it.

And FYI: because of all the flashing I lost my overclock settings (which I thoroughly tested with OCCT for over 20 hours), so it can’t be that either, because everything is running on stock now.

Though I might sound like a dumbass at certain points by doing random stuff, but be assured that I actually do have some experience in setting up RAID arrays.
The problem here is, when things don’t work as they should, I try to start testing / experimenting with other things.

Will report back later this evening…

//edit

Just to make sure; when I use Intel RST OROM 12.9 or 13.1 (those seem to be the best for my x79 motherboard) to setup RAID 0. I don’t need to load drivers in the Windows 8 installation screen (where you select to install Windows), right?
Don’t think this is needed, but want to make sure. If I can get to the Windows 8 screen where you select on which partition you want to install Windows 8 it shows up as ~450 GB of unallocated space. This means Windows recognizes it correctly and that I don’t need to load drivers, right? Again, sorry for stating the obvious, but just wanting to make sure I am doing things correctly here. :S

First things first, the ME should be reported at the BIOS. It’s important to have it working because it takes care of multiple things like power management, fan control, overclocking, safety, intel rapid start etc. Also, keep in mind that you can only use v2.x MSI BIOS now. All v1.x versions had ME7 firmware and you cannot downgrade from ME8 to ME7. Usually a ME major version is series-exclusive but 6-series was updated from ME7 to ME8 for IVB support.

X79 is a 6-series. The good thing is that up until 6-series the ME could get corrupted and if the BIOS detected that it could boot and have a working system without it. Mind you, a working system with some limitations due to corrupted ME. However, since your system now has ME8 (7-series firmware) in order to support IVB cpu’s I’m not sure if a corrupted ME would work. Basically I am not sure if the ME’s ability to be corrupted is firmware (ME7) or platform specific (6-series).

Anyway, I checked your latest BIOS and it has ME v8.1.50.1456. However, MSI is packing the BIOS inside an idiotic .exe which not only requires to be put at the root of a usb drive but also checks if your motherboard is MSI. I did extract the 8MB image by cutting from 5AA5F00F and down but since I am not sure this will work 100%, can you attach me the latest MSI BIOS image (8MB)? Also attach me your UBU-modded latest BIOS image.

Yes, this is correct. The Win8/8.1 Setup wil detect your RAID array without the need of loading any special driver at the beginning of the OS installation.
Precondition: Your on-board Intel SATA RAID Controller has been set to "RSTmode" (DEV_2822) within the mainboard BIOS.