[Solved] How to mod an ASUS Rampage V Extreme BIOS?

Latest 2001 BIOS [Solved] How to mod an ASUS Rampage V Extreme BIOS? (11)

Hi, I have only ever tinkered with Router firmware and I have not done a lot to that.
I would like to know what I can do with the latest RvE BIOS, I have seen updated Raid for the 1502 BIOS but they have now released 1701 & I would like to get to grips with doing it myself.
Could I have some links to the threads I need please :slight_smile:
Tried having a look but I guess my old age took over and I gave up.

Thanks in advance.

>Here< is the appropriate thread for you. Since your ASUS Rampage V Extreme board has an X99 Chipset, the best suitable BIOS modding tool for it is CodeRush’s UEFITool.

Thanks, I think I managed to replace the Option Rom

Not sure what went wrong, I have replaced the module upgrading it to RaidDriver_14_5_0_2241

I did the flashback and booted into the bios, if I selected the EZtuning wizard and it showed the old option rom with my array intact.

If I then try and boot with Ctrl I it ignores it or hangs, if I then go into the BIOS and select raid I can see the new version 14.5

Flashing the stock 1701 results in a working Ctrl + I to get into the Raid setup.

Could I have a little help please?

@ GoNz0:

You obviously had successfully updated the Intel EFI RAID module named RaidDriver resp. SataDriver, but forgot to update the Intel RAID ROM as well, which will be loaded, if you run your system in LEGACY mode.
As long as you are running your system in "clean" UEFI mode (CSM disabled within the BIOS), the currently not updated Intel RAID ROM module will not be used.

Well Ctrl + I still causes the system to lock, I can get in it fine with the original BIOS though.
I also have CSM disabled, it seems the R5E has a 2nd module to account for the EZwizard, it also prevents the Raid screen popping up during the system POST letting it boot faster.
I can enable raid with out the wizard and it shows my arrays and allows the system to boot, it also shows the updated 14.5 version, but the wizard still shows 13.x.x

Do you know what I have done wrong to lose the ability to Ctrl I and also what other module will I need to replace and what with?

Sorry, I have no idea what to flash/swap to sort this.

150902143443 by Gareth Holland, on Flickr

Just tried the modded 1502 BIOS listed on this site and I can Ctrl I with that, it also shows the older 13.x when using EZtuning :frowning:

I believe you have mixed the modules. You can get CTRL+I only with OROMs and only when CSM is enabled, while the screen from above appears only for EFI drivers. The file posted here has updated ROMs only, thus the title. Try again and update with the right modules.

Thanks, this is all way above my pay grade so I am going to leave it alone for now. I have no idea where to put the files and what files to put where. Half a day and I am none the wiser to this.

The file looks like this:


You can let UBU replace the EFI drivers, you just have to replace the ROMs in A032—. You must use UEFITool, as MMTool will break when replacing more than one ROM in that GUID. For the microcodes there is a workaround, but it takes some writing and I suppose you are not that interested.

Intel RST RAID ROM & EFI SataDriver modding on the Asus Rampage V Extreme Intel X99 Motherboard.

Use the Latest version of UEFITool.

The Intel RST RAID OROMs are located in GUID A0327FE0-1FDA-4E5B-905D-B510C45A61D0 as Freeform.

A quick way to get to the correct location of the Intel RST RAID OROMs is to use the search feature of UEFITool
and select the GUID option and then paste A0327FE0-1FDA-4E5B-905D-B510C45A61D0 into the GUID box.

Once you’ve done the search, it should mention in the message window that it has found this GUID. Click on the
message and it should take you straight to the GUID where the Intel RST(e) RAID OROMs are located.

The two Intel RST RAID OROMs in the BIOS are located in Subtype GUID: E095AFFE-D4CD-4289-9B48-28F64E3D781D
and Subtype GUID: 20FEEBDE-E739-420E-AE31-77E2876508C0.


You can also go straight to the Subtype GUID of each Intel RST RAID OROM by using the same search method above.

You can download your required Intel RAID ROM module from the page below under 1. Intel RST/RST(e) RAID ROMs section.

The EFI RaidDriver is located in GUID: 793BA4EB-A6E9-4526-996D-79393F51B443 and it’s the PE32 image section that
contans the EFI RaidDriver and so you must replace this with a clean EFI image file.


You can download your required Intel EFI SataDriver BIOS Module from the page below under B. For Intel 7-9 Series chipsets (except X99 running in RSTe mode): section.
Intel EFI “SataDriver”/“GopDriver” BIOS Modules

Remember to download one of the Intel EFI SataDriver BIOS Modules marked (without header) because the other ones won’t work on the Rampage V Extreme.

Use method “Replace body” to insert new Intel RST RAID OROM image into each of the Subtype GUIDs above
replacing the current one and the PE32 image section for replacing the EFI image.

Flash the modded BIOS using USB Flashback only.

Download your required Intel RAID ROM module from the page below under 1. Intel RST/RST(e) RAID ROMs section.

For the Intel EFI SataDriver BIOS Module, you can download the one you require from the page below under B. For Intel 7-9 Series chipsets section.
Intel EFI “SataDriver”/“GopDriver” BIOS Modules

Remember to download one of the Intel EFI SataDriver BIOS Module marked (without header) because
the other ones won’t work on the Rampage v Extreme.

Thanks for this, I can understand this as I have no clue where to look :slight_smile:

For the ROM I have downloaded >Intel RST(e) RAID ROM v14.6.0.2285<

for the EFI I have downloaded ">"pure" Intel RST(e) EFI "RaidDriver" v14.6.0.2285 (without header)<"

The bit about running RSTe went straight over the top of my head so I went with a matching number, did I do right?

Not tried Ctrl I yet as I need sleep.

Many many thanks for this!
I can now see the new ROM in the EZsetup screen

That’s correct. You must download the Intel RST RAID ROM & Intel RST EFI RaidDriver matching the same version number.

excellent stuff, all seems to be working and in order now,. can’t thank you enough for the walkthrough and links :slight_smile:

& everyone else who chipped in :smiley:

Hi, what programs that ?

I have been told over at ROG forums that the CPU had a microcode update so is this necessary?
The only thing I would like to get working is the Cache adaptive voltage as it never works as it does with the CPU voltage, Asus blame intel for the microcode but I am not so sure as they seem full of it most of the time as far as official reps go.

(Blaenant copy and paste from @voodoo as it is so well worded & huge thanks to @sinders for the guide and holding my hand throughout!)
Note: Like all modded BIOS’, must be flashed via USB Flashback. To do this, load file “R5E.cap” (do NOT rename) onto a usb drive, insert it into the LOWER USB port on the PS/2 Mouse/KB hub, and then press and hold the ROG Connect button (below BIOS reset button / green circle arrow) for a few seconds. Corresponding BIOS light at the bottom of the motherboard will then start to flash (at which point you can release the button), and will blink faster and faster as it progresses. BIOS flash is complete when light stops blinking. At this point you can turn the motherboard power on and enjoy (note that you might have to press the power reset button on the board just once after a BIOS flash).

This contains the option replaced in both modules allowing traditional Ctrl + I setup and the EZtuning (F11 in Bios) option, also the EFI Sata driver so you have 2 ways to setup raid. My personal favorite is EZtuning as this stops the Raid option rom page during POST and seems to POST a lot faster.

Modded 1701.CAP

150903090844 by Gareth Holland, on Flickr

@ GoNz0:
Thanks for your report and congratulations for having succeeded with the update of both Intel RAID modules (the LEGACY RAID ROM and the EFI “RaidDriver”), which were within the AMI Aptio V BIOS of your X99 Chipset mainboard.
Question: Why did you start a new thread?
It would be much better for users with a similar problem, if your final report would be added to >this< thread after having changed the title to something like “[Solved] How to mod an ASUS Rampage V Extreme BIOS?”.
If you should agree, but do not know how to manage it, I will do it for you.

@ sinders:
Thank you very much for your intensive and successful help. I will add a link to your AMI Aptio V BIOS modding guide to the start post of >this< thread.


You don’t have to update the CPU microcode because like I said to you over on the ROG forums, ASUS updated this in the latest BIOS 1701 to MU063F022E which is the latest version as far as I am aware.

I was following Voodoo’s lead on posting a new thread, but feel free to move the post into said topic and delete the remainder.