[SOLVED] How to update CherryView Intel EFI GopDriver?

My motherboard is based on Braswell.

Using UBU, I successfully updated the Realtek UNDI driver, but it seems that UBU doesn’t support the update of Intel CherryView GOP.

I’ve found a newer version of Intel CherryView GOP in this thread, and would like to use UEFITool to update the driver.

I tried to follow this guide, but failed to find out which target DXE driver to replace. I made a search using the UBU output …

Intel GOP SubGUID 380B6B4F-1454-41F2-A6D3-61D1333E8CB4

... and UEFITool returned:
GUID pattern "380B6B4F-1454-41F2-A6D3-61D1333E8CB4" found as "4F6B0B385414F241A6D361D1333E8CB4" in 380B6B4F-1454-41F2-A6D3-61D1333E8CB4 at header-offset 4h

I followed the search result but found that there was no PE32 image section.

Any help on how to find out the corresponding section to replace would be greatly appreciated.

First, be sure you edit the file using this guide, so your system specific settings get transferred into the GOP/vBIOS you want to use (you want to do both GOP and vBIOS)
[Guide] Transfer of specific Intel VBIOS settings by using Intels BMP tool

Also, make sure the file and method you replace, starts the same in a hex editor. Extract “as-is” and “Body” and then compare with the file you are inserting, to make sure they both start the same one. If the file you have only looks similar to a body extraction, then when inserting choose replace body.
Do this with UEFITool.

There is no PE32 for GOP, it’s that raw/freeform file you found, right below the GOP SubGUID (380B6B4F-1454-41F2-A6D3-61D1333E8CB4) is vBIOS at SubGUID 06767E64-19BF-459F-8564-5F25D4896FB0
Both, within the compressed section at main GUID A0327FE0-1FDA-4E5B-905D-B510C45A61D0

If you are unsure still about the As-Is/Body stuff, send me the exact file you are planning to insert and I will tell you exactly how to replace it (ie if it’s a body file, or also contains header = as-is)

Thank you.

After following the guide and saving the system specific settings to vbios_new.dat, I am now stuck at how to update VBIOS. UBU does not support CherryView VBIOS update, and I can’t find any guide on how to use UEFITool for VBIOS update and apply the vbios_new.dat.

You’re welcome @620756613094 Upload your newly edited vBIOS and I can put in for you if you want, it’s done with UEFITool how I explained above.

Many thanks for your help!

Updating to GOP 8.0.1038 works, but updating to GOP 8.0.1040 does not, resulting in no display during BIOS stage.

Did you check both files are similar beginning? I mean, both have header or not when inserting? I was thinking maybe 1040 fails due needing a header or needing it’s header removed (If 1038 does not have header), but I guess all that also depends on how you insert etc,
Sometimes internal size does not allow further update too, I’d need to see the files themselves if you are not sure the cause. Is 1040 the latest one you found?

Both versions come from this thread (see the attachment in #4). plutomaniac included v.1040 in the attachment, but I can’t seem to find any BIOS containing v.1040 with Google.

I used a HEX editor to check the beginning of both files, and they start with the same HEX values.

Did you “Replace Body”? Those are GOP Files without header, so replace body must be used and the header updated for file size (This is done automatically if using UEFITool)
Here is file I made to check this for you - http://s000.tinyupload.com/index.php?fil…609174569941155

If that does not work, maybe plutomaniac has some updated knowledge about this now since the other thread you linked is two years old.

Yes, I used "Replace Body". After using UEFITool to replace body, I used UBU to check the new BIOS file and UBU showed the correct version (1040).

May I know if there is a newer version of CherryView GOP?

I stopped checking for BIOS modules 2.5 years ago so I don’t know.

Thanks plutomaniac, I’m sure there may be newer probably, I was wondering if you had any knowledge why 1038 may work for him but 1040 does not. I’m not sure if he’s tested my inserted BIOS test or not, but it’s probably same as his creation since he did same way (Maybe different UEFITool version used)