[SOLVED] Lenovo Flex 5-14ARE05 bricked/black screen

I don’t know why my comment is so hard to understand, It’s literally the same model and same issue as the OP. I’m just asking for a more simplified version of the instructions provided in reply #6, as I mentioned in replies #58 and #59.


Hi friend, your pc is bricked as update session didn’t finish, so you can try if exist an Recovery Bios way #58, #59 (i don’t think on UEFI as we tried many times)
or use the SPI Programmer CH341a + Pomona Clip … (the best solution)
The Firmware we can be recovered from your Dump (about your system data, UUID, serial, etc) and original stock bios (or a different DUMP) …
There are not many chances …

Well, there’s lot of information on how to use a CH341 programmer to read the bios on the net and especially in this forum. The procedure is described properly and if you’re not comfortable with the guide and/ or with a little reading/ learning in addition, then you might go to a shop and ask them to read the bios content and give it to you maybe on an USB stick whatever… Post the bricked bios here and maybe you find someone to do the job for you.

It’s rather optimistic to expect that someone will invest time in rewriting a properly written guide for you not having even a clue which part you don’t understand.

Just wanted to say, thank you OP, it took a while but I sorted out your instructions and managed to fix my BIOS. Soldered it back on just a few mins ago and it booted :slight_smile:

My tenure on this site was successful albeit brief, I’ll be deleting my account now if possible.

And a special shoutout to IFB6 for taking the time to create 2 responses that added nothing meaningful to the conversation nor helped me in any way. Must love the sound of your own voice.

Hello everyone,

I have this exact model and exactly the same symptoms. However the failure happened not during the night and without loud beeping. It happened while streaming a movie - the screen went black and the laptop wouldn’t boot.
Here are the corrupted BIOS from the laptop and the BIOS from the Lenovo site. I tried to copy the suggested areas from the corrupted BIOS into the stock BIOS but this did not help. The laptop still has black screen with no backlight. Only the keyboard is lit.

I’d like to ask you to please take a look at these two files and copy what you think is the necessary information into the stock BIOS from Lenovo.
Thank you!

Corrupted_BIOS.bin.zip (5.45 MB)

BIOS_from_Lenovo.bin.zip (5.23 MB)

That’s not exactly the same, screen going black is not a very specific symptom. Even with Windows now performing bios updates, a bad flash would normally get active on next boot. Sounds more like hardware to me?

Anyway, try the attached file, it’s unfortunately not possible to check your old firmware since the (rather old version) EECN21WW is no longer accessible.

36pl.zip (5.24 MB)

Thank you @lfb6 Unfortunately your file did not have any effect. You are probably right that it’s a hardware defect and not the BIOS.
I noticed while using the UEFITool that every volume within the Corrupted_BIOS.bin file has a valid checksum. Can this be considered the proof that the BIOS in fact is NOT corrupted otherwise the checksums would be invalid?

Didn’t do any statistics, but I’d say not completely 100% but makes it less probable that there’s an error. If you compare stock bios volume checksums to your own dump and they’re identical that’s even better. But put both files (stock and dump, same version) in a hex- editor and compare the from the end, it’s a lot quicker since the variable parts of the bios region almost always reside in the beginning of the bios region.

if possible it would be greatly appreciated if someone could rebuild my bin file
Many thanks in advance
https:// drive.google. COM /file/ d/16MRI1igs_mcOOoXttgaiAmQAFR4rZTcO/view?usp=sharing

I am wondering if I can use this programmer https : //www. amazon.com/KeeYees-SOIC8-EEPROM-CH341A-Programmer/dp/B07SHSL9X9/ref=sr_1_3?keywords=ch341a+programmer&qid=1646314893&sprefix=ch34%2Caps%2C182&sr=8-3 that I bought to perform the steps to reflash my bios?

Wanted to shout out this thread for saving my laptop after a failed BIOS update. For whatever reason the update process failed and turned the laptop into a paperweight. I decided to flash the version of the BIOS I was trying to update to (EECN39WW) because I was troubleshooting a separate issue when the update failed. I am also never updating the BIOS on this thing ever again.

This was the programmer I used that includes a 1.8v adapter and no instructions whatsoever https://www.amazon.com/dp/B07VMPZFWH

I did use a separate range of data from the recovered BIOS for the new BIOS image. I used 21000-40FFF because 37D8F was in the middle of some other data in my case. Other people seem to have noticed this as well. B21000-B21280 still worked for the serial number etc. I didn’t get to spend much time with it, but I think the Lenovo logo might be missing/corrupted in my firmware now as I just get a black screen during boot until the OS takes over. I’m fine with this as I’m a little annoyed with Lenovo at the moment.

Glad this info is still helping after all this time.

I still don’t know much more about this topic than what I learned back then, but I would expect the offsets to change some with different BIOS versions. It’s also probably best practice to copy and paste the relevant bits into the exact same BIOS version and then update to a newer version afterwards if you need to.

If you want, I can look at your dump to see if my opinion matches yours on which offsets should be copied.

Sure, knock yourself out bad bios

For future reference I was (probably) updating from EECN36WW.

lfb6 brought up a good point about the windows key. I looked at the BIN file I edited and it does have the key, so I must have copied it over, but didn’t mention it in my instructions post. I have really bad memory problems (literal brain damage), so I don’t remember why.

Anyway, the key is offset block B10000-B100B8. The other areas are 21000-40E8F (or 40FFF like you did, doesn’t matter) and 21000-B212FF. Again, not sure why I stopped at B21280 originally. My old edited file shows I went to B212FF.

The black screen at boot might have something to do with the missing key? I guess you could try again and see what happens, but I’m sure the last thing you want to do is mess with it again. Trust me, I understand the frustration. I was pretty furious when I had to deal with this problem. It still amazes me that I was able to fix it on my own. This bits and bytes stuff makes my head spin.

Hello Plastixx. After trying to update bios in my Lenovo Flex 5 14ITL05 by Vantage (Lenovo app) I receive the same symptoms like you. My laptop has Intel i3-1115G4. Is your’s programmer good for me? And second question: what version of Bios I need?

Different machines in addition intel vs amd so don’t use the offsets mentioned here without check!

Seems lenovo doesn’t provide complete firmware image so you’ll need a valid backup of the bricked bios!

Recommend to start your own thread!

But all steps and programmer the same? Difference only between BIOS?


Who can help me with this? I am new to this topic.