[SOLVED] Looking for BIOS Chip File Dumps Epson Endeavor Pro 7500 / Foxconn Quantumian-1


This is kind of embarrassing but I accidentally bricked my motherboard while flashing a bios update using AFUDOS. I didn’t have a backup at the time and was wondering if anybody has dumps of the two chips that are onboard. I was going to mod the bios but decided to just try updating the bios to the latest version first.

If not, I’d be willing to try to flash dumps of the foxconn quantumian-1 files which is the retail version of the board.

If anybody can help that would be great. Since it would be a shame to junk the board just because of a bad bios.

I’ve outlined the chips in red

I’ve attached the AP4-P11-EY6 bios if anyone needs it in the future. This includes the ME as well so can be directly flashed as needed.
Epson Endeavor Pro 7500 Bios EY6.rar (2.4 MB)

Not even back in 2022, upon this thread, you made a backup?

Indeed the Foxconn files have a MFG bios file suitable for SPI program…

Such rare system, a backup should be a MUST in this case… it wont be an easy task to find such dumps, good luck.

Yeah, I didn’t end up making a backup cause the ch341 was having issues (Flasher itself wouldn’t even detect as a device in Windows). So I never went ahead to try to flash a modded bios :frowning:

I figured flashing just stock would’ve been okay. I guess not. At least I learnt something from it.

Read/ dump the chips with a CH341 programmer and lets see whats inside. Normally an update of the bios region wouldn’t harm the other regions.

Could get the CH341 to show up in windows at all. Before flashing I did make a bios backup with AFUDOS and the file looked exactly like the bios flashed. No ME on it though. So I’m not sure if that’s why there’s a second chip on board.

I got an EZP2023+ to replace the CH341 but it won’t detect the chip properly. Found out it might be a 1.8v chip since it detected using the 1.8v adapter but not when my test clip was plugged directly into the flasher. But it’s not detecting as the correct chip.

From what I can read on the chip looks like a W25Q64DVSIG which I can’t find. Definitely isn’t a DW.

I attached the backup from AFUDOS not that it will be much help. I’ll try to see if I can get the flasher to read the chip though. Maybe a different test clip will work.
X79_Bios_Backup.rar (1.8 MB)

Well, it’s just looking what’s written onto that chip, can’t help here. Try some alcohol / spiritus on the markings? Take a close pic with a camera?

I wish I had done this earlier. I brought out my cheapo electronic microscope cause my cam couldn’t do it. It’s a 25Q64CVSIG.

Is it me or does that look like a fake winbond chip?
Since that could be why I’m having issues trying to read it.

Also want to say thank you for everyone trying to help. I really appreciate it :slight_smile:


The other chip on the is a 25X40BVNIG. Not really sure what that one is for. Foxconn board reviews weren’t really sure what that was either. Maybe it’s where the ME is located?
I couldn’t read this one either but I think that came down to my clip not fitting the chip correctly. It’s not mentioned in the documentation from Foxconn either.

Dont tell me that you previously said the CH341A…because you didnt know the SPi Chip ID???
This is the 1rst thing to do…even without connecting the SPi programmer…
Now get info on those IDs pdf’s around the web and you’ll know the specs and voltage required.
Perform both dumps as they are now.

EDIT: Oh i see it was a defective hw piece.
With CMOS battery on or off, psu stand-by on or no psu attached…it cant have voltage fluctuations from/or without, for correct read/write, so thats a bit odd if its 2.7v to 3.6v operation range, on the ssheet.
Well a bunch of FFFF its a no go!

The W25X40BV its a 4M-bit/512K-byte (524,288), so it could be EC/Intel ME, same voltage operation range.

EDIT: Its my Mac Pro “half-brother” hehehe, its an unique machine and it has a nice chassis… for old timers like me of course…young people may say “arghhhh”

My CH341a doesn’t work at all. Got a defective one maybe. I’m now using an EZP2023+.

I did look at the chips beforehand. But not with the microscope. So I was manually setting in the programmer program to the correct chip ID.

When i saw the 25Q64CV I thought 3V (documentation says 3V). But it says not detected when fed 3V. Only detects a chip when fed 1.8V but when I actually try to read or write to the chip I get nothing. Can’t write properly (verification error) and read comes up blank.

Edit: Strange so everytime I read the 25X40 chip it has a difference read showing on the Hex values. Getting a no read anyways anyways. I think my clip doesn’t make good contact with that one. But yup a bunch of FFFF. Could be 25X40 just stores bios save data maybe.

Oh CMOS battery is in. No PSU power going in at the moment

Still haven’t gotten the alleged 25Q64CV to read though.Yeah it is strange. I don’t have any spare bios chips on hand at the moment but hopefully can get some in a few weeks. Maybe is a bad chip. Not sure. Since that winbond logo with the wrong font doesn’t give a lot of confidence.

I’ll see what I can do for the “fake” 25Q64CV but it doesn’t seem very promising so far. I tried 2 different clamps wasn’t having a lot of luck :frowning:

Frequent things are frequent, rare things happen rarely. The board could read the chip quite well a lot of years.

Most of the times it the positioning of the clamp!

You need 2 a 100% identical reads with a correct structure (UEFITooleNE)…

Don’t use much time for the other chip, 512kB might be EC but it’s too small for FD and ME.

1 Like

You were right. Clip must’ve not liked going on. I desoldered the chip with a hot air gun and it detected perfectly using the seat programmer clip.

Edit: I figured it out. :slight_smile: Something in the bios region got corrupted. But the ME was preserved so I’m going to replace the bios region from the bios files online. Hopefully it works.

Thank you everyone. I’ll make sure to post the dump here just in case since somebody might need it in the future if this works.

1 Like

Good to hear that you came that far, would be interesting to have a look into the bios region, but I assume you might not be very much interested in serials/ board specific data.

I wouldn’t say I’m not but more that I would be interested in learning more.

Programming is a beginner hobby for me so I definitely would be interested in learning more in depth about these things.

I really appreciate you and MeatWar working hard to help me out here though.