[SOLVED] Searching for an AMD RAID driver to get Win7 installed onto the RAID0 array

System specs so we can get that out of the way

Gigabyte GA 970A-DS3P v2.0
2x8gig sticks Corsair vengeance 1866Mhz
2x250gig Samsung Evo 850 SSDs
Seasonic 1050w PSU

Just trying to install Win7 Pro 64 bit in Raid-0.
Driver won’t load.
USB drive has LED light that flashes when accessed. Never flashes when trying to install driver during windows install.
Raid array cannot be seen thru windows, can be seen in BIOS.
I went to the recommended driver page for AMD driver. Tried every single one thru flash drive.
I have seen on the internet this isn’t a new thing & I wish I had done more research into this hardware.
If anyone has the holy grail of drivers to get this installed I appreciate a link to it. Thanks

EDIT by Fernando at 04/29/2016: Since the problem meanwhile has been solved, I have customized the thread title.

@MikeHawk :
Welcome at Win-RAID Forum and please forgive my late reply (I obviously have missed your post).

Before I can answer your question, I need some additional informations:
1. Have you been able to create the AMD RAID0 array? If yes, how did you do it?
2. Has the AMD SATA Controller been set to "RAID" mode within the BIOS? If not, is this option available within the BIOS at all?
3. Which is the exact name and DeviceID of your on-board AMD SATA Controller shown within the "Storage Controllers" resp. "IDE ATA/ATAPI Controllers" section of the Device Manager?

Dieter (alias Fernando)

ok to answer some of these right away.

1. Yes, I can create the array through the onboard controllers BIOS by hitting Ctrl+F. I didn’t change any of the perimeters(64k chunk size/Raid-0/etc…)
2. Yes, SATA controller is set to raid mode, once the array is created it can be seen & selected as a boot device in BIOS
3. Now as far as the DeviceID in device manager, I currently have the SATA controller set to AHCI since I cannot get raid setup. I installed the OS on 1 Evo 850 & the other is sitting here.
I see the IDE ATA/ATAPI controller & opening it says AMD SATA controller. Now where you find the exact name I cannot tell. Maybe since the SATA controller isn’t set to raid it is not showing the name.

Since it’s a UEFI BIOS I set everything to legacy on that page in the BIOS. Since Win7 is a legacy OS nothing worked with any of the UEFI options enabled.
I feel the main issue is the driver is NOT signed by Microsoft & it’s not allowing the unsigned driver to install the OS. I get no failure warning however. Nothing as a matter of fact. It just goes back to drive selection screen & still shows a blank screen.

I’ve tried installing it off the motherboard disc, 10-15 diff USB drives. Nothing seems to work.
Searching the internet before I bought this setup would have shown me all the issues people were having with these south bridges.
So I blame me.

But I thank you for any & all help you can give me. Just let me know where in device mngr I can find that info.

@MikeHawk :
Thanks for having answered my questions.

Yes, as long as your AMD SATA Controller isn’t running in RAID mode, the Device Manager will neither show the exact name nor the DeviceID of the on-board AMD SATA RAID Controller.
Nevertheless I will try to find out the DeviceID of your on-board AMD SATA RAID Controller, if you post the HardwareIDs of your AMD SATA Controller, which is currently running in AHCI mode.
To see the HardwareIDs of the listed “AMD SATA Controller”, right click onto it and choose the options “Properties” > “Details” > “Property” > “HardwareIDs”.


Ok, from top to bottom that is what I see.
Yea since I’m unable to get windows installed thru the raid controller, I’m unable to get into the device mngr & see it’s name.

@MikeHawk :
Since I am not sure, whether the Win7 Setup will accept any driver, which has not been digitally signed by Microsoft, I propose to download and to load/integrate the “64bit Win7Vista AMD SB7xx/8xx RAID Driver v3.3.1540.40 WHQL”, which you can find >here< (look into the chapter A. c) point 2). The problem may be, that this driver has been designed by AMD just for the OS Vista and not for the OS Win7.
If this driver should not work, you may try the attached 64bit AMD RAID driver v3.8.1540.14, which has been customized by me for being usable with Win7 x64. Unfortunately you cannot import the Certificate of the digital signature, because the OS is not yet running at the moment, when it is needed.

Good luck!

Side note: Your Signature is fine, but uses too much space. If you enter more than 1 device into a line, your signature will not need more than 3-4 lines.

64bit Win7 AMD RAID driver v3.8.1540.14 mod+signed by Fernando.rar (161 KB)

That winrar file you attached keeps giving errors when I open it. The certificate file won’t allow me to extract it. Thanks for all your help though.
So you want me to try using the Vista 64bit raid driver 3.3.1540.40 to install? I can give it a try.
I’d like to get a copy of that file you uploaded to properly extract though first.
I’m wondering if I am using a very old version of winrar. Yea reading the error, it says file is corrupt.
Let me know if you can upload a new one.

The archive is not corrupt, but compressed with WinRAR v5.xx. So you have to install a newer WinRAR version (latest is v5.31), if you want to unzip it.

Ok sorry for this, I installed latest version Winrar 5.31
Still showing me error
was trying to upload a pic to show you the error, but unable to figure out how here.

@MikeHawk :
You may have corrupted the archive by using an outdated WinRAR version.
Solution: Re-download the attached package and unzip it with WinRAR v5.xx.
I just have tested it without getting any problem while extracting the content of the package.

Off topic: Please avoid unneeded blank lines (to save space and to improve the readability of your posts).

Ok, moron time now. I rebooted & it works now lol.
So I guess I will give a try right now. WTH why not …

Quick question. Do I need to take the cert file out of the folder & place it in the USB drive? Or leave inside folder & put it in a folder with other 3 files? Sorry for all of this. Just trying to get it right.

@MikeHawk :
Have you read my side-note within >this< post and the Off-topic part of my last post?


You cannot import the Certificate as long as the OS has not been installed.
The driver is digitally signed, but maybe the Win7 Setup will not trust the organisation (Win-RAID CA), which has done it.

About the cert line needing 3-4 lines if there is more than 1 device?

I do not understand what you mean.
Your last post verifies the discrepance between the size of your post (needs 1 line) and the size of your signature (needs 9 lines).

Ok now I am lost.

Your side note states Side note: Your Signature is fine, but uses too much space. If you enter more than 1 device into a line, your signature will not need more than 3-4 lines.

So this is where I am lost. I have the file you attached. I opened it & extracted those files to a folder & added them to a USB drive. Now you are saying I need to add lines to this signature file?
I double clicked the import certificate file & it opened a cmd window & asked me hit enter & say "Y" yes to something. Now it added the lines it needed? Or it has now signed this driver?

  1. Neither this side-note nor my "off-topic" notice has anything to do with the AMD RAID driver and its digital signature. What I meant is your personal Forum signature listing the details of your current system.
    2. Where have I written, that you shoud add lines to your signature? I asked you to remove 5-6 of them.

That is nonsense.
I told you already twice, that it doesn’t make any sense to import the digital signature of the modded driver before starting the Win7 installation.

Ok I understand the way my forum signature might take up some extra space. I did not realise that it was such an issue. But I’m thinking you are talking about a signature in the driver cert, not my silly forum sig. I appreciate that my forum sig might be an issue for you. But I’m kind of focused on getting this problem fixed, if fixable. So I can move on with my life. lol
This is a little over my head. My overall knowledge of drivers is they are needed. That is about it.
I told you already twice, that it doesn’t make any sense to import the digital signature of the modded driver before starting the Win7 installation.
I apologise for my confusion. So do nothing to the .rar file you uploaded & try it “as is”. But also try the Vista/Win7 64 bit driver for the previous south bridges 7xx 8xx. I hope that helps with my adjusted forum sig

Yes, load the driver as it is (without trying to import the certificate at that point). The driver has been digitally signed by me. So the import of the certificate is not required to get the driver digitally signed. Nevertheless it is possible, that the Win7 Setup will not accept the digital signature of the driver, because the driver has no WHQL stamp from Microsoft (Microsoft’s digital signature gets lost by each modification of any file, which belongs to the driverpack).

Yes, you should prepare them both and load the older Vista driver, if the mod+signed Win7 driver will not be accepted by the Win7 Setup.