[Solved] Win 7 x64 intel 10th gen (Comet Lake) Intel UHD 630 Video driver

Hello I am trying to figure out how to install 10th gen (Ice Lake) Intel UHD 630 Video driver plus other drivers such as network adapters and etc on a Windows 7 OS. I recently bought a Dell Alienware Area51m r2 with these specs:
10th Gen Intel® Core™ i9 10900K (10-Core, 20MB Cache,3.7GHz to 5.3GHz w/Thermal Velocity Boost)
NVIDIA® GeForce® RTX 2080 SUPER™ 8GB GDDR6
64GB Dual Channel DDR4 at 2933MHz
OS: Windows 10 Pro 64 bit and Windows 7 Ultimate 64 bit (dual boot)
My Intel UHD 630 Hardware IDS:
PCI\VEN_8086&DEV_9BC5&SUBSYS_099B1028&REV_05
PCI\VEN_8086&DEV_9BC5&SUBSYS_099B1028
PCI\VEN_8086&DEV_9BC5&CC_038000
PCI\VEN_8086&DEV_9BC5&CC_0380
My NVIDIA RTX 2080 Super Hardware IDS:
PCI\VEN_10DE&DEV_1ED3&SUBSYS_099B1028&REV_A1
PCI\VEN_10DE&DEV_1ED3&SUBSYS_099B1028
PCI\VEN_10DE&DEV_1ED3&CC_030000
PCI\VEN_10DE&DEV_1ED3&CC_0300
The only thing I managed to modify and install on Windows 7 OS was NVIDIA® GeForce® RTX 2080 SUPER:


I tried to install other drivers to it even network adapters but they all failed due to the incompatibility of the OS.
These are my BIOS settings :




If there is anyone who could help me with this that would be very much appreciated because I have tried different methods but none of them worked so far.


This isn’t Ice Lake, but Comet Like.
Unfortunately, my public mod for Comet Like isn’t compatible with Q0 stepping. It supports G1 stepping only.

@DeathBringer I tried your mod and it worked thanks. It seems my laptop supports both Q0 and G1 stepping. Now the only problems I have are the other drivers I mentioned such as Network drivers the NVIDIA® GeForce® RTX 2080 SUPER driver (code 12 error) and the drivers that has the exclamation marks on them.

Show screenshots.

@DeathBringer here you go:

@Shadic12
Thx! Can you show Mainboard tab of CPU-Z?

@DeathBringer Here it is:

@DeathBringer do you know a method on how to modify network adapter to work on a windows 7 OS on a modern laptop? I tried to do download the drivers on Intel website but every time I install it doesn’t work.


No, I don’t analyzed it. My motherboard ASRock H410M-HDV has Realtek’s network adapter. It’s compatible with Windows 7 & 8.1

@DeathBringer alright I will see if Realtek’s network adapter works on mine.

Just wonder if your computer has CSM support or only UEFI?
I try to install windows 7 in comet lake system with H470 chipset and failed.
Could you share your experience, like which kind of windows 7, which files modified or which drivers integrated?
Thank you.

@donaldtone
Use UefiSeven to install and run Windows 7 on systems without CSM support.

I’m trying to get a Comet Lake laptop (Lenovo T15G, i7-10850H) running Win7. I’ve installed the modded drivers (thanks!!) and according to Device Manager they are loaded.

Unfortunately, I’m stuck in VGA mode. I think this is because Win7 is unable to find a monitor (the section is entirely missing from Device Manager.) Could this be due to an incompatibility between my Comet Lake system and the modded drivers? If so, would you ( @DeathBringer ) be amenable to helping me figure out a fix?

cpu-z.png

device man.png

I don’t know the reason.

Thanks for the reply… Looks like Win10 for this machine then.

wrong topic