[SOLVED] Win7 wont boot on my acer nitro 5, even using modfifed uhd 630 signed drivers.

Before i get into anything, to get a better unstanding of this, all of this was disscussed at the reboot pro forums http://reboot.pro/topic/21991-windows-7-…l-issues/page-3 If you need a better understanding with whats going on. Allso theirs a guide to installing the os on 8th gen cpus.

Below here is just a shorted down thing here just to get you an idea of whats going on. But is best if you look at the guide on their.

We install using an modified 630 uhd driver. That has already been modifided. We sign it using this guide here http://woshub.com/how-to-sign-an-unsigne…-windows-7-x64/
Note theirs a few modifications beetween the guide at windows hub and the one on the reboot pro fourm.

Then we extracrted the reigstry key using https://security.stackexchange.com/quest…iven-only-physi
With a few modifcations beeweetn this and the reboot pro guide

Get all of that onto a usb, when get a windows 7 install.wim file, and make sure that you use an bootmfgw from an windows 10 or elase it wont work with rst and optane, and neither do i think it works with the other sata modes.

Then to do all of this, we used a windows 10 medicat mini usb, we added the iso using dism. Before hand also cleaned the hard drive into an w parition for all the main stuff and an s for the boot files.
Also installed the modifed Intel driver on it too.

Then disabled legacy vga from the w partition

set Services=HKLM\loaded_SYSTEM\ControlSet001\Services
reg.exe load HKLM\loaded_SYSTEM W:\Windows\system32\config\system
reg.exe add “%Services%\Vga” /f /t REG_DWORD /v “Start” /d 4
reg.exe add “%Services%\VgaSave” /f /t REG_DWORD /v “Start” /d 4
reg.exe unload HKLM\loaded_SYSTEM

And then with the wim file added with dism, you need to get rid of vga.sys, since you need specical permissions and all that you need to use unlocker and delete the file that way.
Then copy the bootmfgw file to the boot partition.

Then you need to disable it again from the efi parititon

bcdedit /store “s:\efi\microsoft\boot\bcd” /set {default} bootlog yes
bcdedit /store “s:\efi\microsoft\boot\bcd” /set {default} bootstatuspolicy IgnoreAllFailures
bcdedit /store “s:\efi\microsoft\boot\bcd” /set {default} novesa on
bcdedit /store “s:\efi\microsoft\boot\bcd” /set {default} quietboot on

Then using the registry key guide you need to add the reg files.
Also you need to put the commands
reg.exe load HKLM\loaded_SOFTWARE C:\Windows\system32\config\software
Before you do add them

and after you add them
reg.exe unload HKLM\loaded_SOFTWARE

Then reboot the machine, it will be blank, it will reboot, and then it will say checking device performence, then everything should go on from their.

Now the acutall issue

I need to further test with rst with optane, but it doesnt seem to working that good. Just not rebooting at all.
My machine will reboot, however it will just stay blank, and wont say checking device performence.

Thankfully the machine is using the modifided uhd 630 driver, or elase it wouldnt reboot at all.

Note xchi support and fast boot is turned off.

Ill have cash reward for who ever can get me a solution to this.


Note “loadoptions DDISABLE_INTEGRITY_CHECKS” and “TESTSIGNING ON” and “nointegritychecks ON” Dont need to be on.

Maybe use PE system to run WinNTsetup will be more easily.
And you can try this UHD630 driver, I use signtools with SHA256 to sign it.

@canonkong no linked file or thread, thanks

@Popoof22 - you need matching RST roms in the BIOS, to go along with whatever version drivers/software you’re using (not exact match, but at least updated to same series).
What driver version are you using? Link your BIOS and I will update it for you.

Cheers thanks for the reply
Driver version is link to download https://www.station-drivers.com/index.ph…id=3256&lang=en if you need
Note it needs modified

How do you mean link your bios? Like link one from the acer website and their drivers?

Its a Insydeh20 bios just to let you know

Yes, I mean link to your BIOS. I don’t need links to RST drivers you are using, but version info would be good to know
What is your chipset? All my reply was in regards to your question/issue with the RST/RAID etc, nothing to do with graphics

And actually, since this is Intel (Still link stock BIOS too) - Check BIOS main page and see if ME FW version is shown, if not then download HWINFO64 and on the large window on left side, expand motherboard and find ME area, inside that get the ME Firmware version.
Once you have that, go to this thread and in the section “C” download the matching ME System Tools Package (ie if ME FW version = 10.x get V10 package, if 9.0-9.1 get V9.1 package, if 9.5 or above get V9.5 package etc)
Intel Management Engine: Drivers, Firmware & System Tools

Once downloaded, inside you will find Flash Programming Tool folder, and inside that a Windows or Win/Win32 folder. Select that Win folder, hold shift and press right click, choose open command window here (Not power shell).
At the command prompt type the following command and send me the created file to modify >> FPTw.exe -bios -d biosreg.bin

Right after you do that, try to write back the BIOS Region dump and see if you get any error, if you do show me image of the command entered and the error give >> FPTw.exe -bios -f biosreg.bin

If you are stuck on Win10 and cannot easily get command prompt, and method I mentioned above does not work for you, here is some links that should help
Or, copy all contents from the Flash Programming Tool \ DOS folder to the root of a USB Bootable disk and do the dump from DOS (FPT.exe -bios -d biosreg.bin)

The issue he has is that his CPU is an i5-8300H Coffee Lake, for which the simple inf mod doesn’t work. I think he needs your driver from baidu on this post which is dead: Win 7 x64 Coffee Like UHD 630 Video driver (2)

In those posts you also say that coffee lake doesn’t need skylake or kabylake emulation. You provided the parts we need to add (only for win7), but i don’t really get it. That’s why I think it’s best to send us that driver again, so that popoof22 can use it. Would be great to include win8 and win81 support so that he can easily test running a windows with screen output.

@canonkong : can you reupload this driver from baidu? Win 7 x64 Coffee Like UHD 630 Video driver (2)

Ill close this since it is no longer needed

Solved using the help and kindness of canonkong’s driver that works for uhd 630 of i5-8300h. See here: Win 7 x64 Coffee Like UHD 630 Video driver (2)

Many thanks again friend!

@Popoof22 :
Due to the fact, that your problem obviously has been solved, I have slightly customized the thread title.

Boots but i need ethernet driver, then im completely sorted

Dude could you upload a step by step tutorial …iam also trying to get this nitro 5 to dual boot with win 7…A video be great …
I just used ntlite with no avail…
I try to do all steps and then repack to a wim using dism …and then do the cmd efi tweak on allready Rufus made pendrive …
It gets forever stuck on windows is loading files

[VIDEO] How to get Win7 installed onto modern Intel Chipset systems (with an 8th Gen CPU) plus drivers


[GUIDE] How to install Windows 7 x64 on Acer Spin 5 laptop (guide can be adapted to more UEFI class 3 machines)