[Tool] EFIFlash v0.80/v0.85/v0.87 for Gigabyte Mainboards

thank you,

soon reflash my z270

Good luck! :smiley:

Can this tool be used to also dump the backup bios?
I’ve used fpt in the past to do an upgrade and mac adress was lost, possible some other values like hardware uuid.
I’m looking for a way to dumb the full content of the backup bios without any external programmer.

@graphine - flash backup to main, then dump main and you will have all that, use PS/2 keyboard if possible (others, and USB3 may not work), press CTRL+F10 on startup (many times as it boots, like you were trying to enter BIOS).
If you do not get screen to flash backup to main, then reboot and keep trying. I Hold down ALT or CTRL then spam the other key
ALT+F10 flashes main to backup
CTRL+F10 flashes backup to main

If you end up at screen with option you do not want, don’t hit OK, just reboot and do the other way around.
On older boards, like Z68 and before, it’s F12 + ALT/CTRL, this also does something on UEFI BIOS too, but I forget what happens with CCTRL/ALT+F12 on UEFI

UUID is not used in Gigabyte BIOS, only MAC ID and you can get that off sticker on the LAN Port.

EFIFlash may backup both via EFIFlash backup.bin /S /DB
Or maybe just /SB? I am not sure, I will test now

* Edit - no luck, with /S /DB, or /SB or /SD or /SDB or /S /DB or /DB /S
Seems like not possible, you will have to use above ALT/CTRL method, or just fix main BIOS MAC ID manually.

CTRL+F10 not working on usb 2.0 keyboard, I will try with ps/2 later.
I’ve already fixed MAC ID by flashing with FPT, if that is the only ID stored in the bios chip then it’s all good.
Maybe I will try to read the backup chip directly via SPI for curiosity.

I wonder if flashing backup to main will restore the entire chip including gbe but preserve MAC ID.

Yes, USB 2.0 works, but it’s hard to do, MUCH easier with PS/2
Yes, I just mentioned in the other thread MAC ID is fixed in BIOS you attached there

Flashing backup to main will flash entire backup to main, all contents. GbE is same in both and MAC ID will be there in backup too, unless you flashed empty GbE to backup previously

I didn’t intentionally flash backup bios until now, only if it did it automatically.

I was trying to understand how things were when the board was new and what got messed up when I flashed with FPT.
Original bios contained gbe region mac id -> downloaded bios contained the generic 88 one.
Flashing bios normally will not flash gbe region, flashing with FPT replaced everything (to allow downgrade from F20 TO F6).

At some moment when using qflash after a bad mod bios i saw updating backup bios. This could have replaced everything on the backup bios as well. But since the only ID is mac it was easy to fix.

For future boards I will first backup both bios chips, maybe with SOIC 8-Pin clamp since no software can currently dump both chips.

Automatic one would wipe out backup MAC ID, if your main BIOS had blank MAC ID (88 88 88 88 87 88) << That’s the only thing that would have been messed up by flashing stock Gigabyte BIOS with FPT, and sometimes MAC ID is stored in GbE twice too, you’d have to check that in your backup flashed over to main to see if it’s in your GbE twice by default

FPT only flashes GbE if you tell it to flash GbE (ie use -gbe switch), or if you flash entire BIOS all regions without a switch (FPTw.exe -f biosfile.bin)
If you are just flashing mod BIOS, and you KNOW you dont need to reflash modified FD or ME in there, and you want to use FPT, then this is the command you should use >> FPTw.exe -bios -f filename.bin
When doing this with FPT, best to backup first, then edit, then reflash >> FPTw.exe -bios -d backup.bin

For your board though, all you have to do is edit that one byte (at 0x7D05EFh >> Edit 01 >> To 00) and then you can Qflash mod BIOS

Could this be used on Gigabyte Z87MX-D3H which is an APTIO IV motherboard?
Thank you!

Original MAC adress could be preserved when you flash with FPT by -SAVEMAC argument.

@nikoZ I don’t have any Z87 Gigabyte board to test with so I don’t know. You could try the unmodified version first with a stock BIOS and see if you get any error messages. With Z87 being Aptio IV it might just refuse to work at all.

Ok. I will test in the spare time, and report back.
Thank you.

i used the stock efiflash 0.80 from a zipped GA bios and flashed both main and backup bios.
with the following command "efiflash bios.xxx /DB /X"
In my case i just wanted to downgrade the backup bios and this did the trick.Bear in mind that i flashed a stock bios not a modded one.

I didn’t know efiflash can do that so thanks for the info :slight_smile:

Do you think this would help to flash my bricked MAIN BIOS of my GA-AB350 Gaming 3? I tried everything. I’m on the backup right now.

@Krist0fh - Yes, use stock flash tool and above command. Ahh yes, so you can use hotkey below info, or ignore I just grabbed BIOS F51b (wow, they made a LOT of BIOS for this model, most I’ve ever seen!)
Anyway, in it’s help text >>
Switch options for Efiflash.exe:
/C - Clear DMI data. (default: Keep DMI data)
/S - Save Original BIOS Image to Disk
/R - Reboot System after BIOS Update
/DB- Update both main & backup BIOS

So, boot to DOS and run EFIFlash.exe filename.f51b /DB
DualEFI will help you switch BIOS, I think, maybe, if we can get it for you

That, or try PS/2 Keyboard and Hotkey combo to flash backup to MAIN (BE SURE, you flash BACKUP to MAIN, it will ask you if you want to proceed before it does anything)
Sometimes it takes a try or three before you time it just right. It needs to be done at bootup, where you’d normally hit DEL to enter BIOS. Spam hotkey combo, if you get boot menu, reboot and try again until you get it.
I explain more here about this - Gigabyte GA-Z97X-UD5H-BK BIOS upgrade (3)

Or, you can also try DuelEFI mentioned one post below the linked post above (#35)
I will PM @thinking now to see if he will still send me the tool, if he sent already I must have lost it?
If you have, and can send, attach zip here renamed .txt, maybe that is OK with your firewall?

Oh thanks. I will try my best. I might get lost because I don’t really understand so well some things. I might need a tutorial for 5 years old.

@Krist0fh - If you don’t know how to make DOS Bootable USB, you can google Bootable DOS USB Rufus and you should find guide to make. Then copy efiflash + BIOS onto USB, then run command I gave above.
Or, you can follow step #1-2 ONLY here, then copy also EFIFlash + BIOS onto USB (USB may look blank to you after #1-2, this is OK) - <Request> Flagship X470 Gaming 7 Wifi Motherboard BIOS Fix
To boot to DOS >> at startup, hit F12 to get to boot menu, there choose USB (not UEFI USB). Or, from BIOS Exit page, go to Boot Override and choose your DOS USB (not UEFI one)

Thanks for creating and sharing this tool. This is the problem that I’m having since trying to flash a std BIOS for my z390 Master motherboard since I used a Gigabytes own modified one which included basic RGB lighting control. I now just get OEM Mismatch errors on both the QFlash and the EFI Flash.

So this was linked in another forum and I then found this site to read about the .80 version and what it is able to do. But for me I still get the OEM Mismatch issues when trying to flash back a std Gigabyte Z390 Master BIOS…

**** sorry can’t post a link to show that DOS error with the 0.80 tool showing the OEM Mismatch error ****

this is using the 0.80 version of this tool which is supposed to resolve that issue…?

Any help please…?


All worked fine, with great help, using the 0.85 version of this tool.


@Vimes - Great you got it sorted! Yes, they linked you to the wrong thread, you needed this thread for the mod version

Many thanks, I do appreciate that. Was getting a little concerned there…!!!