[Tool] EFIFlash v0.80/v0.85/v0.87 for Gigabyte Mainboards

Gigabyte recently released EFIFlash v0.80 of the DOS based BIOS flashing tool for Gigabyte’s Z390 platform, although it is also compatible with 100/200/300 series Intel chipsets [Edit: and 400 series using v0.87], as well as AMD X570, X470, X370, B450, B350, A320, X300, A300, and PRO 500 chipsets.

What’s so special about this release?

From v0.80 and above users of motherboards with Gigabytes ‘DualBIOS’ can now update the backup BIOS via the command line switch /DB.

This means that any ‘DualBIOS’ motherboard that doesn’t have a dip switch to switch to the backup BIOS can now have the backup BIOS flashed manually.

EFiflash normally only flashes the backup BIOS chip if;

(i) the new BIOS is a major release with higher/newer version

(ii) the new BIOS is not a beta BIOS

While this is fine for most users, there are some cases where you may want the backup BIOS chip to have the exact same BIOS as the main

For example, if you rely on a beta BIOS that is the final release for you motherboard and you know it is stable or if you have a modified BIOS with custom settings (such as RAID always enabled) or you want to run a Coffee Lake CPU on a 100/200 series motherboard and still be able to boot if the backup BIOS chip kicks in.

Command line options

The command line for EFIFlash needs to be run using a DOS bootable USB stick (can use either MSDOS or FreeDOS) or UEFI shell and the commands are not case sensitive:

efiflash filename <options>

/S Save current BIOS file to a backup file on your USB stick
/C Clear DMI
/R Reboot
/X Force Flash
/DB Update both main & backup BIOS

E.g. efiflash bios.rom /db

This will flash the BIOS file to the main BIOS chip and then the backup BIOS chip sequentially.

WARNING: Use common sense and don’t flash the backup unless you know you can recover the motherboard with a SPI programmer if the flash fails for any reason!

Disclaimer: I am not responsible if you brick your motherboard, you need to decide if the benefits outweigh the risks!

[Edit] Added Dsanke’s modified Efiflash for those that may need it - thank you Dsanke!

[Edit] Added newer versions to support newer chipsets (e.g. Intel 400 series) and UEFI versions for booting from a UEFI shell

[Edit] All EFIflash versions in my possession have now been uploaded to this MEGA folder.


I ha x470 aorus ultra gaming, my main bios don’t work (cpu led blink with dram led), i boot with backup bios.
With efiflash /db rewrite main and backup bios?

With this version I honestly don’t know, you would have to try it - note that it is not without risk if the backup fails to be flashed for any reason then you may brick your board.

With previous versions of EFIflash if the board has booted from the BACKUP BIOS and you attempt to flash the MAIN BIOS to repair the corruption, it will flash the BACKUP chip even though the command line will say it is flashing “MAIN” BIOS.

Gigabyte has a Windows tool called “Gigabyte Firmware Update Utility” which you can apparently use to recover the MAIN BIOS chip by booting from the BACKUP BIOS chip into Windows and then running the DualBiosRescue.exe which will copy the BACKUP BIOS to MAIN BIOS, I have never used it so I can’t comment whether it actually works.

Once installed, the DualBiosRescue.exe is located at;

C:\Program Files (x86)\GIGABYTE\GigabyteFirmwareUpdateUtility\DualBiosRescue.exe

Link to the latest version; mb_utility_gfu_B19.0227.1.zip

I have no idea whether this will work on your motherboard but I would try it before you attempt to use EFIflash.

Yesterday I took courage and used DualBios Rescue.exe.
Damage didn’t make them, he made 2 passes (1 quick and 1 quite slow), he finally restarted the PC and I had no problems.
I disconnected the power supply, situation for which you had the problem cpu led blink with dram led (M_bios), and to my astonishment the PC has restarted correctly.
Now I don’t know if I really recovered the M_bios, in the next few days I’ll let you know.
For the moment I am satisfied
Thanks for your help

Thanks for the update.

From my experience when the motherboard is starting from the B_BIOS the motherboard speaker gives 6 short beeps (to indicate it can’t boot from M_BIOS) before it finally POSTs from the B_BIOS.

I have a way to copy the back bios to main. In the q flash of back bios, first back up the back bios. Then update from the back up of the back bios document, choose intact module. At last the main bios will be updated.

I tested the normal and the modified version of efiflash 0.80 and I got unreadable message . See attached picture

@Houacine Which version of DOS did you use and what motherboard do you have?

I used MS-DOS . Prepared the USB key with Rufus
Motherboard MSI B450M pro vdh plus.
Flashed with Gigabyte b450m gaming
AMD Rysen 3 3200g
Ddr4 2×4GB dual Chanel

@Houacine So are you saying you cross-flashed an MSI motherboard with an Gigabyte BIOS?

I cross-flashed the MSI after a fail upgrade to the latest bios.
The mobo stopped completely. No post.
I used the ch341a to flash it with MSI bios but it goes until 100% but when verified, the content of file and bios-chip was different.
So a I found on the web that the bios of Gigabyte b450m gaming is compatible with the card. I flashed it and now I have an MSI mobo working with Gigabyte.
I’m looking to reflash this (false GB) to restore my original msi

@Houacine Which ch341a do you have - green or black? The black pcb version supplies 5V to the chip due to improper design, the green pcb version works correctly by supplying only 3.3V to all pins.

The Macronix 25U128 (128 Mbit EEPROM) is rated for [Edit]1.65 to 2.0 volt so if you feed it 5V it may corrupt the data or damage the EEPROM.

How many times did you attempt to write the MSI BIOS using the programmer?

If you have a green pcb ch134a I would certainly try it again with an official MSI BIOS that you know worked 100% before.

If it fails to verify then you may need to adjust your clip for better contact with the pins.

If it still fails to verify then you may need to try different versions of the software until you find one that will verify ok.

The Macronix 25U12873F is rated for 1.8V (datasheet of manufacturer).
I tried many times with different bios’s downloaded from msi site.
The gigabyte bios was flashed easily. with the same soft and same green programmer.
Also I used spipgmw.exe on lpt port to the jspi1
The chipset mx25u12873F was identified exactly, disabled write protection, erased and programed.
Same result, gigabyte bios successed but msi failed

At this stage you may want to RMA if still under warranty.

I don’t think I can help you any further - good luck!

is there a tool that bypass verifications and flash it directly

For AMD chipsets I don’t know of any - only FPT (Flash Programming Tool) for Intel chipsets.

Is this tool able to downgrade ME on a gigabyte motherboard?
because my z270x gaming k5 is locked at me 11.8

@hasandoel2 Yep, it sure can.

efiflash bios.rom /x /db

so i’m using this?

@hasandoel2 No, just use;

efiflash bios.rom

Use the modified version of efiflash.

The /x command only needs to be used with the original version of efiflash, the modified version has protections removed.

Once you know that the modified BIOS works 100% then you can use the /db switch and flash both main and backup BIOS.