[Tool] EFIFlash v0.80/v0.85/v0.87 for Gigabyte Mainboards

@Vimes - You’re welcome! Any time you have BIOS issues, or need something edited, let me know, I can usually help

Updated the OP to include EFIflash v0.85 as it may be required for newer BIOS/motherboard.

Sorry to bother you again but, does it matter if I’m in the F25? Should I go in order before jumping to the last one?

@Krist0fh - Per all the warnings on that BIOS download page, if none apply to your CPU, and you already updated to latest AMD Chipset drivers, then it should be OK to directly update from 25 to 51 using EFIFlash (If you already updated EC FW as noted below)
However, if using Qflash you would need to update to F31 first via EFIFlash or @BIOS, sounds like Qflash update.

Also, at F40, be sure you note this and do before F51 too >> 2. Before update BIOS to F40, you have to install EC FW Update Tool (B19.0606.1 or later version) to avoid 4DIMM DDR compatibility on 3rd Gen AMD Ryzen™ CPU

So, if I was you, to avoid any possible issues, I would update to latest AMD chipset driver, then install the EC FW Update too, then flash to F31, then F40, then F51

I’m very sorry, I haven’t come to the forum for several days.
See your message,I came to this thread as soon as possible.
I remember in this thread([HELP] Gigabyte MD71-HB0 : Onboard LAN MAC Adresses wiped (00:00:00:00:00:00)…How to solve?), our friend Nozay33 solved the problem with eeupdate 5.3, and he uploaded the file on the #15 floor.

@thinking - It’s OK, thanks for stopping back in! I already have eeupdate, don’t need that.
I was asking for you to send me DuelEFI tool, you discussed here at post #35 - Gigabyte GA-Z97X-UD5H-BK BIOS upgrade (3)

I’m sorry I got it wrong. I’ll fix it right away.
A few months ago, it became slower and slower to visit this website, so I didn’t go to it every day.

Another primary and secondary BIOS converter SWITCHN.exe
Using this in DOS only, you can switch between the main BIOS and the backup BIOS. (It may only support the old motherboard without UEFI function and DUALEFI.exe support new motherboard with UEFI .)

DUALEFI.rar (34.1 KB)

SWITCHN.rar (892 Bytes)

@thinking - Thank you! Is the site still slow for you? If yes, do you think it’s our site, or due to your country firewall?

Now I have to get used to this kind of network environment. At present, it’s not bad.
The most pleasant thing is that I can get to know many experts on this website, you, SoniX, and webmaster plutomaniac…

@thinking - Yes, please stick around and hang out with us more often, when you can
Do you edit BIOS too?

Oh, no, I’m not as good at editing BIOS as you are, but I’m the beneficiary of you masters, so I’m also willing to share good methods, good software, and contribute to the forum.

It’s amazing. My MAIN BIOS it’s unbricked. I flash it with Efiflash to the f31 and in booted well. This was not the surprise. Then I turn off the PC unplugged the power, a minute later plug it back and I turn it on and unbelievaly it booted (since unpluging the power will force the motherboad to boot on the MAIN insted of the BACKUP) considering that if I did this before it won’t even boot anything. So I’m now running in my MAIN BIOS !!! And I can’t worry about the power turning off and starting the PC with the backup reseting everything in the BIOS. Incredible. Thanks. Now, my question is, it’s worth to upgrade the BIOS to the f51? Or I should keep mine in the F31? The F51 brings something new or good for my PC? I have a Ryzen 1700 btw. Well I can’t express more apreciation for this. Thanks and sorry for this butchered english.


Really appreciate all the work you have done here. I was wondering if you can assist me in the right direction. I have an OEM x470 mobo where when I try to update the bios I get the "oemid mismatch" error as it says above. Which version out of the 4 efiflash tools do I need to use to update to the latest firmware?

I just want to make sure I do it right and use the correct one as to get around the OEM restrictions of not being able to update the BIOS.

Am I correct in thinking it is the Efiflash_v0.85_mod?

I basically just want to overwrite there bios.

Any help would be muchly appreciated

Many thanks

@dom191984 Hi, I would try Efiflash_v0.85_mod first (after making a complete backup of the original BIOS) and if that doesn’t work try Efiflash_v0.80_mod.


Ok great. and when I run the mod in MS-Dos will it be this address line C:/efiflash X470AOUG.F51 /x

@dom191984 You can just use;

efiflash X470AOUG.F51


Many thanks for this.

Sorry one other thing. Do I change the name of the mod just to efiflash?


Sorry one other thing. Do I change the name of the mod just to efiflash?

@dom191984 You can name it whatever you want.


All done and worked like a charm. You are a legend for this. Really happy :slight_smile: