[Tool] UEFI Download Tool v1.86

Hello all i would like to present to you my program i have been developing for quite some time now called UEFI Download Tool.

You can visit my website to download it.

Last Updated: 3/31/2017

• Bug fixes & DLL Updates.

Details about it are listed below↓

UEFI Download Tool is a Tool that will find any UEFI updates for your desktop motherboard/laptop.
Works for all CPU Sockets and chipsets.
Supported Motherboard Manufacturers: ASUS, ASRock, MSI, Gigabyte, Dell, Alienware.

I use PhantomJS as a webparser for many things so first time running this, you may get a windows firewall message asking you to allow it.
You can safely allow this as it is what i use to parse websites.

The Version Control Feature:

Version Control.png

The UEFI Update Tab:

UEFI Update Tab.png

The Program Update Tab:

Program UpdateTab.png

The Preferences Tab:


The About Tab:

About Tab.png

The Extras Tab:

Extras Tab.png

Command line arguments are present to help you get out of any bad things that may occur.

Force Update Argument

Force Update.png

This will force an update to the latest version, incase you cannot launch the program to update from an app breaking bug, when i fix the issue you could update this way.

Reset Settings Argument

Reset Settings.png

This is useful for whenever your settings gets messed up and the program will not launch for whatever reason.

Seems like an interesting tool, unfortunately chrashes when i try to run it.
Motherboard is Asus Z87 Expert.


It should work with all LGA 1150 Boards from ASUS.
This program requires three dll’s that are needed for certain tasks. They are auto extracted to the folder is you don’t have them.
Check to see if you have the three dll’s in the same folder as program.

Also make sure you are running this program as admin, it needs admin, it should ask you to run as admin already how it is setup. if you have UAC turned on in window.

Some more info, there is only the .exe in the folder, i have UAC off and tried as admin, and OS is Win 8.1 64bit.
What dll’s does it need?

It’s working on my ASRock X79 Etreme6. It seems that I’m up to date :wink:

UEFI Download Tool.PNG

Awesome to hear :smiley:

Oh and also the check for updates tab is for the program its self and any updates i push out. The UEFI Updater tab is for checking for your bios updates.

Ok I see. That means the tool is looking for complete BIOS files or parts of the BIOS (OROM’s etc)?

Its checking what bios version you have installed vs what asus’s server bring back for your board that is auto detected, and if you don’t have the latest bios update it will tell you there’s and update and you click the download update button. So yeah BIOS files pretty much. but if your’re up to date already then it’ll say you’re up to date.

I will try it a Little later on my Maximus 6 Gene also.

Sorry for late reply i needed to get the links for the dll’s that for some reason aren’t extracting right for you.
You need these three dll’s put them in the same folder as program.

Ok understand. Thanks for answering…

Also apparently this is a major problem i didn’t see till now, i got a requesting board notification from someone who sent me a report cause their board company was not supported.
They had ASUS, Problem was the company made their name ASUSTeK COMPUTER INC instead of ASUS, i am pushing out a update in a few minutes that fixes this problem for all asus users. sorry for inconvenience.

Also anyone looking to get the latest version of their BIOS anyways even if they are already on the latest update, go to Preferences > Spoof UEFI Version To 0 Option.

Thanks for this tool. my motherboard is ASUS P8P67 but I get error :frowning:


I know i have a bug with asus which was my fault, i was checking for asus instead of asus tech inc, update will be pushed out in a few minutes, go to check for updates tab to update program.

Weird, i put the dll’s in the same folder, but still crashing.
From Event Viewer.

Faulting application name: UEFI Download Tool.exe, version:, time stamp: 0x534fbb80
Faulting module name: KERNELBASE.dll, version: 6.3.9600.17055, time stamp: 0x532943a3
Exception code: 0xe0434352
Fault offset: 0x00011d4d
Faulting process id: 0xc64
Faulting application start time: 0x01cf5a3b9efe61b1
Faulting application path: C:\New\UEFI Download Tool.exe
Faulting module path: C:\Windows\SYSTEM32\KERNELBASE.dll
Report Id: dcad4fe9-c62e-11e3-82bd-ac220b749db4
Faulting package full name:
Faulting package-relative application ID:

Application: UEFI Download Tool.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.FormatException
at System.Number.StringToNumber(System.String, System.Globalization.NumberStyles, NumberBuffer ByRef, System.Globalization.NumberFormatInfo, Boolean)
at System.Number.ParseDecimal(System.String, System.Globalization.NumberStyles, System.Globalization.NumberFormatInfo)
at UEFI_Download_Tool.UEFIDownloadTool…ctor()
at UEFI_Download_Tool.Program.Main()

@ GlitchyHack:
Thanks for publishing your interesting tool.

At first try the tool worked with my ASUS P8Z77-V and showed, that it is up-to-date, but after a retry I got this message:

Error message UEFI Download Tool.png

Like i said there was a a major problem with asus because i was checking for the wrong set of words. I have fixed this now, i pushed out a update 0.6 All ASUS users check for updates with the check for updates tab to get this fixed.