Toshiba Satellite Pro R40-C-10W Stuck at Toshiba Logo

Hello everyone :),

I have a question, i have been assigned at work to flash a bricked bios on a satellite PRO r40. The laptop is sitting on the Toshiba logo and doesn’t proceed forward with posting.
I can’t seem to be able to force flash the bios as I don’t exactly have the correct file to do the flashing. Can someone help me get the correct files for flashing the bios and help me find the right key combination to start the flashing?

I downloaded the zip file from the dynabook website and unzipped the exe file, i think i found the bios file because there is only one big file but i have no idea what to rename it as to flash the bios correctly and i cant find that information anywhere.

So far i have tried the key combinations:
ctrl + home - WIN + B - WIN + R - FN + R - FN+ B - FN + U

Any help would be appreciated :slight_smile:

Hello.

Why do you think this laptop has a system of bios recovery?

Good point. Although I think most of the laptops and machines overall nowadays have some way to recover the BIOS. I also have a way to flash the BIOS chip itself but the imminent problem is that I don’t exactly have the correct file to flash the BIOS to the chip itself. If I can find the correct file to flash on the chip I can also do it externally not necessarily from a recover menu within the motherboard.

Dump the bios/ firmware before flashing with a programmer (if you’re interested in preserving machine specific information like service tag, S/N, …)!

Post the information you have, for example attach the update file og at least the link.

And what makes you think it’s a bricked bios? I there a timely relation to a bios update or settings change?

@Beam
I can’t extract nor find bios file. Maybe I can figure out which part of update .exe is a bios file if you share a copy of your corrupted bios.

Hereby I’m attaching the .rar file that contains the bios .exe file which I’ve downloaded from the Dynabook (Toshiba) website. It’s their latest one as they apparently don’t keep older versions. Please let me know if you can figure out which one of all these files is the bios file I need to program the chip myself.

bios-20190107141045.zip (6.8 MB)

I am guessing that is an bricked bios because:
1. Doesn’t get past the Toshiba logo when I turn it on
2. Can’t access the bios
3. I tried to do an clean install of windows on the laptop but that did not work because there was a supervisor password installed in the bios, other colleagues of mine tried to remove that and afterwards we could not access the bios at all anymore (they must have done something wrong and i sadly do not know what they exactly did)

We have tested other hardware inside the laptop but that seemed to be working fine so i personally came to the conclusion that there is a decent chance that it is the bios

Serial number = 6G039337H

@Sweet_Kitten Exe extracts to %Programdata%\toshiba Cut user rights for this folder to admin group, edit advanced permissions and uncheck ‘delete’, ‘delete subfolders and files’ then files won’t get deleted at once.

Bios is in com-file, use https://github.com/LongSoft/ToshibaComEx…leases/tag/v0.1

What I got from the file linked is attached, unfortunately not a complete image.

tosh1.zip (3.41 MB)

@lfb6

So how do you suggest that we get a full image out of that .exe file? I don’t think we can program it without a full image or am I wrong?

@Beam Thanks for telling us the complete story! In this case I don’t think the bios is really bricked but it might be doing what it’s supposed to do when someone fiddled with these measures.

‘Earlier’ those passwords were stored in CMOS or the NVRAM area, so starting with resetting CMOS and stock NVRAM did the job. Newer machines store the passwords outside bios firmware chip, unfortunaltely. Anyway not my cup of tea, no experience in this area…

Regarding getting a complete firmware image: Buy a cheap CH341 programmer and a SOIC clip (and a 1.8V adapter depending which chip) and dump the complete content of the SPI. Maybe the dump can be edited and fixed, as written, I don’t have any experience regarding passwords, I assume that Sweet Kitten will be able to help you!

Thanks for the advice!

In case someone else has more insight in that area please do let me know as I would still be searching for a way to get that laptop working again.