Toshiba XG5 NVMe Drivers for Installing Windows 7

I am all set up for Windows 7 on my new HP Spectre, but I can’t find the NVMe driver for Toshiba XG5 1TB SSD that’s inside this laptop. Thus, I am not able to get the Win 7 installer to recognize the SSD. I was able to get the whole process working on the exact same computer, but which has a Samsung SSD, so I know it can be done. Anyone know where I can find it?

I tried to add the NVMe hotfix from Microsoft to the install.wim, and I tried the drivers…rs/td-p/5782017 and Recommended AHCI/RAID and NVMe Drivers. No luck. Any advice would be incredibly appreciated! Long live Win 7!


NVMe Controller HWID’s:

I see the issue might not be the XG5, but the fact that the “modded” drivers found on this forum cannot be loaded without being signed from within the Windows 7 Installer. Looking for a workaround…

The problem is not the modded drivers, it is the fact they are not signed. From within the bootable Windows 7 installer, go to Repair windows installation, and there’s an advanced recovery option. Then there is an option to load drivers from within there. It will open up an explorer-type window that allows you to specifically click the .inf file from the modded drivers by Fernano. Then, when you go back to the installer (without restarting), the drives will show up.

Now working on BSOD loop because of the driver signature file…

@jakehero :
Welcome to the Win-RAID Forum!

As you have already realized, your problem has not been caused by the mod+signed OCZ driver itself (it has been correctly modified and digitally signed), but by the fact, that the OS Setup within this early stage is not able to check, whether the signer is trustworthy or not. Unfortunately the user has no chance during the OS installation to import the Certificate, which would verify the trustworthiness of the signer (here: Win-RAID CA).

Why haven’t you integrated the MS NVMe Hotfix (look >here<) into the Win7 image? After having finished the OS installation, it is no problem to get the mod+signed OCZ NVMe driver installed (after having imported the Certificate).

Dieter (alias Fernando)

Thanks for the quick reply @Fernando. I have already integrated the MS NVMe Hotfix, but upon looking closer from within NTLite, it says "Integrated (Install Pending)"

Is there another step I must do to fully integrate the fix?

@jakehero :
The Hotfix has to be integrated into the BOOT.WIM and INSTALL.WIM of the desired Win7 Edition.

@Fernando , yes, I already integrated the hotfixes into boot.wim, and install.wim. I integrated them a second time, following the instructions from the hotfix download page, and I also used NTLite to add the modded Toshiba drivers to the Windows 7 installer, but it still does not recognize from within the installer. Additionally, since trying this, now my trick to use the “Repair your computer” -> “Load drivers” option to add the drivers does not work. It now says “The installation has failed.” So I have no way to Install Windows all the way.

Are you saying I need to add the Certificate to boot.wim and install.wim too? I’m sorry if this has already been spelled out, but I’m having trouble finding the correct steps here.

When I try to boot, disregarding the signature error, I get " a required file is missing or contains error." on \Windows\system32\winload.efi.

No, you cannot add it.

If you want to install Win7 x64, you will have to do some additional steps after having created the bootable USB Flash Drive. Please have a look into point 11 of >this< detailed guide.

I did not have to do Step 11 from the guide above to get Windows 7 x64 running before. I tried it, but both versions of bootx64.efi were the same (it was already there).

I was able to install the certificate by opening up command prompt, and changing %systemroot% to E:\ (where Windows is installed) from within the Windows 7 installer. However this step does not change the fact that Windows still cannot boot.

The instructions that would be most helpful — starting with a fresh USB .iso of Windows 7, exactly what steps are needed to load the mod+signed Toshiba/OCZ NVMe driver during Windows 7 installation so that the computer will boot?

I started from scratch just in case something went wrong somewhere along the way. Steps:

1) Create Windows 7 Bootable USB using Rufus
2) Add USB 3.0 Drivers to USB, using this guide:…-usb-3-0-ports/
— At this stage, mod+signed Toshiba/OCZ NVMe driver can be loaded during Windows 7 install by going to “Repair your computer” → “Load drivers”
— Then Windows 7 WILL recognize the Toshbia XG5 SSD
3) Add Hotfixes (486575 and 477475) PLUS mod+signed Toshiba/OCZ drivers to the Win 7 installer, using this guide:…indows-7-and-wi
— At this stage, not only is the SSD not found, but the mod+signed Toshiba/OCZ NVMe drive WILL NO LONGER LOAD DURING WINDOWS 7 INSTALLATION using “Repair your computer” → “Load drivers” = “The installation has failed”
— Windows 7 will not recognize the SSD with the Hotfix + mod+signed drivers added

If I install mod+signed Toshiba/OCZ NVMe driver from Step 2, then install Windows without adding the hotfixes, computer enters error loop on \Windows\system32\winload.efi as driver is not “authentic” and the efi problem I mentioned above. I’ve been looking at these links:…dows-8-7-vista/…w7itprohardware
and wondering if I need to convert to MBR booting to use bcdedit to escape the error on \Windows\system32\winload.efi. I’m fresh out of ideas and have spent all day on this.

Any help would be very much appreciated! I need to get this laptop returned tomorrow so hoping to get it working.

@jakehero :
There is a report within this Forum, where a user was able to get Win7 successfully installed onto an NVMe SSD by loading one of my mod+signed NVMe drivers. He started the same way as you (using the “Repair” option), but I do not remember how he managed it, that the Setup rebooted into the NVMe SSD.
Anyway this procedure should work:
1. Integrate the NVMe Hotfix and the USB 3.0 drivers into the Win7 image.
2. Install Win7 in UEFI mode onto the NVMe SSD.
3. Optional after having completed the OS installation: Import the Win-RAID CA Certificate and then install manually the demanded mod+signed NVMe driver (maybe you have to force the installation by using the “Have Disk” button).

@Fernando there is no way I can find to complete Step 2. With the NVMe Hotfix including the mod+signed drivers, they do not load in the installer, plus the "Repair" load option becomes unavailable.

@jakehero :
You should not integrate or load 2 different NVMe drivers at the same time.
My advice was to integrate just the MS NVMe Hotfix and nothing else. You are not the first user, who tries to get Win7 installed onto an NVMe SSD. All the others obviously succeeded by inserting the MS Hotfix.

@fernando, so in the command lines that include "add drivers" what goes in those folders? Nothing?

Step 5 "Copy the driver files to c:\temp\drivers." is intended to be skipped?

If I understood your reports correctly, the mod+signed NVMe driver worked only once, but after the reboot the Setup didn’t detect the NVMe SSD anymore.
My conclusion: It doesn’t make any sense to load the mod+signed NVMe driver during the OS installation.

In your situation: Yes, since there is no WHQL certified OCZ NVMe driver available, which supports your XG5 NVMe Controller.

Ok, it worked! Win 7 install successful. Thanks a ton.

Interesting note: the modded driver was actually quite confusing in this context. I tried very hard to get it working before/after Win install to no avail. Even with Windows 7 installed, the modded driver results in a crash loop on my XG5. The "pure" driver works fine, selecting RD400 or XG3, once Windows is installed with the Hotfix.

@jakehero :
Thanks for your feedback. It is fine, that you finally got Win7 installed onto your Toshiba XG5 SSD.

That is hard to believe. The installation of a correctly modded driver is always better than to force the installation of an original driver, which natively doesn’t support the related HardwareIDs (by choosing a wrong, that means not present device).
Are you sure, that you hadn’t integrated the modded OCZ driver into the Win7 image? The problem is, that an integrated modded driver will always be seen by the OS as not digitally signed, even if the user imports later on the related Certificate.

I am positive I didn’t include the modded driver in the image. As I mentioned, the install will not even start if it is included. Anyway, the hotfix works, as long as no driver is included with the hotfix.

This is exactly what I recommended to do (to integrate just the hotfix, no additional driver).
It is fine, that you finally succeeded.

Thank you jakehero for asking this question…I was too ashamed to ask it. But NOW I will ask something perhaps even more embarassing. Fernando refers to a certificate in the third post of this thread…Win-RAID CA

But that is not a link. Is it not needed?

The Win-RAID CA Certificate is within all my mod+signed driverpacks and should be imported according to >this< guide before you are going to install the driver itself.