Trouble with NVME via PCIE x4 Adapter GA-Z68AP-D3 rev 2.0 with ua9 bios

I have Windows 10.

Sometimes my computer boots up and recognizes the Samsung 970 EVO connected to the adapter in my pcie x4 slot and lets me use that disk as a storage disk.

Most of the time it does not recognize this disk and I do not have access to it in disk manager or device manager.

When I go into my BIOS, it does not list this disk drive anywhere that I can find it.

Do I need to mod my BIOS to support and recognize this drive? Or do I need specific drivers for it?

@icecreamman :
As long as you don’t want to boot off the NVMe SSD, you don’t need to mod the BIOS.
Win10 has an in-box NVMe driver, which supports the NVMe Controller of all NVMe SSDs.
If the OS has problems with the detection of the NVMe SSD, you may try to put the M.2>PCIe adapter into another PCIe slot.

> If the OS has problems with the detection of the NVMe SSD, you may try to put the M.2>PCIe adapter into another PCIe slot.

So put my GPU in the PCIe x4 slot and the NVME SSD and adpater in my PCIe x16 slot?

Yes, that is what he meant. Sounds like you have a bad adapter maybe, since it should always show up. You may want to try another you can get them dirt cheap on amazon or ebay (less than $5), let me know if you need linked examples.

Yes, just for testing whether it is the PCIe slot or the M.2>PCIe adapter, which causes the problem.

So I actually have tried two adapters so far:
1. RIITOP NVMe Adapter M.2 PCIe SSD to PCI-e x4/x8/x16 Converter Card
2. Vantec M.2 NVMe + M.2 SATA SSD PCIe x4 Adapter

Both had this problem in the same pcie slot. But I will try putting the RIITOP one in the other pcie slot to see if it works or not

EDIT by Fernando: Links to the vendor of the adapters removed (we don’t like advertising)


I have similar motherboard and NVME connected via PCI adapter, and I think I nailed this problem (I mean, not have resolution) disk is dissapearing after sleep. I think it is a motherboard problem, not a adapter or disk. I don’t think we can fix it on bios level, maybe using main PCI lane for disk and secondary for GPU will fix it. I think I just will not using sleep function. But I’ll glad to hear better solution.

Fernando, Lost_N_Bios I would like to thank you for help you give here, I already learned a lot about matching hardware form different timeframes from your kind answers on this forum, Regards!

Okay I swapped the pcie port for the gpu and adapter. It works now.

But the GPU is running at pcie x1? I know that the pcie x4 bus shares bandwidth with the pcie x1_2 and pcie x1_3 lanes but nothing is plugged into those. Maybe if I swap which pcie x1 lane my wifi adapter is plugged into I can keep the gpu in the x16 lane and put the nvme adapter in the x4 lane.

My GPU in the pcie x4 lane unfortunately blocks access to 3 sata ports

Okay. Switched them back and then tried putting my wifi adapter in a different lane: wifi didn’t work but my nvme drive loaded…

Something is happening where the PCIe x16 and PCIe x1_1 are getting priority over the PCIe x4 slot. Could be my cpu is limited to a certain amount of pcie lanes? I have a i5-2500k. Maybe if I can force my gpu to run at pcie x8

So I will check this option myself then. If something new comes to my mind I will drop by.

It’s neither of these. According to the block diagram I should be able to run GPU in pciex16, nvme adapter in pciex4, and wifi adapter in pciex1_1.

Just gonna give up on getting the NVME Adapter to work for awhile. Can’t force my GPU to run at pciex8.

@icecreamman - So, when the NVME does work in the X4 slot, did it show up as X1 too??
Maybe that slot may be going bad, due to the NVME issues you mentioned, and then GFX showing up as X1 there too during this test. Never mind, see below!

This explains the x1 at X4 slot issue, from your spec page >>
1 x PCI Express x16 slot, running at x16 (PCIEX16)
* For optimum performance, if only one PCI Express graphics card is to be installed, be sure to install it in the PCIEX16 slot.
1 x PCI Express x16 slot, running at x4 (PCIEX4)
* The PCIEX4 slot shares bandwidth with the PCIEX1_2 and PCIEX1_3 slots. When the PCIEX1_2 slot or the PCIEX1_3 slot is populated, the PCIEX4 slot will operate at up to x1 mode.

x1 NVME speeds would be TERRIBLE, and likely would also cause all these issues due to not having enough bandwidth to run properly
So you just need to purchase a USB or PCI WIFI adapter instead, so you’re not using that x1 slot -

@AdamRatai - Sleep issues can be any number of things, BIOS or drivers, or programs etc. Best to test on a clean install, no drivers or anything, to rule out drivers/programs.
Then if issue remains all you can do is try newer or older BIOS, and or report this issue to your motherboard manufacturer and hope they look into it and fix

So the problem that I debugged with someone on reddit is linked here.

The issue is that my Wifi pcie adapter is plugged in the PCIEX1_1 slot, which according to the block diagram and mobo manual and website, shouldn’t cause the PCIEX4 to run lower bandwidth (but it probably does).

I have not tried the Wifi pcie adapter in the PCIEX1_2 slot (maybe the spec online is wrong?) with the NVME Adapter in the PCIEX4 slot.

I should see if the NVME shows up at PCIEX1 when it works in the X4 slot, what tools could I use to check that? I only know how to check the GPU because of the GPU-Z program.

Yes, maybe the spec or manual is wrong, it wouldn’t be the first time such has happened
Or, it may still just be the adapter? I use these $5 adapters, on several boards without any issues -
Maybe just get a USB WIFI adapter and then you don’t have to fight this issue. NVME works properly with PCIE x1 WIFI adapter removed, correct?

You can see NVME lane width in slot by using CrystalDiskInfo -
Info will be as shown here once you select the NVME disk


* Edit - Ahh! I see in reddit thread you are using the UEFI BIOS, and don’t even have Ivy CPU! Even with IVY CPU all those BIOS are very buggy, so this may just be one of the bugs!!
Go back to old Award BIOS and then I bet all will be proper!! Never mind, sorry, I forgot this is not possible to then use NVME, unless you want to use one of the USB bootloader methods

YOu can try UA7 BIOS and see if it’s any better, yes I know it’s older, but worth trying in case there is bug in UA9 -
Otherwise, your best option is to get USB WIFI card (May not help, if x1 issue is due to UEFI BIOS Bugs), or go back to award BIOS and use USB Bootloader method for NVME booting.

Oh wow. Thank you so much dude. Do I just flash the UA7 BIOS over the UA9 as if I was updating the BIOS like normal? Will my disks need to be IDE mode or can they stay in AHCI mode? Thank you so much again

What’s the difference between the BIOS you linked and the earlier BIOS versions on the gigabyte website (FD, etc).

EDIT: Oh I see on this thread some people flashing this BIOS with the Gigabyte @BIOS utility.

Not sure if I want to boot NVME so maybe just flashing this old BIOS will solve my issue. Either way, I do have an empty USB port on the back of my computer if I want to boot off the NVME.

I’m using latest award Bios for this Motherboard (next one is a UEFI Beta you are using, I suppose) And have this “sleepy PCI”, so give an info about v7 and this issue, please. Still trying to use USB method, but my lack of focus bite me in the ass.
Edit: O course I have similar, not “this” motherboard, so scratch it.

Tried to downgrade to UA7 with the @BIOS gigabyte tool and ran into a boot loop (I’ve never used this tool so unsure if it was a bootloop or not), either way I got worried and restored to the UA9 bios using the dualbios feature of my motherboard

Might have to flash with a dos usb (give rev 1.0 had to, maybe rev 2.0 has to):

from here.

EDIT: Flashing the UA7 update via Q-Flash also resulted in a bootloop (could not enter BIOS settings on boot) so I had to restore to UA9 via dualbios.

Can I still use my NVME drive as a storage drive with an old Award BIOS?

EDIT: Downgraded to FD version of Award BIOS. Going to shutdown, install the NVME adapter and NVME, reboot, and find out if the drive is recognized and then post the crystal disk info

EDIT2: Windows 10 will detect the NVME drive through the adapter a second or two after booting and logging in. The disk is running in PCIEX4 mode.

Unsure if upgrading to UA7 would be worth it (seems like the AMI/Non-Award BIOS booted faster than the Award BIOS)

@icecreamman UA7 is just an earlier version of UA9, it may have more or other BIOS bugs, so may not be ideal to use, I only linked so you could test just in case maybe it worked better for you.
The way those UEFI Beta BIOS are made for Ivy, that PCIE Slot may be linked to CPU instead of SB, since IVY changes PCIE to 3.0 and generally changes how one of the non-main PCIE Slots function on other boards
So it may all be the direct cause of these things you noticed and there may be no way to fix or change them unless you go back to old non-UEFI BIOS and use USB Bootloader method for your NVME booting.

Flash it via Qflash - DO NOT USE @BIOS! If you do not want to boot NVME, then you can safely go back to the non-UEFI BIOS at any time, but you need to use special EFI2AWARD tool and method, let me know if you need that info/tool linked.
Ahh, Qflash failed too, then all you can try is the FlashEFI and then if boot loop too this is bad BIOS

NVME is being wasted if used as storage, use HDD for storage, and for the NVME boot off it or remove from this system and save for later use in another system
This also especially a waste of NVME to use as storage AND on PCIE 2.0, save the drives lifespan for another system, remove that and put away until you upgrade motherboard and CPU

Nice to see you have x4 speed at least now with the older BIOS!! Did you check that with the UA9 BIOS before you downgraded?

@Lost_N_BIOS :
Checked speed after downgrading to FD Award BIOS.

I already have an SSD boot drive in SATA 3 running at 6gb/s. That is slower by 3x compared to the NVME.
The Samsung 970 EVO’s Mean Time Between Failures is 1.5 million hours on PCIE 3.0 according to this database.

I may make the NVME my boot drive later this month, but I need a break from messing with it while I setup Wi-Fi 6 in the home and get my raspberry pi up and running. It’s been four or five days of non-stop debugging this problem hahahaha
I guess I will use Clover usb to boot into the nvme

@icecreamman - Seems like I previously found and fixed this issue for @gloobox and I looks like it affects many boards / BIOS -
NVMe module integration to Gigabyte Z68P-DS3 legacy award bios help need. (5)

I also advise against running SSD to boot from on SATA 6/GB/s on these boards, the 6Gb/s controller isn’t up to it and can’t handle 6Gb/s very well, especially at high speeds (It’s actually 5Gb/controller)
But yes, 970 will be faster still, and it will last, but only so long. I still say better to save it for a more modern system, upgrade as soon as you can Even Z77-Z97 boards/CPU will be much better, and those are all much cheaper now used.

Actually I tried it on many mobos,and found the problem as @icecreamman.Such as P67A-UD3R(B3)/P67A-UD3P(B3)/P67A-D3-B3/P67A-UD3-B3
So I think it must have something to do with the ME setting,but I have no idea so far.