Trying to boot a Xeon E3 1270v5 on Asrock z170a-x1/3.1 (Help)

So I’m trying to boot Xeon E3 V5 on Asrock z170-x1/3.1, but so far no luck. I tried Me_Cleaner pc boots with Celeron G3900, on BIOS ME version is showing, with Xeon it does not boot, it turn on and off very quick and stays off. I tried the MeAltDisable bit set and Me_Cleaner whit MeAltDisable bit set, both didn’t work. PC turn on and off and keep doing that on and off. Can someone help me?

ME version sounds messed up. I would start by being sure of two things, and use your other known working CPU until you get the ME updated to the one you want to use.
Since you are having issues, I would not rely on shortcut tools like ME-Cleaner to do this, do it manually

1. Are you sure you can flash the ME region? - [Guide] Unlock Intel Flash Descriptor Read/Write Access Permissions for SPI Servicing
2. Have you tried cleaning the ME yourself manually according to the guide - [Guide] Clean Dumped Intel Engine (CS)ME/(CS)TXE Regions with Data Initialization

Once that is done, I would leave the older CPU in until I was sure the new GOP module, and modified vBIOS was working with the older CPU.
Then once all that is OK and working correctly, meaning booting OK and ME showing properly in BIOS and in MEinfoWin, update the CPU microcodes and boot still with old CPU, then if all good put in new CPU

OK! I don’t have to much knowledge about ME etc… I was just follow what some people said, like disable ME would make the Xeons E3 V5 work on intel 100 series chipset. I’m flash back to the original BIOS v2.20 and start from that.

1. No, not sure, how can i check that?
2. No, i didn’t.


@Lost_N_BIOS I follow the guide for Clean Dumped Intel Engine. I did with a downloaded BIOS from Asrock website. Apparently it work, flashed via Instat flash, but i don’t know if really clean it. Me region file that i replaced was a little bit bigger than the original, like the original was 1,7ish mb and the Me region from Repository paste was like 1,9ish mb. Is that right? System is working fine with Celeron G3900, din’t test with Xeon E3 1270v5 yet. Do you know what blocks the Xeons E3 V5 from booting on 100 series chipset?

For #1, read that link, it will tell you all about locked regions and how to check (Section D). You can check many ways, easiest way is the way mentioned using those FPT commands (Specifically dumping entire BIOS via fpt -d spi.bin or dumping on the FD region via fpt -desc -d desc.bin)
Use a FPT version, from a matching “System Tools” package here, that matches the ME Firmware you think is currently flashed into the BIOS (ie if you think 10.x.x.x is flashed use system tools 10, if you think 11.xx.x.x.x is flashed use system tools 11 package to get right FPT versions)

Follow the guides, ME files to use are there in “Repositories” you download those and a “dump or backup” from your PC. Then clean and create matching new one with your downloaded BIOS or ME region extracted from that downloaded BIOS.

To clean the file, the #2 link shows you method, it is involved and you must do each step one by one, be sure you read fully before proceeding on any step.
Sometimes little bigger is expected, did you transfer settings from the downloaded clean BIOS to the new ME?

How did you reflash the new BIOS (What command), and did you issue command fptw -greset once you reflashed?
If not, you must remove all power from the board for 1 minute or so, you always have to do that command, or below method to reset ME state if you’re changing ME
This means after flash unplug from the wall, remove CMOS battery and press and hold the power on button for a little bit, this will drain all power from the board and reset the ME

No, I don’t know what the block is for CPU’s. I was only trying to help you get properly working ME, that’s key first before anything else, ME showing as is not right.
Disable ME may be all you need to do, where did you read that and can you post a few links so I can look into it for you. You never read a certain version of ME has to be used, only to “Disable” ME?
Where these people discuss that, they don’t say how to disable ME? Cleaning ME is not disabling ME, that would be something entirely different (I assume, since clean and disable are totally different in all languages)

Once I can read more info about this I can help you get it done probably, as long as there is proper proven info or examples out there.
And not only testimonials by someone saying “I did it, disable ME” “Clean ME works for me” (Since those are different things, and not helpful to anyone trying to make same changes on their system)

OK! FPT command ‘‘fpt -d spi.bin" give me error 310:’‘fparts.txt’’ file not found FPT operation failed. I did follow the guide from D2 part. I use a downloaded bios from Asrock website not dumped spi image from my system, don’t know if that could be a problem. What ‘‘transfer settings"? You mean that "config.xml’’ saved on step 8? I rename the ''outimage.bin to Z17AX312.20 put on usb flash it via Instant flash on BIOS, them on Windows i use command fptw -greset and PC restarted. I tried this, them a saw someone saying here the ME was blocking the Xeons E3V5 and that disable using Me_cleaner would allowed to boot the Xeons E3V5.

@Lost_N_BIOS I think my FD is locked, i run fpt -d spi.bin on dos usb boot drive and give me error cpu host could not access descriptor something like that.

OK, on the fparts.txt file error, is that fiel in the folder you are running FPT from? If not, it should be, redownload the system tools package if you’ve somehow lost the file. I could also be your BIOS chip is missing from the list in that file, not sure if that is same error or not?
Just in case it is due to that, can you please get a magnifying glass and flashlight and read the label of your BIOS chip and post it all here, so we can make modified fparts.txt for you if necessary.
Which version package are you using, in case I need to upload the file for you, it you don’t find in the folder your using FPT out of, look in other lie DOS or Win/Win64 etc.

It’s OK to use downloaded BIOS if you want, but better since it’s for you and not someone else, to use a dump if you can since it has all your board info in it. It’s not always possible though, so it’s OK. I mean transfer, as if you are using the downloaded BIOS / ME as source to transfer those settings to a new clean ME from the repository

Thanks for the links, I will read through that tonight. FD may be locked, that’s why we need to get FPT working to confirm what exactly is locked FD or ME too, via those three output commands I gave above. It looks like one gives proper instruction to unlock via FIT program, so I will look into that tonight for you.
Flashing ME is necessary for that to work though, so you need at least unlocked ME region, this is why we need full dump or FD dump to see if ME locked. Or you check SPI info via FPT once we fix fparts issue, w/ this command and post image here, this will show if ME locked >> fptw -I

What all 2-3 pin jumpers do you see on your motherboard, and what are the labels around them? And, do you see anything anywhere in your BIOS about unlock ME, allow flash ME etc?
Sometimes jumper will allow you to flash ME, or sometimes BIOS setting will allow via single reboot. If no to all of this, you will need to order a CH341A USB Flash programmer so you can flash the BIOS off board, they’re cheap usually only $2.50-$4 - Choose “Blue” model, and if $$ is no issue, get black one below too, it’s cheaper than ordering same one from this seller. Or get both from same seller, add blue to cart, go back and add black from same seller, then checkout.

I suggest both types, because often people have issue with one or the other in various situations, and they’re so cheap everyone might as well get both.

Yes, that file fparts.txt. Winbond 25q128fviq. I use ftpw64 from Intel CSME System Tools v11 r12. There is only the Clear_CMOS 2-3 pin jumpers. No, no options about unlock ME or flash ME. Already have CH341A USB Black PCB.

Edit: I ran fpt dos version on an usb boot drive with command fpt -d spi.bin and -fpt -me -d me.bin it give me this error: ‘‘Error 318: The host CPU does not have read access to the target flash area. To enable read access for this operation you must modify the descriptor settings to give host access to this region.’’ With command fpt -desc -d desc.bin it successfully dumped desc.bin. So that means that my FD is locked right?

Is there any 2 pin jumpers, with or without labels? Never mind that, and don’t worry about your errors!! See below!

Great, you already have flash programmer, sorry if I missed you mentioned that before!! This means you don’t have to worry about if the FD or ME is locked!
You can unlock it right now by reflashing stock BIOS with unlocked FD using your programmer! Use your programmer, make a backup of your currently in use working BIOS, verify it matches with your programmer, then send here.
I will edit FD to be all unlocked for you, then you can use UEFITool every time you mod or flash a BIOS, and replace the FD region before flashing or programming, then it will always remain unlocked.
Always be careful when removing BIOS rom from board and programmer, pins bend easy. And always make sure notch in BIOS lines up with notch in programmer and board when inserting.

Once you do that, and always remember to put in the unlocked FD it will always be unlocked, and you can flash FD or ME anytime you want, or backup full BIOS without having to use your programmer via AFU or FPT
That’s is why you could not use any of the ME versions you already modified, the BIOS is not flashing the ME region. Your mods may be working, but since ME never gets flashed over to your modified version you can’t tell and think new CPU is still not working.
Once I send you BIOS back, you can try your ME mods again, just always be sure you put back unlocked FD. I will show you in images how to check this before you flash, and I’ll send the FD region only too separately so you can use later on any BIOS mods for this board you do later.

Attached is fparts.txt, in case you need for future use, but you will have to wait to use this until you get your FD unlocked The chip ID is in the original fparts.txt, right near top 4-5 lines down, but space is missing between chip name and ID space, so probably give error.
I edited it back to how it should be, look at your original and you will see what I mean. If this does not fix it, let me know and I will add in full chip name on following line.

I found this, about disable ME w/ that reserved bit, if that is the only reserved bit there is… Scary who initially asked for this!…tesy-of-the-nsa

I checked the links you gave, and I would do the mod manually since it’s only that one change to ME. Export ME via UEFITool, or import entire BIOS to FIT, then change that one ME setting and export build outimage like you already mentioned.
I bet you did it correctly, just wasn’t able to write to ME due to FD locked and you didn’t know it. Time to break out your flash programmer once you have edited FD unlocked!
BUT, @htpcfans say has to be ME 11.0.xx and you have 11.6 in latest stock BIOS, mentioned starting at post 8 here - Use the E3 V5 series CPU method on the H110 B150 Z170 motherboard.

fparts.txt (12 KB)

@Lost_N_BIOS When i click on the file you attached it gave some error:

Grafik nicht gefunden

/last0/b602300/f16t3770p53954n2_gExXemwo.txt Backend fetch failed
Guru Meditation:

XID: 687698435

Varnish cache server

I on bios version 2.20 which has ME, so i think is OK. Can you guide me on How to unlock the FD? Can i do it on FIT?

BIOS I checked was 2.20, it has ME 11.6 - this BIOS -…1(7.20)
Ohh, maybe that is 7.20 like it says? Sorry about that! I assumed .20 was same, guess not

Here is new upload of fparts to file host, not sure what that error is, something to do with upload to this site I guess?

How to unlock FD (And ME!) is here, you will need to program the modified BIOS with these unlocked, with your Flash programmer, you cannot flash with the BIOS or DOS/Wndow flashers
Read “B” Section, spoiler 2 - You can either find this area via entire BIOS edit with hex, or extract FD with UEFITool and edit, then insert back with UEFITool, then program with CH341A
[Guide] Unlock Intel Flash Descriptor Read/Write Access Permissions for SPI Servicing

Thanks! Will check that.

@Lost_N_BIOS Your fparts didn’t work, same error. I edited the area off CPU/BIOS and ME on HxD Editor to FF FF FF. Flash with programmer and now FD is unlock. Check it with DOS version of FPT, it dumped spi.bin, me.bin and desc.bin. So now i guess i’ll try mod the ME change the setting Reserved to Yes.

@Lost_N_BIOS No luck with the mod. PC turn on and them off… turn on and off keep doing that.

Here, try new fparts again, I added specifically your chip ID

With your mod BIOS flashed, and it fails with new CPU. Put back in old CPU while that BIOS still there, and run dump the BIOS again.
Then check that dump with UEFITool, extract the ME region, and then open in FIT and see if that bit is set to yes, then you know your ME is flashed into the board.
Before you open to check ME from dump in FIT, make sure you delete all old files and logs settings etc from the FIT folder (only remaingint FIT.exe, newfiletmpl.xml, and vsccommn.bin) before you open the new ME Dump in FIT again to check setting is same as you set.

I didn’t use the Xeon, it was with the Celeron. PC turn on and them off… on and off.

So i flash back to the bios that was working with FD unlocked. Still give me same error with the new fparts, don’t know what is happening, DOS version works fine.

This is my current Meinfo:

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.


Intel(R) MEInfo Version:
Copyright(C) 2005 - 2017, Intel Corporation. All rights reserved.

Intel(R) ME code versions:

BIOS Version P2.20
MEBx Version
GbE Version 0.8
Vendor ID 8086
PCH Version 31
FW Version H
Security Version (SVN) 1
LMS Version Not Available
MEI Driver Version
Wireless Hardware Version Not Available
Wireless Driver Version Not Available

FW Capabilities 0x31101940

Intel(R) Capability Licensing Service - PRESENT/ENABLED
Protect Audio Video Path - PRESENT/ENABLED
Intel(R) Dynamic Application Loader - PRESENT/ENABLED
Intel(R) Platform Trust Technology - PRESENT/DISABLED

Re-key needed False
Platform is re-key capable True
TLS Disabled
Last ME reset reason Firmware reset
Local FWUpdate Enabled
BIOS Config Lock Enabled
GbE Config Lock Enabled
Host Read Access to ME Enabled
Host Write Access to ME Enabled
Host Read Access to EC Enabled
Host Write Access to EC Enabled
SPI Flash ID 1 EF4018
SPI Flash ID 2 Unknown
BIOS boot State Post Boot
OEM ID 00000000-0000-0000-0000-00000000000
Capability Licensing Service Enabled
OEM Tag 0x00000000
Slot 1 Board Manufacturer 0x00000000
Slot 2 System Assembler 0x00000000
Slot 3 Reserved 0x00000000
M3 Autotest Disabled
C-link Status Disabled
Independent Firmware Recovery Disabled
EPID Group ID 0xF9F
LSPCON Ports None
5K Ports None
OEM Public Key Hash FPF 00000000000000000000000000000000000
OEM Public Key Hash ME 00000000000000000000000000000000000
GuC Encryption Key FPF 00000000000000000000000000000000000
GuC Encryption Key ME 00000000000000000000000000000000000

— –
Force Boot Guard ACM Disabled Disabled
Protect BIOS Environment Disabled Disabled
CPU Debugging Enabled Enabled
BSP Initialization Enabled Enabled
Measured Boot Disabled Disabled
Verified Boot Disabled Disabled
Key Manifest ID 0x0 0x0
Enforcement Policy 0x0 0x0
PTT Enabled Enabled
PTT Lockout Override Counter 0x0
EK Revoke State Not Revoked
PTT RTC Clear Detection FPF Not set

Could be something that is prevent the ME to get disable and them restart the PC?

Maybe try meinfowin, not x64 version, in windows.

If PC doesn’t start with ME mod BIOS, with Celeron, then there is an issue with the ME and or ME+BIOS mod method.

Post here, link to the working BIOS you have now, and tell me the ME version you want included and I will do the mod and you can test that to see if same outcome or not.
Is that shown above, the ME version you want to modify H? If yes, OK, send BIOS you are using without ME mod and I will modify the ME and insert it.
Then you program to your BIOS with programmer, no flashing BIOS only programmer for now so you can be 100% sure everything you want is flashed onto the chip.

So mu current working BIOS is version 2.20 with FD unlocked, just like Meinfo shows above. Meinfowin show the same result as the 64 version. Here my current working spi.bin .