Trying to change the power throttling limit on Acer Spin Pentium N5000

My Acer Sp111-33 has a passively cooled Pentium Silver N5000 which sinks its heat into a copper plate, maintaining temps in the 40s-50s most times, with burst temps in the 70s and sustained load temps in the 60s. The problem is the CPU can hit almost 15w in very short bursts, but the higher over 7w it goes, the sooner it gets clamped down by the throttle to 7w and no more. I want to increase this 7w throttle point. My testing has shown heat doesn’t play a role, but rather it’s some calculation based on watt-hours over 7w, with a 9w load lasting longer than a 12w load, and an ice pack having no effect on time. Other models of laptops (usually off-brand in origin) containing the N5000 are reportedly able to take a command in RW Everything, for example:
“WRMSR 0x610 0x0 0x00DD8A00” 10W TDP
but my Acer shows no signs of change from this. ThrottleStop cannot increase turbo time nor affect the voltage either, but is capable of reducing the CPU multiplier limit, which has the effect of increasing the GPU power budget, limiting wattage, preventing throttling and improving non-CPU limited gaming performance. This comes at the cost of much of the CPU’s already limited performance…

Please link to the BIOS you are using, from the Acer website (not something you upload)

I use this BIOS:…BC=ACER&SC=PA_6

Downloaded from this source:…pn=NX.H0UAA.007
@Lost_N_BIOS is this a BIOS issue, rather than a CPU microcode one? I’m new to this sort of modding…

I don’t know what is doing what you mention, maybe you can find answer about it on the throttlestop forum thread (google this, I’m not sure, but I know Unclewebb will be able to answer your questions about this kind of thing)
What I can do, possibly, is make you mod BIOS to where you can access all the settings to change yourself directly. Please zip for me images of all your main BIOS pages, and then inside any submenus at Advanced or chipset which are related to CPU/Power etc.
Or, may be easier to just help you change that setting directly in the BIOS without a BIOS mod. But, I checked your BIOS, and hidden settings etc, there is no wattage limit setting, only temp/fan Thermal DPTF controls and various C-State options that may be causing what your experiencing (shown below)


@Lost_N_BIOS I don’t see any advanced BIOS options to change, not sure if they’re all hidden in a menu it takes a special key command to access, nothing I tried worked. Zipped screenshots attached. I posted on the ThrottleStop forum, it seems my account was being slow in getting approved, so it temporarily prevented me from posting without telling me why.

@JasonD - Yes, maybe all hidden. You can’t see “Advanced” section at all? Show me one image from each main page of your BIOS (nothing attached(

I’m not sure where the file went the first time, let’s see if it works now. Hardly any settings to change that could be described as Advanced. (3.38 MB)

Thanks, yes, advanced (both/either) and power is missing entirely . Please wait, i will see if I can find enable edit location, Insyde BIOS is not my strong suit, but sometimes I can find
Funny, I see at Main >> Sata Mod, but then only one option, pointless to offer to user in this state They hide POST Animation & Sound from you too on Main, so lame to not allow user to enable or disable this kind of thing!
Sorry, it’s too messy in there, I can’t find exact spot to enable the missing menus You’ll have to ask for this at forum.

I can however, make settings visible that are hidden from you in current menus, you may have to show me a failed BIOS flash so I can know the error to bypass to allow stock flasher to flash mod BIOS, this not always possible either.
Maybe best to ask about unlock BIOS at BIOS-mods forum first, they’ll know and tell you right away if this is possible or not, if not they’ll say you need flasher and SOIC8 clip.
We can jump right at it though if you want, I will edit one setting and send you mod BIOS package, then you show me the error you get on screen and let me know if that happens before or after BIOS reboot during the flash process (it before, best chance you may not need programmer)

I’m not even sure if SATA is a bus that’s in use on this machine, considering the eMMC storage it uses, and if it is they wasted the implementation since the SD slot is incredibly slow. Is the machine still going to be usable after the failed flash attempt, or is it going to require some down-time during which we find the necessary mods for the custom BIOS to work?

And would the “flasher and SOICB clip” mean opening the laptop up, finding the BIOS chip, and attaching a device directly to it to force a flash? I did that with a friend on his PS3 a while back…

That may be why AHCI is only option there, if there is no SATA lanes used, that should have been hidden from user them and the eMMC options shown instead (didnt look to see in this BIOS, but usually there is 3-5 options for this)
For the edits I’m talking about, it wont be a failed flash as in bricked BIOS, it would be failed flash as in “it wont flash it” so no changes made. Once I see error given, I can edit flasher to go around, sometimes, if not then no way possible to flash mod BIOS except with flash programmer.

Yes, flash programmer and SOIC8 means open the system and find BIOS etc.

Okay, let’s go with the custom BIOS, I’m happy to test out software on my machine! Will it have the Insyde flasher included, or will I need something separate/custom?

Yes, it would come with the stock BIOS contents, all the insyde flash stuff. That is what I will then edit (ichflash.dll usually) to go around the error you get.
Lets make one setting visible for this test flash test, this is a one byte edit (46 to 47 ) >> POST Animation & Sound…760320639074250

Show me image of error on screen, or give me the exact text (must be exact). Also, let me know if error happens before reboot, or after reboot
Run this, as Admin >> H2OFFT-Wx64.exe


Probably not the kind of error we would be hoping for?
(This error stops the process before it even tries to flash the BIOS)

Yes, any error is valid and I need to see, but yes, didn’t expect that one and should have made this edit initially Please replace “platform.ini” with the one from this package and try again, show me next error…072061262124950

New error: “Load file: File may not have EC rom!”

PS I got a response from Unclewebb:
“Without any proper documentation or new hardware to play with, ThrottleStop will not fully support new CPUs like your N5000. It will be the end of the TS era. Sad times.”

Did you reply, “not fully support” I get, but can you help with any info on what it does support now, can/can’t do etc?
Next -…662544960099240


I asked the Throttlestop forum about N5000 functionality, described how only lowering the multiplier seemed to have any effect, and provided screenshots. I might have to buy Unclewebb an Acer Spin 1 if I want further progress there :stuck_out_tongue:

Does this system have ME FW? Check with HWINFO64 if you are not sure, in the large window on left side, expand motherboard and do you then see ME section inside there? Also, please link me to your boards driver download page, so I can see if ME driver offered.
We may have easier way to do the BIOS if you do have ME FW.

Back to previous ini edit for a second. Please replace INI now, and the included .fd file and try again…396168371434875

As I said always, Insyde is a pain, especially for me.
You may need to get a flash programmer and SOIC8 test clip with cable, would all be much easier that way.

Yes there’s a ME entry, and here’s my driver page:…pn=NX.H0UAA.007


New error (still occurring before flash attempt) and more ME pics attached.

@Lost_N_BIOS I don’t see any Management Engine entries in the support website, at least not for my exact model…