Trying to change the power throttling limit on Acer Spin Pentium N5000

@JasonD - Sorry, always behind! As I mentioned all along, I hate Insyde BIOS, and you may have to get flash programmer, it would be halfway here by now if you ordered when you started this thread Did you order yet?

You have SPS ME FW 4.0, as shown in your second image at post #20. Please download this package and follow along, maybe we can get lucky this way instead!?!?…805146258443861

Once unpacked, inside you will find Flash Programming Tool folder, and inside that a Win64 folder. Select that Win64 folder, hold shift and press right click, choose open command window here (Not power shell).
At the command prompt type the following command and send me the created file to modify >> spsFPTW64.exe -bios -d biosreg.bin

Right after you do that, try to write back the BIOS Region dump and see if you get any error, if you do show me image of the command entered and the error given >> spsFPTW64.exe -bios -f biosreg.bin
^^ This is important step, don’t forget ^^

If you are stuck on Win10 and cannot easily get command prompt, and method I mentioned above does not work for you, here is some links that should help
Or, copy all contents from the Flash Programming Tool \ DOS folder to the root of a USB Bootable disk and do the dump from DOS (FPT.exe -bios -d biosreg.bin)…creators-update…menu-windows-10…ator-privileges

Or here is simply registry edit that adds “Open command window here as Administrator” to the right click menu
Double-click to install, reboot after install may be required…134606820377175

@lost_n_bios can you link me the programmer? I’ll look into ordering one then

Here is examples on ebay, but you can get anywhere they sell lots of computer stuff usually, like Newegg or Amazon. Also, these are cheaper shipped examples, you can pay more and get quicker on ebay and or all other places << On these, make sure it says it comes with cable, some people selling show cable but are only selling the clip

Can you see the BIOS chip in this picture? I’m unsure if BIOS chips come in different sizes I might need a specific clip for…


You need the clip I mentioned, it’s standard size for modern things. You may need to flip that over and let me see other side too. On the side you showed, move everything out of the way here and let me see these two chips better.
Also, if you can read them, what is printed on each? Probably one on right is BIOS, but could be other data stored there too, or controller and BIOS is maybe on other side of board


One’s a Winbond flash memory chip (probably BIOS) and the other is a Nikos mosfet (i wonder how concerned I should be that the mosfet is heat dissipating into the battery cables?). On the back of the board is nothing of consequence, aside from a cheap USB 2.0-based Realtek SD card controller, which I hate for how slow it is… I may lose it if I learn it’s mounted in a USB 3 bus





I would tape off the cables, or move them, you are right that doesn’t sound ideal. Yes Winbond probably the BIOS, checking images in a bit once they all load.
Yes, that is the BIOS W25Q64FW << This is a 1.8V chip, so you also need one of these 1.8v adapters -

Damn, that is a naked backside!

So, good thing you checked first, so you know in advance you need the 1.8V adapter.
Some sellers sell kits, CH341A + SOIC8 clip w/ cable + 1.8V adapter, or you can get them all at the cheapest price by themselves shipped slot and arrive in 3-5 weeks (that’s how I order this kind of stuff)

I just bought this, will arrive in 2 days:

I just followed post #21 instructions, attached the result of what happened. Looks like I’m unlucky! Good thing I’m determined…


@JasonD - What system are you running, looks like Win10, but is it 32bit?
Ahh, sorry! Maybe I sent you wrong one, I saw v4 in your image and assumed SPS, maybe you have TXE one, try FPT from this thread’s V4 system tools - Intel Trusted Execution Engine: Drivers, Firmware & System Tools

Windows 10 64-bit. I’ll report back on results tonight.

Uhh that’s a very long and complicated post, what am I doing with it exactly? Also the flashing tool arrived!

@Lost_N_BIOS I found an interesting post on another forum where the Throttlestop forum is. A user named Dufus seems to know of a way to trick the CPU into thinking it hasn’t reached its power limit:…haswell.766743/

“There are a least 2 other ways to program power limits other than through MSR’s, those being memory mapped addresses and PECI and it does not matter if the MSR is locked, seems lowest setting wins. For instance PL1 and PL2 can also be programmed via MCHBAR+0x59A0 and MCHBAR+0x59A4 while PP0 and PP1 can be found at MCHBAR+0x59A8 and MCHBAR+0x59AC. The PECI ones though are generally controlled by the Embedded Controller (EC). If you are lucky the manufacturer might provide access to the relevant registers. If not, then an EC firmware mod would be required.”

Too bad all the pics are gone…

Sorry for any confusion, I meant for you to download the V4 system tools from that thread, then try FPT again using the FPT in Flash Programming Tools folder like I mentioned before. You will need to use different exe name in the command, since it wont be spsFPT in that package.
About the stuff you mentioned, you may have have access directly to the PL1/PL2 settings in BIOS once we can unlock it, but not sure if they are in this BIOS. That may not even apply to your CPU, maybe only certain CPU family’s have controls/BIOS access to stuff like that.
I looked through the IFR of all your settings, no PL0/PL1 or PP0/PP1, or power settings etc, only what I showed you on page one. There is power/thermal settings in other areas, but nothing like we’re discussing here.

If yours is EC FW controlled, I can’t help with that, there’s no tools that I’m aware of that edit EC FW, only direct assembly edit would be possible and I’m not familiar enough with assembly to do anything like that since it’s not a usual edit I do in assembly.

Poking around, I see, even with programmer editing BIOS may be an issue. I know a few threads about re-signing RSA Signed BIOS, but I’ve never done it. Sometimes this doesn’t matter once you have programmer, we’ll have to see


@Lost_N_BIOS I have the programmer, it’s here! What do I do with it?

Dump BIOS and send me a dump. What is yoru BIOS chip ID? here’s general software -…695330485827902

And here’s some guides, sadly the one with the most images all the images are down…341A-programmer << Same as one directly below, but with all images expanded/visible at once
[GUIDE] Flash BIOS with CH341A programmer
[Guide] Using CH341A-based programmer to flash SPI EEPROM
[GUIDE] The Beginners Guide to Using a CH341A SPI Programmer/Flasher (With Pictures!)…grammer-ch341a/…ini-programmer/

Before you connect to the chip, open software and on “Auto” function, uncheck erase/blank check, that way nothing gets erased accidentally.
Do not erase, or write to chip until I tell you the file you sent me is OK/good dump

Read, verify and then if chip and buffer match save and send me the file.

Okay @Lost_N_BIOS I found time to get the BIOS chip read, file attached! I hope zipping doesn’t mess it up somehow, the forum told me in German that the original was too large by 2MB… (can that be changed to English?) (3.9 MB)

@Lost_N_BIOS did you get a chance to look at the file? Also do you have recommendations of good guides for viewing/editing the BIOS file if I wanted to try out some mods myself?

@JasonD - I think we can’t change that German message, or they would have by now Zip is preferred, so no problems there!
Sorry, I don’t know any guides for manipulating this kind of BIOS (Insyde), I hate Insyde BIOS There is no related settings to what you wanted in this BIOS, aside from the ones I showed you image of previously (or mentioned)

First, lets see if BIOS edit in general bricks the BIOS or not (be ready to recover!) This has FD unlocked and BIOS Lock + FPRR Disabled - so if BIOS boots, we should then be able to use FPT to dump/flash etc after that
Please make a note here, what software version and chip ID you use for the above dumped BIOS, and what is your actual chip ID, in case we need to reference this later.
This package contains two BIOS, program FD.bin one first and see if it lets you boot to BIOS. If it does, great, we can edit FD without breaking anything.
Then next program in FDSet.bin, if that fails to let you boot or enter BIOS, then RSA Signed BIOS and I will have to see if I can work around for you.…487773091899844

Also, after checking BIOS, BIOS Lock and FPRR are already disabled at least in NVRAM anyway, however both are enabled at setup modules, but I’m not sure which your BIOS uses.
So if you would have continued with the correct FPT we may have been able to flash that way, or unlock and then flash that way, but you never tried again once I linked you to the correct version.
But, it’s good we wait for programmer to arrive in anyway case it’s RSA signed. If it is, I may know how to work around now, but it would be my first time doing that edit, so may take a few failures too

Love the avatar! Do yo own that one? I have a few, but none I really like yet, I always grab the cheap random sample sets.

Is this info that I get while reading the BIOS chip from another computer, or at another time?

Sorry, it confused me what you wanted me to do. I’ve now done it, and attached the screencap of what happened, I think this v4 needs a different command from the other package…

I don’t own that one, but I do own an Intel wafer from the '80s or '90s of some random unremarkable secondary chip, and another that was a test wafer from an unknown source. I was supposed to get a third but the seller “forgot” to ship it!


Software version and chip ID is something you get what using the programmer, you choose what software version you are using when you download and pick a folder to use the program from, and then either “Detect” or you picks the ID you use.
But, I guess that may depend on where you downloaded the software and what the actual software was. I generally pass out this link, have several versions of general CH341A software -…695330485827902
I assumed I’d linked you to this, and that’s why I asked which version you used so you could be sure to use same to write back (or if I needed to tell you use something else, other ID etc. What is your actual chip ID, written on the chip itself?

Did you test the BIOS I sent you at post #38 (via programmer)?

Yes, v4 FPT would have a different named exe file, but rest would be same. Looks like you tried to flash something that wasn’t there.
You first have to dump the BIOS region (Nameofexe.exe -bios -d biosreg.bin), then flash it back (Nameofexe.exe -bios -f biosreg.bin) Obviously, change the name of the exe there

Too bad you don’t own that wafer, looks nice! I’ve picked up a few sets of 3-4 at different times, some $8-12 for each set I think, few cool ones but nothing super fancy, I think they all hold onto those and or sell them for much higher $$