Trying to enable full AMT on Optiplex 7010 Micro (2023)

I have an Optiplex 7010 Micro (2023 version) with ME code 8 (ESSEN/ISM). It is vPro capable but I’m assuming full AMT is disabled in bios.
I can access MBEX and provision, but it is limited to ISM, so no KVM.

I couldn’t find any me servicing jumper pins. I also couldn’t find the Realtek HD audio chip on the motherboard.

I downloaded the FPT and MFIT tools from this post. I dumped the bios with fpt -d bios.bin -bios, opened it up in UEFITool, extracted the body of the Setup UI, opened it up with ifrextractor, and found the VarOffset (0x3) for “ME FW Image Re-Flash”. I booted up an EFI shell and set it to enabled: setup_var 0x3 0x01.
After rebooting, I tried dumping the full spi/bios fpt -d spi.bin but it still gives me the error

Error 185: FCERR is set. Hardware sequencing failed. Make sure that you have access to target flash area.

FPT Operation Failed.

I also just tried dumping and reflashing only the ME region fpt -d me.bin -me fpt -f me.bin -me but it seems like it’s still locked. I booted into the EFI shell again to see if the ME FW Re-Flash offset got reset or not, but it’s still set to 0x1.

Also, when I try to run the ME dump through MFIT, I get an error

ME Corporate H

Q670 chipset
Intel WGI219LM NIC

You can’t work just on a region with ME 16. So you need a full dump, if there’s no jumper then it’s a programmer…

1 Like