Unlock Chipset tab in ASUS N580V

I tried to unlock the tabs CHIPSET and 2nd ADVANCED menus following the @Lost_N_BIOS ’ guide in another thread, but without success.
I post the dump here, if any guru can give me a hand, I’m very appreciated.


@fv1862 - I don’t have any guide for this, it’s different for all boards and sometimes many methods are required, any information you saw I posted usually would only apply to that boards BIOS unless it was an “in general” type of info post.
Please link me to the stock download from Asus for the BIOS you want modified and I will look

Here is it

Did you first try editing setup IFR to unsuppress chipset and second advanced, change suppress if true to false (change 46 to 47 for chipset and advanced)?
That would be where to start first, then on top of that apply AMIBCP edit to user access for each menu at the root level above it (ie at “Setup”), then if no luck still, AMITSE edit.
And if you were talking about an AMITSE edit I posted somewhere else for this type of mod recently, it does not apply to your BIOS in the same manner.
AMITSE can be edited for this, but not the same way I’ve posted about previously for anyone, but this would only be done if the above two methods failed to give any results.

Since you said you tried to do some edits, I’ll leave you with that info for now, since I’m not sure what all you tried, what all you can/can’t do, and maybe the above will help you make some progress. If not, then let me know and I can start sending you test files.
Do you have a flash programmer (Like CH341A or other) and SOIC8 test clip cable? If not order now in case you need later!

1st of all, tahnks for your time @Lost_N_BIOS.
Change 46 to 47 in setup does not change anything, going on AMITSE there are many similarities with your guide for TONGFANG GK5CN6Z https://www.win-raid.com/t4232f16-Unlock-BIOS-menus-options-in-Overpowered-OP-LP-Aptio-V-BIOS-rebranded-TONGFANG-GK-CN-Z-6.html#msg69041
1st I replaced the 2 menus 16 27 and 17 27 (CHIPSET and 2nd ADVANCED) with 00 00 and 00 00


Then I replaced the 2 menus with 000000, but all this did not bring changes



if you have any ideas, I have test clip and sp-8 to test…

@fv1862 - You’re welcome, I like to learn and it’s great to see someone else trying to learn as well, so happy to help! It’s good you have programmer, make sure you’ve taken a backup and validated it in BIOS tools, then programmed back in to be sure your recovery process is working

After doing 46 to 47 for both chipset and Adv in setup, did you apply on top of that root menu access change to user in AMIBCP? And that being only BIOS changes, then test and see before doing anything deeper.

For your first edit at 000022bc, 1627 is visible main menu and 1727 is visible Advanced, so you have those ID’s incorrect. And from the ID’s there, that string your looks to be a “Visible” short menu list. Instead of 00 there, you want to change/swap to the other ID’s (ie swap advanced ID there + add chipset then remove two following FF bytes for the chipset add)
So you can see correct versions of these ID’s, always compare Setup IFR and AMIBCP, look in each menu duplicate (Advanced and other advanced) to see which matches your current visible BIOS and then make a short list in notepad while you edit of which ID is which menu so you don’t have to keep looking back and digging around on the IFR.
The ones you want are 1227 Adv and 1327 chipset.

Then at 000312b4 I believe is the hidden list, FF ID’s for 12 and 13, I would cut and then add the FF’s at end along with the trailing FF’s there.

This BIOS is a bit tricky compared to TONGFANG one, since this AMITSE has a main enabled short list instead of a short disabled list, and then two disabled list with long ID’s, one shorter in total than the other, I believe these are split up due to the controls also present in setup via suppress.
Shorter hard block list at 00056c74 only contains 1127 and 1b27, and other contains all the hidden ones at 000312b4 (And all have suppress constraints in setup IFR too)

And I believe the list you edited at 00056b14 is a list of enabled menus in general as well, add ones you want there too

So I think a large combo of edits is needed on this one, add to the visible short list in AMITSE, add long ID’s to the large block of enabled in addition to what’s there, FF from extended block list in AMITSE, unsuppress in setup IFR and then possibly/probably on top of all that set root access to user in AMIBCP.

If you can’t get it, and want me to stab it for you, I will do once you’re sure you can’t get it. I’m not an expert at editing in this area either, learning just like you on AMITSE editing

Thank you for your interest … in fact I think it’s very difficult and I’m starting to think about quitting…
in these 2 days I have tried a change several times but without success,
the thing that most saddens me is after every change does not change a single comma…
I have deleted all the menus at 000312b4, but the bios the 5 default menus always appear,
I added some menus to at 00056b14, always the bios the 5 default menus always appear (as if everything was written elsewhere).
If you can be useful to you, the only changes that change something are:
at 000022bc if you clear the 6 FF, in bios the menu does not appear,


2^ at 00056b14 if you delete the two 4A 10 59 7B 0D C0 58 41 87 FF F0 4D 63 96 A9 15 11 27 and 4A 10 59 7B 0D C0 58 41 87 FF F0 4D 63 96 A9 15 1B 27 in bios 2 main and 2 save and exit appear.


However if we want to continue ....

@fv1862 - You’ve lucky no changes, AND still bootable too, that’s a good thing! Mod BIOS incorrectly can easily brick a board, a single wrong byte sometimes can brick it, but at least you were smart and picked up a programmer first!

Menus at 000312b4 is list of hidden, so deleting those alone without other enabling/adding etc wont make anything appear, and you don’t want to delete it all. Adding means adding long ID at 00056b14 if not already present, and adding short ID at 000022bc

On your last image, that is list starting at 00056c74, the two you deleted there are in the short hard block list I mentioned, this is where you’d later add any long menu ID’s you want to hide.
Good to know the second main and save and exit do not need unsuppressed or User access in AMIBCP, unless you already had those changes done too before editing that list? Let me know if you already had those done when you tested that 00056c74 edit.

I’ll make test BIOS for you tonight.

@Lost_N_BIOS I believe your theory is right,
everything is given by these 3 points, 000022bc, 000312b4 and 00056b14 , but even today I made various changes without result…
sometimes it is also frustrating, changes and changes and always remain those 5 menus.

p.s. just for curious, the points 0000188c and 000561cc, do you think they can mean something?

OK, if you want make a few test, I’m available

@fv1862 - Yes, sometimes BIOS very tricky, and several methods needed on top of each other sometimes too. Can you please take images of your BIOS for me, one or each section visible and zip and upload for me, thanks
Then sit back and relax, will see if I can figure it out.

@Lost_N_BIOS These are the 5 section stock of bios


@fv1862 - Will work on this tonight. Lets test one menu item at a time for now, until we figure out enable method. Chipset of course
If this edit works, it involves 5 individual edits to enable one menu - 3 @ AMITSE (2x addition, 1 removal) + 1 @ Setup/IFR + 1 @ AMIBCP (Or AMITSE/SetupData)

*Edit @fv1862 - how are you flashing this in, with programmer, or via FPT or what? Here is mod BIOS region only, removed from capsule.
If you put this on with programmer or FPT you may loose system specific details during the test since this was built with stock BIOS, if it works, for final mod BIOS moving forward I need either BIOS region dump from you via FPT, or full dump via FPT or programmer, so your details will be kept (UUID, Serial, LAN MAC if not in GbE etc)
Sorry, I forgot you did post dump already in post 1! Is that an unedited stock BIOS dump? If yes, I will use that one moving forward, if it’s edited, please reflash stock BIOS using stock flash method, then dump BIOS region via FPT or dump entire BIOS via programmer and send me that instead.

This is not full unlocked BIOS, as mentioned I only edited one menu this round (+BIOS Lock disabled) to see if method works as suspected.

@Lost_N_BIOS With regret I confirm that nothing has changed!


@fv1862 - Hmmmmmmmmmmmmmmmm

You didn’t answer my questions, how are you flashing, or are you programming?
I was assuming maybe some AFU method, since none of your edits worked or failed either Often AFU will only appear to be updating, but flashes nothing, especially with mod BIOS.

Sorry !
Updating with FTP, the classic error 368 (even the only BIOS part) appears. I could unlock it with RU, but from the next time it is reblocked…
Trying the easiest method, with AFU, THE PC freeze, (tried with about 10 versions of afuwin) for which I flash with programmer sp8.

So how you say my mod didn’t work then, did you try it at all? If yes, as I asked, how did you flash it? If you are using programmer to test it, did you erase chip, then blank check, before you write and verify BIOS?
If not, please do that first, otherwise you never know if you get complete BIOS as input or it skips some data already there due to not being erased first

Yes, FPT will give you that error until you unlock BIOS lock via grub, here is guide
[GUIDE] Grub Fix Intel FPT Error 368 - BIOS Lock Asus/Other Mod BIOS Flash

So you can start at step #5 in the guide, Your variable is >> 0x8BE
Rename your .efi file to >> Shell.efi

Then at grub prompt >> Setup_var 0x8BE 0x0

Then it’s done, will remain until you reflash any stock BIOS that has the lock enabled (I disabled it in the file I sent you)
Then you can use >> FPTw.exe -bios -f filename.bin

certainly, to write a file, the operations are performed:

So you did that with the BIOS I sent? I didn’t send a complete BIOS, so that is not possible method to program with like that, otherwise it will be a brick, unless you put BIOS region into a complete BIOS file, then programmed it?

I saw it was just the BIOS part, and before loading it I added the DESC and ME part

@Lost_N_BIOS - I spent several hours today to edit in hex without result.
I started from the most logical thing,
replacing at 000022bc the menus and 1A;
to 000312b4 (menu to hidden) I put and 1B, and at 00056b14 (menu visible) I put and 1A.
The logic would say that this is the right way… but always appear the 5 usual menus !!!
Even, in a moment of frustration, I substituted all entries at 000022bc
11 27 12 27 13 27 14 27 15 27 1A 27 FF FF FF FF with FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
and again, appear the usual 5 menus !!!
Stuff not to believe !!!

Maybe the solution is somewhere else, do not you think ?