Unlocking Supermicro H11SSL-i Bios Menus- could need some help

I’m having a little bit of trouble unlocking the menus of my H11SSL-I Bios. You can open it in AMIBCP (v 5.0.2), if you edit some strings throughout the image. The only problem with this is, that the system won’t post anymore after altering the image to open it in amibcp. It doesn’t help to edit everything back after changes in amibcp have been made.

Changes explained here: Error: AMIBCP 5.02.0023 language name present exceeds 0x08 in lenght (3)

The Menu (AMD CBS) i’m trying to unlock is outside of the Setup in UEFITool, so i just switched the pe32 and dxe sections from AMD CBS into Setup and could boot into the CBS Bios. Some of the submenus were still missing and this isn’t really a practical solutions since i don’t have access to the normal setup like this. And i still want the submenus of AMD CBS unlocked and the missing stuff from the normal settings would also be neat.

I tried the IFR extractor after that but what i got from it was too much for me to understand. I attached the 2 IFR files from the Setup menu and the CBS menu and 2 pics of how it looks in AMIBCP. Can someone point me in the right direction? Seems to be quite different from the casual bios unlocks for notebooks etc.

cbs in boot.jpg


cbssetup-whole IFR.txt (169 KB)

setup_whole IFR.txt (313 KB)

AMIBCP may not be needed at all for what you want. Can you see CBS options at all in stock BIOS, and some stuff just hidden? If yes, then all you have to do is unsuppress via hex/IFR
And, any changes you wanted to make in AMIBCP can be made in setup IFR anyway, so AMIBCP not really needed. This is even more-so relevant because you said it breaks after you make AMIBCP compatible, and then make changes and try to put back to original non-AMIBCP compatible.

Link stock BIOS you are using, then I will extract what I need and show you how to unsuppress CBS Menu items.

The CBS menu is completly hidden in the normal setup menu. But i think it is accessible through the boot submenu, as the AMIBCP screenshot shows. So i think in the boot submenu the CBS option has to be unsurpressed and the suboptions from the cbs menu have to be unsurpressed.

I uploaded the dump from the chip here https://www.mediafire.com/file/8mpx6re8h…/smsp3.rom/file

If you’re searching for the Setup in Uefitool just search “04 39 00 00 00 39” the first find is the Setup and a few registers over it is the CBSsetupDXE. The Entries for the CBS menu are not in the normal Setup, thats what i swapped around to access the cbs setup.

Here’s some of what i can see in the CBS menu when i do the switcharound:

Also heres the bios that is modified to open it in AMIBCP, if that is somehow helpful to view the menus.

OK, thanks, I thought in your AMIBCP screenshot that was of edited BIOS you added CBS into Boot area. I will take another look, but please send me stock BIOS or BIOS dump of your system running stock BIOS, swapping around as you’ve mentioned is not needed to do what you want.
All that needs done is enable Advanced/Boot Feature submenu if it’s not enabled already, then CBS submenu, then unsuppress CBS Options in their own module via IFR/Hex. Can you see Advanced >> Boot Feature Page by default in stock BIOS? If yes, great, half the battle is done already.

I have done this many times, so am familiar with everything your talking about etc. And I’ve enabled these CBS/PBS menus many times too, where they were not normally visible

The first mediafire link before the edit is the original bios dump.

The Advanced -> Boot feature menu is accessible in the stock bios.

@barracudax - So, both of your AMIBCP images in first post are from stock BIOS? And to verify, this link is stock dump, correct >> https://www.mediafire.com/file/8mpx6re8h…/smsp3.rom/file
How did you dump the BIOS, with programmer, or some software?

By default CBS Setup is show as it’s own menu section in AMIBCP with stock BIOS, under and outside of Setup section, did you already try to enable at root of setup by setting user or supervisor where I showed arrow in second image below?
Please show me some images of your BIOS



Okay so a newer version of AMIBCP works fine with this Bios. I can now unlock menus and post afterwards.

The only problem is, that the AMD CBS option in the Boot Feature menu is not a selectable menu. It is only a line of text when unlocked.

boot feature menu.jpg

I thought so when looking at that, but wasn’t sure if it maybe enabled a link back to the main CBS section below setup. I will unsuppress CBS option menu for you later tonight and then you can see if anything changes.
Did you already test enabling CBS here, set User at circled location?


I already tried setting that to user, I basically set everything related to the CBS menu to user. But nothing shows up in the bios settings.

Maybe there’s a section for the boot menu accessible in uefitool, so I can switch that out with the CBS menu. One time boot would still be accessible through the normal setup.
Another thing to try would be swapping the CBS menu with “sata information” , since that entry is linked in the normal setup.

@barracudax - Thanks, I just wanted to confirm you already set that as well. None of what you mentioned is needed, sorry I’ve been so far behind, I believe all that needs done is unsuppress CBS Menu via IFR hex edits.
I will leave this page open and get on this first thing tomorrow

*Edit - please test both these BIOS, check in all areas of the BIOS and see if you can now find any CBS options. Test smsp3CBS first, this is IFR edited only, other is same, plus additional changes in AMIBCP just in case those are needed once IFR is changed

I tried the first one, it doesn’t really work. The system does post and boot, but theres no video output during that. If i hit “del” during post it halts with a blackscreen, pressing esc + enter during that doesn’t bring me any further from that point.

@barracudax - That’s unexpected, how about the second one? Maybe I unsuppressed something that conflicted with an already enabled setting? Here, quick test with a single change in CBS only, unsuppressed Downcore control only.
Now, this one may not make CBS visible, but I’m interested if it boots properly into BIOS etc. or not. If not, something else is going on, maybe need to use a different tool to do the re-insert.

Same issue with that one. Every other Bios Version i tired to mod or stock works flawlessly.

I also found out that theres a Bios version for a dual socket supermicro mainboard, which has the CBS Menu activated as standard. I was unable to find it, i dont think it’s available for download anywhere since it’s the release version. You can see how it should look like in the Manual for the specific Bios version, found here at page 36 https://data2.manualslib.com/pdf6/129/12…accbb363c389bb8

@barracudax - thanks for testing report.
Mod with AMIBCP is not same as what I am doing, since AMIBCP only changes NVRAM it’s not ideal for this enablement since we’ve both already tried that in the proper manner without success. Thanks for the added info, will try to find that BIOS and snag it’s CBSSetup. The manual shows pinout on page 36, but I found it on page 70.
It’s enabled like AMIBCP normally would do via what I showed in the image at post #8 That is the ideal enabled way too, I will find that in assembly, but we’ll still need to find the other BIOS to get that CBSSetup since it’s all suppressed in your CBSSetup and a single change there causes non-boot.

I’ll try to find that BIOS today, never mind, found it at China!

Let me get into assembly and see where that main menu section CBS is being skipped in your BIOS, since it’s not being done via VNRAM/AMIBCP, magic string (I don’t think, please add an image of your BIOS so I can see all visible sections across top), or setup/IFR.
There’s a JZ/74 bypassing it somewhere in assembly, I will find it!

Don’t waste your time its version 1.1c, only version 1.0 (non b or c etc) has it. You can see the build date in the manual i linked. The newer manual on the supermicro page is for version 1.0c and has the pages removed. The manual i posted is a archived one for ver. 1.0.

The earliest Bios file i could find was 1.0c on a archived supermicro site but the CBS menu is also disabled there.

I also already dug through the Driver CD .iso and in the Bios folder there is only a .txt linking to the new download page :c

How do you know CBS Disabled on the BIOS you found?
Have you emailed them and asked to enable for you, sometimes they might send out special BIOS at customer request

It’s removed in the pictures from the newer manuals (with newer build date), you can see the Build Date and the upper row without the CBS menu. Also no server board manufacturer in their right mind would ship a mainboard with full blown overclocking options to the end consumer :stuck_out_tongue:

I can try it but i highly doubt that i’ll get an answer. The last time i wrote them about a BIOS for an older H8DGG Board i never got anything back.

I found a early Bios from a Gigabyte MZ31-AR0 with a “halfway” unlocked CBS Menu, the setup layout is pretty similar. Could this be somehow helpful?



I wonder why they wouldn’t want best possible user experience for their servers, it’s biggest market segment and you know aside from stability server user would want to push performance some when possible.
No, Gigabyte BIOS will be no help, it’s in your BIOS just turned off/skipped at assembly coding level. I think that’s why when I unsuppress any option in CBS menu it causes a fail due to the menu not being enabled causes the continued processing of the rest of the code to breakdown and loose it’s mind Just a guess

Although, maybe they have some security check, like a signature etc causing anything outside of NVRAM edited to cause a failed boot. Please test this, unsuppressed something in Setup module itself.

Did you see my edit on page one, about the BIOS image request? Pausing on the above test, to see that image, then I will make single edit to setup module and see if it’s a fail too, if so they may have some security in place like signature check etc.

Because of warranty issues i guess…

Heres what my standard Bios menu looks like, the Chipset option is missing for example.

I also noticed that i need a earlier Bios version, any other version results in an instant crash under heavy CPU load.
This one works


Yes, I suppose that is a good “Lame” excuse Thanks for the image. Yes, I see chipset is suppressed right at the beginning of the setup IFR, taking that outside the suppress may enable it but there’s only a few options there anyway, if not some string edit which probably is also needed for the CBS, just need to find it.