Updating MSI P55A-G55 with newer Intel RST OROM

Hi there. I’m a first time BIOS modder. The need comes about because the Intel RST Option ROM on my MSI P55A-G55 (from ~2009) doesn’t support 4TB drives.

I saved a copy of the current (and its the lastest) BIOS via the MFlash menu in the BIOS Setup to a USB key (FAT filesystem). Then I loaded that BIOS file into MMTool (Non-UEFI). It loaded OK, and I could identify the Intel RST Option ROM.
I downloaded ROM 8086-2822_11201527.bin.
I replaced the Option ROM with the downloaded file, then saved it.
Then I followed the instructions here Non-uefi.
After clearing CMOS, booting, setting the SATA controller to RAID mode & rebooting the PC stops with a flashing cursor after initialising the on-board Marvell controller. The PC is not hung, as I am able to soft-reboot (Ctrl-Alt-Del).
I tried with no drives connected, 1 drive connected, 6 drives connected. All the same.

Any ideas what is wrong?

I was able to reload the original v1.40 BIOS (after a bit of faffing around) and get it back to operational state with the 6-drive RAID array working (albeit with one failed drive replaced with a 4TB that isnt recognised properly by the Option ROM. The RST driver does recognise it - but wont let me repalce the failed 2TB drive with it).

Cheers for you help!
Geoff.

Hi.

Do I need to provide more details on what I’m trying to do, or the hardware involved, to get some help here? I have a 6 drive array running in a critical state with one drive failed that I want to repair ASAP. To do that I want to get 4TB drives supported by my MSI mobo - therefore the RST Option ROM upgrade attempt.

Does anyone know what might have gone wrong to cause the flashing cursor in top left-hand corner issue?
Is there a better recommended combination of BIOS & RST Option Rom for the P55 chipset?

Thanks for your helps.
G.

Could you post links to the vanilla BIOS you used for modding, the oROM(s) you wanna replace and your modded BIOS?

Yeah, sure. I’ll put them on OneDrive and post a link. Take me a few hours as I cant access the system with those three files on it at the moment

Cheers,
G.

@ clowg:

Hello Geoff,
welcome at Win-RAID Forum! I am sorry about my late reaction, somehow I missed your first post.
As far as I see you got already support by out Forum member e.v.o.

Regards
Dieter (alias Fernando)

I have uploaded the three files to OneDrive.

1) 8086-2822_11201527.bin is the UPDATED O-ROM I downloaded from this Forum
2) a7668ims.140 - Upgraded-11.20.1527.rom is the upgraded BIOS including 8086-2822_11201527.bin
3) A7668IMS.140.ori is the original v1.40 BIOS that I saved out of the BIOS M-Flash utility. (The BIOS downloads from MSI web site are not in a useable format)

Hope that helps.

Geoff.

@ clowg:

I have just checked your uploaded files.
As far as I could see the update from the Intel MSM ROM v8.9.0.1023 to the Intel RST ROM v11.2.0.1527 has been done perfectly.
Just a side note: Since you have inserted the original and not the TRIM in RAID0 modded variant of the Intel RAID ROM v11.2.0.1527, you will not get TRIM activity within an SSD RAID0 array.
Dont forget to rename the modded BIOS, before you are going to flash it.

Good luck!
Dieter

Thanks for looking Dieter.

Mmmmm… wonder why it never brings up the Intel RST Option ROM during the boot sequence then? It gets to the point where that should happen and just displays the flashing cursor in the top left hand corner of the screen. The computer doesn’t hang, as I can soft reboot OK.

Is it worth trying a different version of the updated option ROM?

Have you already tried to press CTRL+I while booting? If yes, what happens?

Enter the BIOS and look into the "BOOT" section. Maybe you have to change a setting there.

No.

No, I don’ think that I tried that.

Zitat von Fernando

Enter the BIOS and look into the “BOOT” section. Maybe you have to change a setting there.



I may not have been clear before. The PC stops booting at this point - with the flashing cursor top left hand corner. So while it is like this, it never gets to loading the BIOS Setup screens. I have to power down, disconnect all drives and then boot and pressing [Del] works - BIOS Setup loads.

EDIT by Fernando: Quoted part re-formatted (to make clear, from whom the text came) and blank lines removed (to save space)

Yes, this may worth a try.
It seems possible for me, that the currently inserted Intel RAID ROM cannot properly be loaded while starting the computer, because there is not enough space for it within the BIOS.
My suggestion: Flash a BIOS, which contains the TRIM in RAID modded Intel RST RAID ROM v10.1.0.1008. This ROM module is much smaller than all the newer ones.

Will the ‘TRIM in RAID modded Intel RST RAID ROM v10.1.0.1008’ O-ROM support 4TB drives?

No, only Intel RAID ROM modules from v10.5 up do support >2 TB sized RAID volumes.

EDIT:
When I have the needed time, I will do a look into your mainboard BIOS and check, whether there is a chance to get more space within it.

The problem is not the missing space, but rather no code to handle such large ROMs. This thread is an example of a fix, but limited to Asus for now.

@ lordkag:

Thanks for your clear statement.
Although you know much more than me about these BIOS details, I want to ask you: Are you really sure, that it may not be just a space problem in this case?
My thoughts:
AFAIK especially (or maybe only?) Intel X58 chipset mainboards with an Intel ICH10R Southbridge are affected by the issue to be unable to get any >100 KB sized Intel RAID ROM properly loaded (regardless what the user removes from the BIOS).
Note: The user clowg has an Intel P55 chipset mainboard MSI mainboard. Until now I have never heard about a similar issue with an Intel 5-Series chipset system.

A space problem would manifest only when trying to insert a module bigger than the remaining empty space, which MMTool will warn you either way. You can fill up to the last byte of empty space and the BIOS will work as before. But if the code is not able to handle such large ROMs, you can remove all the safe components and it will still blink while RAID is loading. The problem is not related to chipset version, but to the source code of AMIBIOS8, which was not updated at that time for large ROMs.

@ clowg:

According to lordkag (and he is obviously right) there is no chance for us to modify the mainboard BIOS of your MSI P55A-G55 in a way, that you can use any Intel RAID ROM module, which supports >2TB sized RAID volumes.
This is what I recommend to do:
1. Replace the currently inserted TRIM in RAID0 modded Intel RST RAID ROM v11.2.0.1527 by the TRIM in RAID modded Intel RST RAID ROM v10.1.0.1008. Disadvantage: >2B sized RAID volumes will not be supported.
2. Ask MSI for an updated BIOS for your mainboard with an inserted Intel RAID ROM v10.5.1.1070 or higher. After you got it, you can replace the module by the TRIM in RAID0 modded v11.2.0.1527 one and flash it into your mainboard BIOS chip.

Good luck!

OK. Thanks sooooo much for all your expert help guys. Really appreciate it.

I’ll see if I can get any communication with MSI going.

Cheers,
Geoff.

I have raised the case with MSI Support. Let’s see if we get a reply.

This is the reply I got (after pushing a couple of times):

MSI Tech Support:
"We are sorry that this motherboard is too old, we no longer keep maintaining for such motherboards. There won’t be bios update for the MB. We are deeply sorry for any inconvenience casued you."

So I suppose that’s the end of the line then. I’ll have to stick to 2TB drives in this PC :frowning:

G.