VAIO PRO 13 and NVME disk...

Hi all,

I have a vaio pro 13 (model SVP1321M2EB), which had an M2 SATA SSD, which is not stable (I get blue screens all the time).
I changed the SATA SSD with a PCIe M2 SSD (NVME). I used linux dd to clode everything from the old disk to the new one, but windows will not boot from the new NVME.

I tried to fix the boot procedure with an installation media usb created at another pc, with no luck.

I tried to reinstall windows, installation completed, but the installed fresh version of windows does not start.

I know that BIOS cannot see the NVME disk (it says "Hard Disk Drive": None). Is there a way to boot from this NVME?
(The laptop does not have any other disk slot)

By Bios mod (Attach a dump) and if possible to flash/programming it.
Or other methods without no changes in bios

NVMe Support for old Systems

Hi, thank you for the reply.

How can I get a dump of my bios? I am running the latest official bios for my model, available as an EXE here: www . sony . gr/electronics/support/svp-series-svp1321-series/svp1321m2e/downloads/Z0001381

After running the executable, it has extracted a set of files. In there there is a file named V710450B.CAP (about 8 MB). Is this the bios file?

I can still boot the laptop using windows installed on a usb drive, and I can run this bios update program from sony. It does not update my bios though, as it says it is the same version and there is no need for update.

Yes thats the bios file, a STOCK with empty data. A dump/backup will retain the original system data (UUIS, MAC, SN), this is a must.
The easy part is the mod itself, the hard part is the dump/flash operation, always with considerable risks, last resource an SPI Programmer.

Ive checked ur bios type, it can be done but its needs to be modified from a dump/flashed by Intel FPTtool, that its part of the Intel ME9.5 tools here: Intel (Converged Security) Management Engine: Drivers, Firmware and Tools

For this it is necessary to unlock the flash descriptor and gain access to bios regions: [Guide] Unlock Intel Flash Descriptor Read/Write Access Permissions for SPI Servicing
Other methods: [GUIDE] Grub Fix Intel FPT Error 280 or 368 - BIOS Lock Asus/Other Mod BIOS Flash or search in forum for RU unlock variables

After unlocked, the Intel FPTtool can be used to perform all the operations, until then if not unlocked FPT WILL fail.

EDIT: Seems that u dont read well or pay attention to the tips… of course it fails, read again.

Ok, it seems this the bios file. UBU tool reads it, and displays some info:

Scanning BIOS file V710450B.CAP.
Please wait…
BIOS platform - AMI Aptio 4

[EFI Drivers - Find and Extract]
Intel GOP GUID 5BBA83E6-F027-4CA7-BFD0-16358CC9E123
Intel GOP VBT GUID 878AC2CC-5343-46F2-B563-51F89DAF56BA

[OROM - Find and Extract]
VBIOS in GUID A062CF1F-8473-4AA3-8793-600BC4FFE9A8
OROM in GUID A062CF1F-8473-4AA3-8793-600BC4FFE9A8
Press any key to continue . . .

I have tried the fpt tool.

fpt -d spi.bin does not work.
fpt -me -d me.bin does not work.
fpt -desc - d desc.bin works

The flash device found is: W25Q64BV.

I tried to follow the steps in the first guide, section "D. Check Locked/Unlocked Status", and just reported the results. Yes, it is locked, but I should not have tried?

Right now I am trying the clover route, to get it to boot. It seems easier for now.

From the guide you provided, it seems I have to connect a pin either to GND, or to 3.3V during boot, which seems a bit difficult.

I followed the Clover-EFI guide ([Guide] NVMe-boot without modding your UEFI/BIOS (Clover-EFI bootloader method)), and I got mixed results.

Clover sees the NVME disk, it sees all partitions. I am able to start the boot loading process, it runs for a while (I can see the dots spinning) and freezes.
Once, windows managed to boot, I got a desktop, and installed some updates. I also installed WD Toolbox (my NVME is an WD SSD Blue M2 SN550 NVMe 1TB), run it, and updated its firmware.

However, on the next boot I got a BSOD, due to a page fault in Wdf01000.sys (which got installed by the WD Toolbox). I erased it from the Windows/System32/drivers, and now I am back into the spinning dots + computer freeze.

Any ideas?

(I have also ordered a cheap EEPROM programmer to read the bios chip, when it will arrive).

Here is the contents of the BIOS chip:…ead.bin.gz?dl=1

I have read it through the command (in linux):

flashrom --programmer ch341a_spi -r backup.bin
flashrom v1.2 on Linux 5.13.12-100.fc33.x86_64 (x86_64)
flashrom is free software, get the source code at

Using clock_gettime for delay loops (clk_id: 1, resolution: 1ns).
Found Winbond flash chip “W25Q64.V” (8192 kB, SPI) on ch341a_spi.
Reading flash… done.

Here is the NVMe mod of ur dump file, good luck.

EDIT: Clear the old OS installation, ignore NVMe not showing in bios, upon OS setup the destination drive (NVMe) should be present, CSM Off (PUERE UEFI) USB OS UEFI, its in the guide.

Thank you for that, I have followed the guide here: [HowTo] Get full NVMe support for all Systems with an AMI UEFI BIOS, so I got a modified bios, and then following the guide here: [Guide] Unlock Intel Flash Descriptor Read/Write Access Permissions for SPI Servicing I unlocked everything in the bios.

And I have used the programmer to program the chip directly (which worked - I was lucky with that). Then booted the PC, it seems to boot, but the NVME is still not visible as a disk in the BIOS.
(It says disk: None).

However, the bios seems to try to load the OS from the NVME, and I get a BSOD, again with a page fault on the WD NVME driver.

So, my mod works partially, the disk does not show up in the bios, but the BIOS does boot the OS in the disk.

Is your mod having any other fixes beyond adding the NVME NvmExpressDxe_4.ffs with AMI’s MMTool 4.50.0023?

(I suppose that now that I have unlocked permanently the BIOS, I can use the fpt tool to change the bios and I do not the programmer any more, whose clip is difficult to attach on the chip… :-))

Ok, your mod is exactly the same as my modded bios, minus the changes to completely unlock the bios.

Thank you,


And of course, re-installing windows removes all BSOD problems, but you need to re-install everything…