W7 RAID0 on Z390

Has anyone modded a driver to enable W7 to run in RAID0 with nvme drives on an Intel Z390 motherboard?


Alright, let me ask this; is it possible to mod a driver, perhaps IRST, to get RAID0 with nvme working on W7?

I have IRST 15.9 installed, but nothing higher (16.x, 17.x) will install.

I got the OS installed, but it will not boot; BSOD at loading screen.

Whom do you mean? There are only a very few Forum members, who are offering modded Intel RST drivers, and I doubt, that there is anyone, who has modded them for your specific purpose.

Are the Intel RAID0 array members NVMe SSDs or is the NVMe SSD outside of the RAID0 array? Which one is your system drive having drive C and the boot sector on it?
Which BSOD error code did you get?
Which version has the in-use Intel RAID EFI BIOS module?

The SSDs are (2) Samsung 960EVO M.2 nvme.

When in RAID0, the OS is installed on C:

I will try to get a screenshot with my phone, it flashes for only a second.

If you are asking what the UEFI IRST driver version is:

@Arctucas :
Thanks for your answers.
You can easily read the BSOD error code and take a screenshot, if you follow >this< advice before you get the expected BSOD.

BSOD is 0x7B.

Which makes sense, since the proper RAID controller driver is missing.

So, I do not expect someone to mod a driver just because I asked.

But, if someone has already managed to mod one, and would be willing to share, I would sure appreciate it.

Or, if someone is willing to coach me, I would give modding the driver myself a try.

Either way…

@Arctucas :
Your system doesn’t need a modded Intel RAID driver. It seems, that your RAID array running on an outdated OS cannot work together with the currently available v17 platform Intel Raid BIOS modules.
My advice is to either upgrade your OS to Win10 or to downgrade the Intel RAID BIOS modules to v15 platform ones.

Another idea: Run the attached SataID tool to find out the internal DeviceID of your Intel SATA RAID Controller (the external one is DEV:2822). Then tell us the result.

SataID tool compiled by Dufus.rar (44.2 KB)


OK, I believe you had a tutorial somewhere on how to mod the BIOS with a different OROM? Also, do you have a source for the 15.x OROM?

If you would have taken a look into the forum structure, you would have found them both (>here< and >here).

I ran the SATAID tool and it says "Intel Sata Controller not found".

@Arctucas :
Ok, this tool is old and doesn’t know about the option to create an NVMe RAID0 array by using an Intel SATA driver.
1. What is the exact name of the Intel RAID Controller, which is listed within the “Storage Controllers” section of the Device Manager?
2. What is the exact name and version of the Intel RST driver, which you had installed and which is currently running with the Intel RAID Controller?

  1. Intel(R) Chipset/SATA/PCIe RST Premium Controller
    2. Intel(R) Chipset/SATA/PCIe RST Premium Controller
    There are two files listed: C:\Windows\System32\DRIVERS\iaStorAC.sys and C:\Windows\System32\DRIVERS\iaStorF.sys

I ran the UBU tool and I got the OROM replaced, but the EFI is the same as the original.

Does that matter, or do I only need the OROM?

@Arctucas :
Yes, all Intel RST(e) driverpacks do contain 2 SYS files, the iaStorAC.sys is the real Intel AHCI/RAID driver, whereas the iaStorF.sys is an SCSI Filter driver.
Since the original v15 platform Intel RST(e) driver natively do not fully support Intel 300-Series chipset systems, it may be a try worth to replace the currently running Intel RST(e) driver v15.9.4.1041 by the newer v15.9.8.1050 one, which had been mod+signed by me. Contrary to the original driver it supports the internal DeviceID of all Intel RST Premium Controllers (inclusive the one of your mainboard). Don’t forget to import the Certificate before you are going to update the driver.

No, your NVMe RAID array needs the EFI RaidDriver to be bootable. Did you copy both files (RaidOrom.bin and RaidDriver.efi) into the RST subfolder of the UBU tool?

Tried to install the v15.9.8.1050, but I get an error: ‘Cannot write value IsSystemOnBattery to key (HKLM I presume)\System\CurrentControlSet\Services\iaStorAC\Parametrs\Device. Verify you have sufficient access to that key, or contact your support personnel.’

@Arctucas :
I have never seen or read about such error message.
How did you try to install the related driver? Before you install any other Intel RST driver, you have to uninstall the previously used Intel RST Software from within the "Add/remove Software" section of the Control Panel.
After having done that, you should reboot and then manually install the driver from within the "Storage Controllers" section of the Device Manager.

I ran the RST_x64.msi.

So, I uninstalled the previous driver manually, extracted the drivers from the .msi, and installed through Device Manager.

I now have the driver installed.

@Arctucas :

  1. Why don’t you follow my advices? You obviously have installed now the WHQL certified original Intel RST(e) driver v15.9.8.1050, which doesn’t fully support Intel 300-Series Chipset systems.
    I gave you the tip to install the mod+signed Intel RST(e) driver v15.9.8.1050, which I am offering >here< as “Universal 64bit Intel RST(e) AHCI+RAID driver v15.9.8.1050 mod+signed by me”. There is no *.msi file within that package.
  2. Intel RAID ROM and Intel EFI “RaidDriver” BIOS modules are completely different modules and are offered within different threads. >Here< is the thread, where you can find the Intel EFI RaidDriver modules.

I found the efi, my apologies for not searching thoroughly before posting.

I do not wish to disagree, but when I extract the “Universal 64bit Intel RST(e) AHCI+RAID driver v15.9.8.1050 mod+signed by me” downloaded from https://mega.nz/#!g04xjYZC!DeAXSsggvtg2N…4rAK8asyMLOGsEE, I get

rst extract.JPG