Which NVMe BIOS module is the best?

@SoniX and @Fernando

I have tried to open Asus x299 mainboard serie bios files, there are 8 of them currently. No matter which one I have tried, the info at MMTool displays no component names! Only a Dummy file explanation, nothing else, I have wished to see the nvmexpress file in their bios, but can not seen…

I wish to learn, there is a card named: Asus Hyper M.2 x16 Card, did anyone tried to install that card with insertion of latest NvmExpressDxe_4.ffs file to x79, z77, z87, x99 etc. chipset based mainboard bioses? Can it work?

Secondly, if works, how to arrange Raid 0 on it? Is that also possible?

Supported mainboards by Asus Hyper M.2 x16 Card:

EDIT by Fernando: This post and the related discussion has been cut out of >this< not matching thread and the title has been created by me.

Your post has nothing to do with the topic of this thread, because all X299 chipset mainboards natively do support NVMe.

The BIOS tools can only show information, which are layed down into the related BIOS modules. You should say “thankyou” to ASUS for their assistance.
By the way: The UBU tool finds the NVMe EFI modules.
Look here:

NVMe EFI file detection.png

NVMe EFI file detection Pic2.png


“Your post has nothing to do with the topic of this thread, because all X299 chipset mainboards natively do support NVMe.” Actually I was asking for old chipsets, but well done…

OK, I will check again with UBU!

With the help of GUID number UBU displays, I will extract with MMTool and see, thank you…

— o —

Extracted and seen, in Asus Rampage VI Bios Version 1401 (Currently Latest)
AMI NVMe GUID 634E8DB5-C432-43BE-A653-9CA2922CC458 → 24kb (NVMe Mass Storage Controller AMI NVMe BUS Driver)
NVMe Drv GUID 02A6DE33-3EA9-4C17-8EA2-5681CC7AFDED → 72kb (NVM Express Driver NVM Express Controller)

The one we know was:
NvmExpressDxe_4 → 21kb (NVM Express Driver NVM Express Controller)

So the latest NVMe Drv is now in size of 72kb, the one we know NvmExpressDxe_4 was 21kb! Can the latest one fit in older bioses and work? Probably no!

But I will try to fit first, but I don’t have a M.2 SSD, so can not verify works or not…

Note: Is it necessary to program both AMI NVMe and NVMe Drv? Currently, I don’t know!

— o —

Latest update: Both of the files fitted inside Asus Z9PE-D8 WS Bios Version 5802, probably it will fit to other bioses.

Result: I don’t have a M.2 SSD, so can not verify those 2 files works (performs better than NvmExpressDxe_4 driver) or not…

Request: If anyone can have an opportunity to test on, “an older chipset mainboard and having a M.2 SSD” (other than x299 chipset) tell us please!

@karakarga :
Can you please explain the sense of what you have done resp. what you are trying to do? I cannot see any.
This is my opinion:
1. The latest BIOSes of all mainboards with an Intel chipset from 9-Series or X299 up have native NVMe support and do not need any additional or replaced NVMe module.
2. The currently best NVMe BIOS module for older UEFI BIOSes without native NVMe support is the well approved NvmExpressDxe_4 one.
3. Only users with an NVMe SSD are able to test the differences between the various available NVMe modules.

I think the background for the question is:
The ASUS HYPER M.2 X16 CARD card with 4x M.2 Slots only supports ONE M.2 Slot on Mainstream Boards.
To use all FOUR M.2 slots at card there must be a special UEFI Support in Mainboard BIOS AND Intel VROC (Virtual Raid On Cpu) Support.
It works at AMD x399 Boards too, on the other hand it’s called bitfurcation.

So karakarga tried to find the special NVMe EFI drivers from supported boards to get that card to work.
But IMHO there must be hardware capability too to get it to run.

There are RUMORS that ASROCK has enabled bitfurcation on all ITX boards (z170,z270,x299,x370) to support risercard-splitters.
If this is true, then there should be EFI-drivers that bring the ASUS card on z170 boards to work.
But where to search this modification? In NVMe-Support? (Has nothing to do with normal risercard-splitters)

btw. bifurcation at a ASROCK z270 ITX only delivers x8/x4/x4… there is no 4x/4x/4x/4x that is needed for ASUS card to work with 4x M.2 SSDs.
Only three are recognized, and these can’t be RAIDed in BIOS over RST(e), only Windows-Software-Raid.

I "think" on Intel this is done in the ME settings, but I am not 100% sure. Give me a single Intel based board example and I will check the BIOS and see if that is where bifurcation is set.

ASrock z270M-ITX/ac
for example has this option to enable x8/x4/x4 at the PCIe3.0 x16 slot
Latest BIOS v2.60 (2018/3/29)

Thanks, I checked and yes that is controlled in Intel ME settings in the Flex I/O section of the board you linked above.
Sometimes also set in “Platform” module of the BIOS - [Guide] - How to Bifurcate a PCI-E slot